Skip to content

Commit

Permalink
media-gfx/asymptote: bump to 2.35
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
  • Loading branch information
Andrey Grozin committed Dec 23, 2015
1 parent 8e11337 commit 60f2c8e
Show file tree
Hide file tree
Showing 5 changed files with 280 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-gfx/asymptote/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST asymptote-2.32.src.tgz 1794495 SHA256 2035035e02774598312d5588da2685d20fb85a378ea2bbe48b825c5442b18fa5 SHA512 a0663f1768cb4340bb6e9224d4fbc6e2f8b41501b1f59793d84db2e0f99b9ff071d3dd8fa5c4715c1874f8ef1af713a54b27de37ff40d8ca042f0f48579a57f9 WHIRLPOOL 38a8aaa581acb07bcc7ac0c802222501acf77abaf609d5ae758d9b5668ac6b8b1343640259cc3948e62a39862404709ddb64b4bbd11bcf20dbb7ce29d4fc25d1
DIST asymptote-2.35.src.tgz 3348122 SHA256 ff3cf5b6a6a65fb1fe5b3ef1e94bf9cff8c3376f0cd7be0fdd7079c0fb46c285 SHA512 671ffdde35b444b645d5ebea016b7fec583c4cecee67cf1700c4b3e2c783abfcc45dfa964864c8bd66be32c13fb109c139346c0dbcfb1b597d4d387ad19c6c97 WHIRLPOOL 70cde1fb0821bd7efa27629183fe36871b45d7f352f5a1e529fbdf3c0d50c53059a7d4befcd4d87663da365733b43006ef1399b5541095d85068c63200e1ddf7
211 changes: 211 additions & 0 deletions media-gfx/asymptote/asymptote-2.35.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,211 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=( python2_7 )

inherit autotools elisp-common eutils latex-package multilib python-single-r1

DESCRIPTION="A vector graphics language that provides a framework for technical drawing"
HOMEPAGE="http://asymptote.sourceforge.net/"
SRC_URI="mirror://sourceforge/asymptote/${P}.src.tgz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE="+boehm-gc doc emacs examples fftw gsl +imagemagick latex offscreen +opengl python sigsegv svg vim-syntax X"

REQUIRED_USE="
${PYTHON_REQUIRED_USE}
offscreen? ( opengl )"

RDEPEND="
>=sys-libs/ncurses-5.4-r5:0=
>=sys-libs/readline-4.3-r5:0=
imagemagick? ( media-gfx/imagemagick[png] )
opengl? ( >=media-libs/mesa-8 )
offscreen? ( media-libs/mesa[osmesa] )
svg? ( app-text/dvisvgm )
sigsegv? ( dev-libs/libsigsegv )
boehm-gc? ( >=dev-libs/boehm-gc-7.0[cxx,threads] )
fftw? ( >=sci-libs/fftw-3.0.1 )
gsl? ( sci-libs/gsl )
python? ( ${PYTHON_DEPS} )
X? (
${PYTHON_DEPS}
x11-misc/xdg-utils
dev-python/pillow[tk,${PYTHON_USEDEP}]
)
latex? (
virtual/latex-base
>=dev-texlive/texlive-latexextra-2013
)
emacs? ( virtual/emacs )
vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )"
DEPEND="${RDEPEND}
doc? (
dev-lang/perl
media-gfx/imagemagick[png]
virtual/texi2dvi
virtual/latex-base
)"

TEXMF=/usr/share/texmf-site

pkg_setup() {
(use python || use X) && python-single-r1_pkg_setup
}

src_prepare() {
# Fixing sigsegv enabling
epatch "${FILESDIR}/${P}-configure-ac.patch"
einfo "Patching configure.ac"
sed -e "s:Datadir/doc/asymptote:Datadir/doc/${PF}:" \
-i configure.ac \
|| die "sed configure.ac failed"

# Changing pdf, ps, image viewers to xdg-open
epatch "${FILESDIR}/${P}-xdg-utils.patch"

# Bug #322473
epatch "${FILESDIR}/${P}-info.patch"

eautoreconf
}

src_configure() {
# for the CPPFLAGS see
# http://sourceforge.net/forum/forum.php?thread_id=1683277&forum_id=409349
econf \
CPPFLAGS=-DHAVE_SYS_TYPES_H \
CFLAGS="${CXXFLAGS}" \
--disable-gc-debug \
$(use_enable boehm-gc gc system) \
$(use_enable fftw) \
$(use_enable gsl) \
$(use_enable opengl gl) \
$(use_enable offscreen) \
$(use_with sigsegv)
}

src_compile() {
default

cd doc || die
emake asy.1
if use doc; then
# info
einfo "Making info"
emake ${PN}.info
cd FAQ || die
emake
cd .. || die
# pdf
einfo "Making pdf docs"
export VARTEXFONTS="${T}"/fonts
# see bug #260606
emake -j1 asymptote.pdf
emake CAD.pdf
fi
cd .. || die

if use emacs; then
einfo "Compiling emacs lisp files"
elisp-compile base/*.el
fi
}

src_install() {
# the program
dobin asy

# .asy files
insinto /usr/share/${PN}
doins base/*.asy

# documentation
dodoc BUGS ChangeLog README ReleaseNotes TODO
doman doc/asy.1

# X GUI
if use X; then
python_scriptinto /usr/share/${PN}/GUI
python_doscript GUI/*.py
dosym /usr/share/${PN}/GUI/xasy.py /usr/bin/xasy
doman doc/xasy.1x
fi

# examples
if use examples; then
insinto /usr/share/${PN}/examples
doins \
examples/*.asy \
examples/*.eps \
doc/*.asy \
doc/*.csv \
doc/*.dat \
doc/extra/*.asy
use X && doins GUI/*.asy

insinto /usr/share/${PN}/examples/animations
doins examples/animations/*.asy
fi

# LaTeX style
if use latex; then
cd doc || die
insinto "${TEXMF}"/tex/latex/${PN}
doins ${PN}.sty asycolors.sty
if use examples; then
insinto /usr/share/${PN}/examples
doins latexusage.tex
fi
cd .. || die
fi

# asymptote.py
use python && python_domodule base/${PN}.py

# emacs mode
if use emacs; then
elisp-install ${PN} base/*.el base/*.elc
elisp-site-file-install "${FILESDIR}"/64${PN}-gentoo.el
fi

# vim syntax
if use vim-syntax; then
insinto /usr/share/vim/vimfiles/syntax
doins base/asy.vim
insinto /usr/share/vim/vimfiles/ftdetect
doins "${FILESDIR}"/asy-ftd.vim
fi

# extra documentation
if use doc; then
cd doc || die
doinfo ${PN}.info*
cd FAQ || die
dodoc asy-faq.ascii
doinfo asy-faq.info
insinto /usr/share/doc/${PF}/html/FAQ
doins asy-faq.html/*
cd .. || die
insinto /usr/share/doc/${PF}
doins ${PN}.pdf CAD.pdf
fi
}

pkg_postinst() {
use latex && latex-package_rehash
use emacs && elisp-site-regen

elog 'Use the variable ASYMPTOTE_PSVIEWER to set the postscript viewer'
elog 'Use the variable ASYMPTOTE_PDFVIEWER to set the PDF viewer'
}

pkg_postrm() {
use latex && latex-package_rehash
use emacs && elisp-site-regen
}
32 changes: 32 additions & 0 deletions media-gfx/asymptote/files/asymptote-2.35-configure-ac.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,32 @@
Index: asymptote-2.35/configure.ac
===================================================================
--- asymptote-2.35.orig/configure.ac
+++ asymptote-2.35/configure.ac
@@ -158,7 +158,7 @@ if test "x$ac_cv_use_gc" != "xno" ; then
fi
CPPFLAGS_SAVE=$CPPFLAGS
CPPFLAGS=$CPPFLAGS" $INCL"
- AC_CHECK_HEADER(gc.h,
+ AC_CHECK_HEADER([gc/gc.h],
AC_CHECK_LIB([gc],[GC_malloc],[
LIBS=$LIBS"-lgc "
AC_MSG_NOTICE([enabling system $GCNAME])],[
@@ -232,7 +232,17 @@ AC_MSG_ERROR([*** Please install libm on
AC_CHECK_LIB([z], [deflate],,
AC_MSG_ERROR([*** Please install libz or zlib-devel on your system ***]))
AX_PTHREAD
-AC_CHECK_LIB([sigsegv], [stackoverflow_install_handler])
+
+AC_ARG_WITH(sigsegv,
+ [ --with-sigsegv use libsigsegv],
+ [with_sigsegv=$withval],
+ [with_sigsegv="no"])
+if test "$with_sigsegv" = "yes"; then
+AC_CHECK_HEADER([sigsegv.h],
+ AC_CHECK_LIB([sigsegv], [stackoverflow_install_handler]),
+ AC_MSG_NOTICE([*** Header file sigsegv.h not found ***]))
+fi
+
AC_CHECK_LIB([rt], [sched_yield])

AC_ARG_ENABLE(readline,
13 changes: 13 additions & 0 deletions media-gfx/asymptote/files/asymptote-2.35-info.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,13 @@
Index: asymptote-2.35/doc/asymptote.texi
===================================================================
--- asymptote-2.35.orig/doc/asymptote.texi
+++ asymptote-2.35/doc/asymptote.texi
@@ -21,7 +21,7 @@ file LICENSE in the top-level source dir

@dircategory Languages
@direntry
-* asymptote: (asymptote/asymptote). Vector graphics language.
+* asymptote: (asymptote). Vector graphics language.
@end direntry

@titlepage
23 changes: 23 additions & 0 deletions media-gfx/asymptote/files/asymptote-2.35-xdg-utils.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,23 @@
Index: asymptote-2.35/settings.cc
===================================================================
--- asymptote-2.35.orig/settings.cc
+++ asymptote-2.35/settings.cc
@@ -90,15 +90,15 @@ bool msdos=false;
string HOME="HOME";
string docdir=ASYMPTOTE_DOCDIR;
const char pathSeparator=':';
-string defaultPSViewer="gv";
+string defaultPSViewer="xdg-open";
#ifdef __APPLE__
string defaultPDFViewer="open";
#else
-string defaultPDFViewer="acroread";
+string defaultPDFViewer="xdg-open";
#endif
string defaultGhostscript="gs";
string defaultGhostscriptLibrary="/usr/lib/libgs.so";
-string defaultDisplay="display";
+string defaultDisplay="xdg-open";
string defaultAnimate="animate";
void queryRegistry() {}
const string dirsep="/";

0 comments on commit 60f2c8e

Please sign in to comment.