Skip to content

Commit

Permalink
mail-client/roundcube: 1.4.0 version bump
Browse files Browse the repository at this point in the history
 - Embrace upstream's complete-dist, which includes PEAR, etc
   dependancies as compsoser would have installed them.  We just seem
   like we cannot keep up with the needed dependency ebuilds.
 - Removes use flags which aren't needed due to complete-dist.
 - Adds ${MY_PV} which adjusts for gentoo vs upstream formatting of
   _rc1/_beta/etc.

Closes: https://bugs.gentoo.org/666718
Closes: gentoo#13662
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Philippe Chaintreuil <[email protected]>
Closes: gentoo#13662
Signed-off-by: Aaron W. Swenson <[email protected]>
  • Loading branch information
Philippe23 authored and titanofold committed Nov 17, 2019
1 parent ef589fb commit 6164535
Show file tree
Hide file tree
Showing 3 changed files with 93 additions and 0 deletions.
1 change: 1 addition & 0 deletions mail-client/roundcube/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST roundcubemail-1.3.10-complete.tar.gz 5495189 BLAKE2B d2b6d7ac28fc609ab3d7275019796c73859a4ecdbbe17018c8ed9d1c702a1563e59429bfb47d9878869d7948ed1051c4a9caaac0d83b26b0a88e293e31bb27d6 SHA512 8fffa16abda87d29081d1afedbf1d9e4862b8b1864785101d422e62048ca7f365c3708e8a76b4a37f716109230943bb9f03a5faa0cf3c3963fa5454207e00c49
DIST roundcubemail-1.3.8-complete.tar.gz 5534385 BLAKE2B 2f0cb528d0901d267c74d57baa18d1f057fdd2eb0f872f3cef1053847861998f8c6551fc17506ae365086ed1f86c3ee9e73a96adb2e43c6c32025e7afaf63710 SHA512 34dc9205cd93be6d6551086f4d22654dad7213b4b09000dc4def08357acdc634744ce1f560144a3d3b46e936258e90482e77fc4c691a55c205bcfdfe3745441e
DIST roundcubemail-1.3.9-complete.tar.gz 5521697 BLAKE2B 4689bb43ff02b99a9b2b06d6370a5dce0ec4eca4e4da2a74e33e77ec74ec14bf22b6bab415c8b5fde9bd76bfaed87f183a8979edb353da3ed947f9bfdb0ecb15 SHA512 42ae9b772272b3e82476beeeb0fc5a909fb07ed0bfbdb655627b1e31da1c292f67f5a305452de31b2d60fe5905bcacabd6874dea394a9b0fd66b7921d73500ac
DIST roundcubemail-1.4.0-complete.tar.gz 6997256 BLAKE2B b19a2d049512ceb53b3844f4680ed061044d2d142bef322c067b381e3be57ecb3181cac4f2492a162da1417fefb4028c36d34dae4bf9064c97568f681bd0c78b SHA512 274372793f1f3af761702f8972f6360f8c8e64a705ff96f1432f6a520d24c9ca0e8ccc3933f26433f1c864bd6c381066fc9eb48bf97e9497b4cbff855412d811
19 changes: 19 additions & 0 deletions mail-client/roundcube/files/POST-UPGRADE_complete.txt
Original file line number Diff line number Diff line change
@@ -0,0 +1,19 @@
Post-Upgrade Activities
-----------------------
1. Check .htaccess settings (some php settings could become required)
2. If you're using the built-in addressbook, run indexing script:
./bin/indexcontacts.sh.
3. When upgrading from version older than 0.6-beta you should make sure your
folder settings contain a namespace prefix if necessary. For example Courier
users should add “INBOX.” prefix to folder names in main configuration file.
4. Check system requirements in INSTALL file.
5. Update your database and configurations by running:
./bin/update.sh

SQLite database upgrade
-----------------------
Versions older than 0.9 were supporting SQLite v2 only. Newer versions require
database in v3 format. The best what you can do is to convert database file
to the new format using command line tools:

sqlite OLD.DB .dump | sqlite3 NEW.DB
73 changes: 73 additions & 0 deletions mail-client/roundcube/roundcube-1.4.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,73 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit webapp

MY_PN=${PN}mail
MY_PV=${PV/_/-}
MY_P=${MY_PN}-${MY_PV}

DESCRIPTION="A browser-based multilingual IMAP client with an application-like user interface"
HOMEPAGE="https://roundcube.net"
SRC_URI="https://github.com/${PN}/${MY_PN}/releases/download/${MY_PV}/${MY_P}-complete.tar.gz"

# roundcube is GPL-licensed, the rest of the licenses here are
# for bundled PEAR components, googiespell and utf8.class.php
LICENSE="GPL-3 BSD PHP-2.02 PHP-3 MIT public-domain"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"

IUSE="change-password enigma ldap mysql postgres sqlite ssl spell"
REQUIRED_USE="|| ( mysql postgres sqlite )"

# this function only sets DEPEND so we need to include that in RDEPEND
need_httpd_cgi

RDEPEND="
${DEPEND}
>=dev-lang/php-5.4.0[filter,gd,iconv,json,ldap?,pdo,postgres?,session,sqlite?,ssl?,unicode,xml]
virtual/httpd-php
change-password? (
dev-lang/php[sockets]
)
enigma? (
app-crypt/gnupg
)
mysql? (
|| (
dev-lang/php[mysql]
dev-lang/php[mysqli]
)
)
spell? ( dev-lang/php[curl,spell] )
"

S="${WORKDIR}/${MY_P}"

src_install() {
webapp_src_preinst

dodoc CHANGELOG INSTALL README.md UPGRADING

insinto "${MY_HTDOCSDIR}"
doins -r [[:lower:]]* SQL
doins .htaccess

webapp_serverowned "${MY_HTDOCSDIR}"/logs
webapp_serverowned "${MY_HTDOCSDIR}"/temp

webapp_configfile "${MY_HTDOCSDIR}"/config/defaults.inc.php
webapp_postupgrade_txt en "${FILESDIR}/POST-UPGRADE_complete.txt"

webapp_src_install
}

pkg_postinst() {
webapp_pkg_postinst

if [[ -n ${REPLACING_VERSIONS} ]]; then
elog "You can review the post-upgrade instructions at:"
elog "${EROOT%/}/usr/share/webapps/${PN}/${PV}/postupgrade-en.txt"
fi
}

0 comments on commit 6164535

Please sign in to comment.