Skip to content

Commit

Permalink
app-portage/eix: Bump to 0.34.12
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Jan 15, 2021
1 parent 7257fc1 commit 61f08e9
Show file tree
Hide file tree
Showing 2 changed files with 104 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-portage/eix/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST eix-0.34.11.tar.xz 629932 BLAKE2B 7b203a4763a880379e5bafe086f70aeca6ad508cd558cc53d53683d8ee4a85111ba9fdea9fa81cd9c3939dd01ea392876b2714257138fd40a2c6b124e0fdbc90 SHA512 518dee499ed27acd39ea4c26e7b94a1098408b1d8cf6bc593e5e4b06aa973ae664e155886681c1e90e4a89afe8b54e05f8bd08d6ace2a2e1559fa613e5a351e7
DIST eix-0.34.12.tar.xz 629704 BLAKE2B 22c3a93b47c607467321445704c8b4fe0f8b131081609709ebe5e2bd09d0ac08194938641ab44304e51d9dc4d473615625a9ca0de649767b6552c60d38974b75 SHA512 458a01b8ccb5fe4c7fbf9eb8368dbb0c63ac587e0452de4c3a58fadfc62aa8b404e509d6f24d20956bd6f04c00bfdfc95d6bf59287c5ea9e07091bea67f8c4e2
103 changes: 103 additions & 0 deletions app-portage/eix/eix-0.34.12.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,103 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit autotools bash-completion-r1 flag-o-matic tmpfiles

DESCRIPTION="Search and query ebuilds"
HOMEPAGE="https://github.com/vaeth/eix/"
SRC_URI="https://github.com/vaeth/eix/releases/download/v${PV}/${P}.tar.xz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="debug doc nls sqlite"

DEPEND="
nls? ( virtual/libintl )
sqlite? ( >=dev-db/sqlite-3:= )"
RDEPEND="${DEPEND}
>=app-shells/push-2.0-r1
>=app-shells/quoter-3.0_p2-r1"
BDEPEND="
app-arch/xz-utils
nls? ( sys-devel/gettext )"

pkg_setup() {
# remove stale cache file to prevent collisions
local old_cache=${EROOT}/var/cache/${PN}
if [[ -f ${old_cache} ]]; then
rm "${old_cache}" || die
fi
}

src_prepare() {
default
sed -i -e "s:/:${EPREFIX}/:" tmpfiles.d/eix.conf || die

sed -e "/eixf_source=/s:push.sh:cat \"${EPREFIX}/usr/share/push/push.sh\":" \
-e "/eixf_source=/s:quoter_pipe.sh:cat \"${EPREFIX}/usr/share/quoter/quoter_pipe.sh\":" \
-i src/eix-functions.sh.in || die
sed -e "s:'\$(bindir)/eix-functions.sh':cat \\\\\"${EPREFIX}/usr/share/eix/eix-functions\\\\\":" \
-i src/Makefile.am || die

eautoreconf
}

src_configure() {
local myconf=(
$(use_enable debug paranoic-asserts)
$(use_enable nls)
$(use_with doc extra-doc)
$(use_with sqlite)
--without-protobuf

# default configuration
$(use_with prefix always-accept-keywords)
--with-dep-default
--with-required-use-default

# paths
--with-portage-rootpath="${ROOTPATH}"
--with-eprefix-default="${EPREFIX}"

# build a single executable with symlinks
--disable-separate-binaries
--disable-separate-tools

# used purely to control/disrespect *FLAGS
--disable-debugging
--disable-new_dialect
--disable-optimization
--disable-strong-optimization
--disable-security
--disable-nopie-security
--disable-strong-security
)

econf "${myconf[@]}"
}

src_install() {
default
dobashcomp bash/eix
dotmpfiles tmpfiles.d/eix.conf

rm -r "${ED}"/usr/bin/eix-functions.sh || die
}

pkg_postinst() {
tmpfiles_process eix.conf

local obs=${EROOT}/var/cache/eix.previous
if [[ -f ${obs} ]]; then
ewarn "Found obsolete ${obs}, please remove it"
fi
}

pkg_postrm() {
if [[ ! -n ${REPLACED_BY_VERSION} ]]; then
rm -rf "${EROOT}/var/cache/${PN}" || die
fi
}

0 comments on commit 61f08e9

Please sign in to comment.