Skip to content

Commit

Permalink
dev-lang/swi-prolog: bump 7.7 development version
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.13, Repoman-2.3.3
  • Loading branch information
keriharris committed Dec 18, 2017
1 parent 1fde7ff commit 620809d
Show file tree
Hide file tree
Showing 2 changed files with 147 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-lang/swi-prolog/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -12,3 +12,4 @@ DIST swipl-7.6.3.tar.gz 16772590 BLAKE2B 644be801e290ec9d949a9b7462256a35e11cf9a
DIST swipl-7.7.2.tar.gz 16775518 BLAKE2B e29ffedfe0ca8c7f4e467fb506d8c17deadaecf867f3ab01dbce777d6b79186ab03ab81e416f0000d0ae423be6d29a3f8dc2492f82e59e9d2f8ad94617a152a8 SHA512 4db5fa3d44061e21fa6811d9b84b42cdc99d9fca4000c6d66fd37017be3bb138f2278a4685feb6698c8ecab643b865b5a015699889eb04aeabf233c5dfa106d7
DIST swipl-7.7.3.tar.gz 16779027 BLAKE2B f533eec9d75dd46b5cbe68b185d503d49aff96effa397648e61cf813bf0caa7bf50549d72301ec20b14fc42d25abd2cb566fe1b2b8b51a7e1c8e957db15fa084 SHA512 231bbbd12c7df4c0fd130ccda370cb8144b2e605895787aa83ff127f3ffa0c9bf016cca0c146ff8c3a42d9f0b32e4d7619f2f0eebbe37ec9e980c45c8ccffdc4
DIST swipl-7.7.4.tar.gz 16787657 BLAKE2B fc9842170b9d9f60cf2e9ba52f64c9d074aaf64c463f287c3bd16009962099371492470392b7e68f60ec90e352ede7977c5a63919ec8e938e20892d1d43c8a78 SHA512 e12598a8193e112ec077a577b9a4e3129ae8dda27e1654dc135fdb68fd6d35bb2cb97d6e0f4f22c49813482fd3caed0f884c2433c87e1c51d21ad439164df01b
DIST swipl-7.7.5.tar.gz 16790003 BLAKE2B 88a62337f04094f6d49d922e46130131b57960e8f816f63427cc8f2ad743feab3bb83ab2cb16a51eaee3a99f21c003308654b6d9c9dd4cede86079b5eac1fc94 SHA512 8b611ce39e5ae5592021ef2f8805810183178edeff8dffd74631843b04d57b0339f7028d2250255a9cf975b4c5afbd1e4dbf8978ab50964e77652c201f9a5880
146 changes: 146 additions & 0 deletions dev-lang/swi-prolog/swi-prolog-7.7.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,146 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5

inherit eutils flag-o-matic java-pkg-opt-2 multilib

PATCHSET_VER="0"

DESCRIPTION="free, small, and standard compliant Prolog compiler"
HOMEPAGE="http://www.swi-prolog.org/"
SRC_URI="http://www.swi-prolog.org/download/devel/src/swipl-${PV}.tar.gz"

LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE="archive berkdb debug doc +gmp hardened java +libedit libressl minimal odbc pcre readline ssl static-libs test uuid zlib X"

RDEPEND="sys-libs/ncurses:=
archive? ( app-arch/libarchive )
berkdb? ( >=sys-libs/db-4:= )
zlib? ( sys-libs/zlib )
odbc? ( dev-db/unixODBC )
pcre? ( dev-libs/libpcre )
readline? ( sys-libs/readline:= )
libedit? ( dev-libs/libedit )
gmp? ( dev-libs/gmp:0 )
ssl? (
!libressl? ( dev-libs/openssl:0 )
libressl? ( dev-libs/libressl )
)
java? ( >=virtual/jdk-1.7:= )
uuid? ( dev-libs/ossp-uuid )
X? (
virtual/jpeg:0
x11-libs/libX11
x11-libs/libXft
x11-libs/libXpm
x11-libs/libXt
x11-libs/libICE
x11-libs/libSM )"

DEPEND="${RDEPEND}
X? ( x11-proto/xproto )
java? ( test? ( =dev-java/junit-3.8* ) )"

S="${WORKDIR}/swipl-${PV}"

src_prepare() {
EPATCH_FORCE=yes
EPATCH_SUFFIX=patch
if [[ -d "${WORKDIR}"/${PV} ]] ; then
epatch "${WORKDIR}"/${PV}
fi

if ! use uuid; then
mv packages/clib/uuid.pl packages/clib/uuid.pl.unused || die
fi

# OSX/Intel ld doesn't like an archive without table of contents
sed -i -e 's/-cru/-scru/' packages/nlp/libstemmer_c/Makefile.pl || die
}

src_configure() {
append-flags -fno-strict-aliasing
use ppc && append-flags -mno-altivec
use hardened && append-flags -fno-unit-at-a-time
use debug && append-flags -DO_DEBUG

# ARCH is used in the configure script to figure out host and target
# specific stuff
export ARCH=${CHOST}

export CC_FOR_BUILD=$(tc-getBUILD_CC)

cd "${S}"/src || die
econf \
--libdir="${EPREFIX}"/usr/$(get_libdir) \
$(use_enable gmp) \
$(use_enable static-libs static) \
--enable-shared \
--enable-custom-flags COFLAGS="${CFLAGS}"

if ! use minimal ; then
local jpltestconf
if use java && use test ; then
jpltestconf="--with-junit=$(java-config --classpath junit)"
fi

cd "${S}/packages" || die
econf \
--libdir="${EPREFIX}"/usr/$(get_libdir) \
$(use_with archive) \
$(use_with berkdb bdb ) \
$(use_with java jpl) \
${jpltestconf} \
$(use_with libedit) \
$(use_with pcre) \
$(use_with odbc) \
$(use_with readline) \
$(use_with ssl) \
$(use_with X xpce) \
$(use_with zlib) \
COFLAGS='"${CFLAGS}"'
fi
}

src_compile() {
cd "${S}"/src || die
emake

if ! use minimal ; then
cd "${S}/packages" || die
emake
./report-failed || die "Cannot report failed packages"
fi
}

src_test() {
cd "${S}/src" || die
emake check

if ! use minimal ; then
unset DISPLAY
cd "${S}/packages" || die
emake \
USE_PUBLIC_NETWORK_TESTS=false \
USE_ODBC_TESTS=false \
check
./report-failed || die
fi
}

src_install() {
emake -C src DESTDIR="${D}" install

if ! use minimal ; then
emake -C packages DESTDIR="${D}" install
if use doc ; then
emake -C packages DESTDIR="${D}" html-install
fi
./packages/report-failed || die "Cannot report failed packages"
fi

dodoc ReleaseNotes/relnotes-5.10 INSTALL README.md VERSION
}

0 comments on commit 620809d

Please sign in to comment.