Skip to content

Commit

Permalink
dev-python/subprocess32: Add new package
Browse files Browse the repository at this point in the history
  • Loading branch information
flacjacket authored and mgorny committed Jun 3, 2017
1 parent 75f8d3f commit 62308fd
Show file tree
Hide file tree
Showing 4 changed files with 50 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/subprocess32/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST subprocess32-3.2.7.tar.gz 54240 SHA256 1e450a4a4c53bf197ad6402c564b9f7a53539385918ef8f12bdf430a61036590 SHA512 d897d6a48824991e2a63ea417ca15222f28c3a4117c9bba8cbb4eceabfba9769acce1166aafa7aee8a025d6ebe7e133ce0dd617f90cb07e11bdb73dc1e21dec6 WHIRLPOOL 41226d999895439a089a319e8b805468d1913ec098d5f92705076ae707efb59c8a92f56e1068927065c5c1060ad84388fbaaf575a6e5c4d12a2b2b1e588f3e0a
Original file line number Diff line number Diff line change
@@ -0,0 +1,14 @@
diff --git a/test_subprocess32.py b/test_subprocess32.py
index c312949..000f7d6 100644
--- a/test_subprocess32.py
+++ b/test_subprocess32.py
@@ -538,7 +538,8 @@ class ProcessTestCase(BaseTestCase):
[sys.executable, "-c",
'import os; '
'print([k for k in os.environ.keys() '
- ' if ("VERSIONER" not in k and "__CF" not in k)])'],
+ ' if ("VERSIONER" not in k and "__CF" not in k and '
+ ' "LD_PRELOAD" not in k and "SANDBOX_" not in k)])'],
stdout=subprocess.PIPE, env={})
try:
stdout, stderr = p.communicate()
12 changes: 12 additions & 0 deletions dev-python/subprocess32/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>[email protected]</email>
<name>Python</name>
</maintainer>
<upstream>
<remote-id type="pypi">subprocess32</remote-id>
<remote-id type="github">google/python-subprocess32</remote-id>
</upstream>
</pkgmetadata>
23 changes: 23 additions & 0 deletions dev-python/subprocess32/subprocess32-3.2.7.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,23 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python2_7 )

inherit distutils-r1

DESCRIPTION="A backport of the subprocess module from Python 3.2/3.3 for use on 2.x"
HOMEPAGE="https://github.com/google/python-subprocess32"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="PSF-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"

PATCHES=( "${FILESDIR}"/${P}-sandbox-test-fix.patch )

python_test() {
"${PYTHON}" test_subprocess32.py || die "Tests fail with ${EPYTHON}"
}

0 comments on commit 62308fd

Please sign in to comment.