forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-embedded/libftdi: Fix version in pkg-config file with USE=-doc
Signed-off-by: Sven Wegener <[email protected]>
- Loading branch information
Showing
2 changed files
with
39 additions
and
1 deletion.
There are no files selected for viewing
38 changes: 38 additions & 0 deletions
38
dev-embedded/libftdi/files/libftdi-0.20-cmake-version.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,38 @@ | ||
From e18b700743217e8c505e97762e0f66a4f6a90425 Mon Sep 17 00:00:00 2001 | ||
From: Maciej Grela <[email protected]> | ||
Date: Wed, 20 Jun 2012 23:08:50 +0200 | ||
Subject: [PATCH] Fix libftdi.pc file generation when building with | ||
-DDOCUMENTATION=OFF | ||
|
||
--- | ||
CMakeLists.txt | 5 +++-- | ||
1 file changed, 3 insertions(+), 2 deletions(-) | ||
|
||
diff --git a/CMakeLists.txt b/CMakeLists.txt | ||
index 4c43a48..07f8bb9 100644 | ||
--- a/CMakeLists.txt | ||
+++ b/CMakeLists.txt | ||
@@ -2,7 +2,9 @@ | ||
project(libftdi) | ||
set(MAJOR_VERSION 0) | ||
set(MINOR_VERSION 20) | ||
+set(PACKAGE libftdi) | ||
set(VERSION_STRING ${MAJOR_VERSION}.${MINOR_VERSION}) | ||
+set(VERSION ${VERSION_STRING}) | ||
SET(CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}") | ||
|
||
# CMake | ||
@@ -116,12 +118,11 @@ add_custom_target(dist | ||
|
||
option(DOCUMENTATION "Generate API documentation with Doxygen" ON) | ||
|
||
+ | ||
find_package(Doxygen) | ||
if(DOCUMENTATION AND DOXYGEN_FOUND) | ||
|
||
# Set variables | ||
- set(PACKAGE libftdi) | ||
- set(VERSION ${VERSION_STRING}) | ||
set(top_srcdir ${CMAKE_SOURCE_DIR}) | ||
|
||
# Find doxy config |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters