Skip to content

Commit

Permalink
app-misc/actkbd: use #!/sbin/openrc-run instead of #!/sbin/runscript
Browse files Browse the repository at this point in the history
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=573846

Package-Manager: portage-2.2.26
  • Loading branch information
austin987 committed Apr 26, 2016
1 parent 30d389b commit 6394191
Show file tree
Hide file tree
Showing 2 changed files with 51 additions and 2 deletions.
49 changes: 49 additions & 0 deletions app-misc/actkbd/actkbd-0.2.8-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,49 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit linux-info eutils toolchain-funcs

DESCRIPTION="A keyboard shortcut daemon"
HOMEPAGE="http://users.softlab.ece.ntua.gr/~thkala/projects/actkbd/"
SRC_URI="http://users.softlab.ece.ntua.gr/~thkala/projects/actkbd/files/${P}.tar.bz2"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""

DEPEND=""
RDEPEND=""

CONFIG_CHECK="~INPUT_EVDEV"

src_prepare() {
epatch "${FILESDIR}"/${PN}-0.2.7-amd64.patch
}

src_compile() {
emake CFLAGS="${CFLAGS}" CC="$(tc-getCC)"
}

src_install() {
dobin actkbd
dodoc AUTHORS ChangeLog FAQ README TODO
docinto samples
dodoc samples/actkbd.conf
newconfd "${FILESDIR}/${PN}.confd" ${PN}
newinitd "${FILESDIR}/${PN}.initd" ${PN}
}

pkg_postinst() {
elog
elog "System-wide configuration file is /etc/actkbd.conf."
elog "Use actkbd.conf from usr/share/doc/${PF}/samples as a template."
elog "You need to create the config and set right input device from"
elog "/dev/input/event* in /etc/conf.d/actkbd"
elog
elog "To obtain keycodes for pressed combinations/keys just run:"
elog " # actkbd -s -d /dev/input/event<MYDEVICENUMBER>"
}
4 changes: 2 additions & 2 deletions app-misc/actkbd/files/actkbd.initd
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
#!/sbin/runscript
# Copyright 1999-2013 Gentoo Foundation
#!/sbin/openrc-run
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand Down

0 comments on commit 6394191

Please sign in to comment.