Skip to content

Commit

Permalink
media-video/mkvtoolnix: add 57.0.0
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/792678
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed May 28, 2021
1 parent d34f96c commit 63c3ff1
Show file tree
Hide file tree
Showing 2 changed files with 132 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-video/mkvtoolnix/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -5,3 +5,4 @@ DIST mkvtoolnix-49.0.0.tar.xz 7493996 BLAKE2B 2f1266a3c4117b8369b361e92728d0b19a
DIST mkvtoolnix-50.0.0.tar.xz 7559852 BLAKE2B ffcc0c608915d32d20fc823208857bf54dc3d645d56d3b8b9f7e33b213ce5046b977b6f3de41d1b779d958d6ffc8578fe0cbac41d92d88bb4c779363739ee437 SHA512 ef0c6f4be768e32e3b0887c17d77f8441fd1b19294120c043dd9b2fdd9b76357bea721a156c3e99e0677d2e83dee92ea776df906347a0d44acbc2631b66c73ea
DIST mkvtoolnix-51.0.0.tar.xz 7569264 BLAKE2B c2af73c278e794739ccb7a8eb560c23e0f54643a67259c15d2e25346ac8d2b6ba65563ec6df7f7d5716be7bbee2d2c540e667b4aff7d7e6fed662c1bba54bf69 SHA512 2e91b039dbcab9afbad29c6c8e66ac305b2518319f68301a34a909fdffb02305025106368d4338abf148be5af4adfebab2eb1b5ccf0c9c0b0cef8f9e6e58a26e
DIST mkvtoolnix-56.1.0.tar.xz 7632872 BLAKE2B 805ddc9fadca4eba2ea4f3d8371f191c20ab6ca74c1564a216f1c001d272d038ee9622a562034b4584e118859a24cdcf36840e9e0bf7d5f2cc9893b91cf1c29b SHA512 7ee1c580c5b8824491652571f30559829700e50b1a74cf92affba77154c2756bd613cfd5776cdd180d1eaa888949ca898caac1bfadc690c68086fb136d41b2a6
DIST mkvtoolnix-57.0.0.tar.xz 7635780 BLAKE2B e0253dc0f48b0c98ee30590560daecbb7cef19e0f92f5baa4694c829c75f28146f7cde58a85a02575b314c2f94efc048003e51f8f6b29abeff2ca1a8d1f28a18 SHA512 583cd9148a361f0886a3e18f32597a980b5ca56d1bba95b36ca613ee291f2cb3d95a0c749a32e6fa480e8dc8f8375e2bd04a1c4b21fd15d8056d8bb2d6082b99
131 changes: 131 additions & 0 deletions media-video/mkvtoolnix/mkvtoolnix-57.0.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,131 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit autotools flag-o-matic toolchain-funcs multiprocessing qmake-utils xdg

if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://gitlab.com/mbunkus/mkvtoolnix.git"
EGIT_SUBMODULES=()
inherit git-r3
else
SRC_URI="https://mkvtoolnix.download/sources/${P}.tar.xz"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
fi

DESCRIPTION="Tools to create, alter, and inspect Matroska files"
HOMEPAGE="https://mkvtoolnix.download/ https://gitlab.com/mbunkus/mkvtoolnix"

LICENSE="GPL-2"
SLOT="0"
IUSE="dbus debug dvd nls pch qt5 test"
RESTRICT="!test? ( test )"

# check NEWS.md for build system changes entries for boost/libebml/libmatroska
# version requirement updates and other packaging info
RDEPEND="
>=dev-libs/boost-1.60:=
>=dev-libs/libebml-1.4.0:=
>=dev-libs/libfmt-6.1.0:=
dev-libs/libpcre2:=
dev-libs/pugixml:=
media-libs/flac:=
>=media-libs/libmatroska-1.6.3:=
media-libs/libogg:=
media-libs/libvorbis:=
sys-apps/file
sys-libs/zlib
dvd? ( media-libs/libdvdread:= )
qt5? (
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtnetwork:5
dev-qt/qtwidgets:5
dev-qt/qtconcurrent:5
dev-qt/qtmultimedia:5
app-text/cmark:0=
dbus? ( dev-qt/qtdbus:5 )
)
"
DEPEND="${RDEPEND}
dev-cpp/nlohmann_json
dev-libs/utfcpp
test? ( dev-cpp/gtest )
"
BDEPEND="
app-text/docbook-xsl-stylesheets
dev-libs/libxslt
dev-ruby/rake
virtual/pkgconfig
nls? (
sys-devel/gettext
app-text/po4a
)
"

PATCHES=( "${FILESDIR}"/mkvtoolnix-49.0.0-qt5dbus.patch
"${FILESDIR}"/mkvtoolnix-56.1.0-optlevel.patch )

src_prepare() {
xdg_src_prepare
if [[ ${PV} == *9999 ]]; then
./autogen.sh || die
fi

# https://bugs.gentoo.org/692018
sed -e 's/pandoc/diSaBlEd/' -i ac/pandoc.m4 || die

eautoreconf

# remove bundled libs
rm -r lib/{fmt,libebml,libmatroska,nlohmann-json,pugixml,utf8-cpp} || die
}

src_configure() {
# bug 692322, use system dev-libs/utfcpp
append-cppflags -I"${ESYSROOT}"/usr/include/utf8cpp

local myeconfargs=(
$(use_enable debug)
$(usex pch "" --disable-precompiled-headers)
$(use_enable dbus)
$(use_enable qt5 qt)
$(use_with dvd dvdread)
$(use_with nls gettext)
$(usex nls "" --with-po4a-translate=false)
--disable-update-check
--disable-optimization
--with-boost="${ESYSROOT}"/usr
--with-boost-libdir="${ESYSROOT}"/usr/$(get_libdir)
)

if use qt5 ; then
# ac/qt5.m4 finds default Qt version set by qtchooser, bug #532600
myeconfargs+=(
--with-moc=$(qt5_get_bindir)/moc
--with-uic=$(qt5_get_bindir)/uic
--with-rcc=$(qt5_get_bindir)/rcc
--with-qmake=$(qt5_get_bindir)/qmake
)
fi

econf "${myeconfargs[@]}"
}

src_compile() {
rake V=1 -j$(makeopts_jobs) || die
}

src_test() {
rake V=1 -j$(makeopts_jobs) tests:unit || die
rake V=1 -j$(makeopts_jobs) tests:run_unit || die
}

src_install() {
DESTDIR="${D}" rake -j$(makeopts_jobs) install || die

einstalldocs
dodoc NEWS.md
doman doc/man/*.1
}

0 comments on commit 63c3ff1

Please sign in to comment.