Skip to content

Commit

Permalink
dev-ruby/actionview: add 6.0.3.4
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.4, Repoman-3.0.1
Signed-off-by: Hans de Graaff <[email protected]>
  • Loading branch information
graaff committed Oct 8, 2020
1 parent f6696e9 commit 64538b1
Show file tree
Hide file tree
Showing 2 changed files with 68 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/actionview/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST rails-5.2.4.3.tgz 8824955 BLAKE2B 7db1bdda581e345713b796152c68e13911076c0af
DIST rails-5.2.4.4.tgz 8825200 BLAKE2B e56f828f46ef72a2ec59006f37410aa53ca33730452d74d8deefc3975a24940500a48864c18523fad1141e025192b8bfc0c050abc04a01a88333fc825640d4b9 SHA512 6ea50009f769e2e2e6df6cd31fb10e8a770c61f28496432cb7a30265f9064fa8e61c8a0c2569fa056baf31d273ab25cc8c9bd02523214a35e3bbd94e4db293e5
DIST rails-6.0.3.2.tgz 18568792 BLAKE2B 574d4b7da1bf0ff308ca1a64369c16e29396c8faddf741bc0f2b7d0c0761e440d64dade6ef67ba4923045c7eab1cd0689d45b6b26f3e3077020157a2b29fb17f SHA512 ea019bef7facc1b8b0d2f181da45d70456a895f2d57eb2410e4a06ba7bea0165dacc0f15fe5080150e4b4ef3c81dacee70b200468232da857fdf60def85b5aec
DIST rails-6.0.3.3.tgz 18569231 BLAKE2B 6e3e90433d655768a8d4da7824178e61bfeeb4645ae77f5e50c0e4859bcbad1f9cbc9391d3ab78ca15be096372abae1085e3e68ea9065cb76ec3c8fa0b12f50b SHA512 750a66613dce04058bb787479be2794b5e20879170640862d1ae3ac12faf3e2b6d7e9b536bdd1e94a2f4934f759228179c4e6f21dfccf6d7461fce9d9bd13892
DIST rails-6.0.3.4.tgz 18568864 BLAKE2B 8f554a25ce02e4752c1a964257836a5cb0a6c01c3453ff11cd8423a9153e90ab833a32cadfe939a34e094cefd553f5514abd7817004b464b054889ab7dc05b76 SHA512 147f76792ce2d2484071fe247c8f1541c9ca27dcc405ff7a780771e3436a9acf3d326bbfd7c6dceca510b6f4d5209ee0a0859867174b8291d796ffd519fa2ba9
67 changes: 67 additions & 0 deletions dev-ruby/actionview/actionview-6.0.3.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,67 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

USE_RUBY="ruby25 ruby26 ruby27"

RUBY_FAKEGEM_RECIPE_DOC="none"
RUBY_FAKEGEM_DOCDIR="doc"
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"

RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"

RUBY_FAKEGEM_EXTRAINSTALL="app"

RUBY_FAKEGEM_BINWRAP=""

inherit ruby-fakegem

DESCRIPTION="Simple, battle-tested conventions and helpers for building web pages"
HOMEPAGE="https://github.com/rails/rails/"
SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"

LICENSE="MIT"
SLOT="$(ver_cut 1-2)"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
IUSE=""

RUBY_S="rails-${PV}/${PN}"

ruby_add_rdepend "
~dev-ruby/activesupport-${PV}
>=dev-ruby/builder-3.1:* =dev-ruby/builder-3*:*
>=dev-ruby/erubi-1.4:0
>=dev-ruby/rails-html-sanitizer-1.2.0:1
dev-ruby/rails-dom-testing:2
"

ruby_add_bdepend "
test? (
dev-ruby/mocha
~dev-ruby/actionpack-${PV}
~dev-ruby/activemodel-${PV}
~dev-ruby/activerecord-${PV}
~dev-ruby/railties-${PV}
dev-ruby/sqlite3
)"

all_ruby_prepare() {
# Remove items from the common Gemfile that we don't need for this
# test run. This also requires handling some gemspecs.
sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|'mysql'\|journey\|rack-cache\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|redcarpet\|bcrypt\|uglifier\|mime-types\|minitest\|sprockets\|stackprof\)/ s:^:#:" \
-e '/:job/,/end/ s:^:#:' \
-e '/group :doc/,/^end/ s:^:#:' ../Gemfile || die
rm ../Gemfile.lock || die

# Avoid tests failing due to missing logger setup in activerecord,
# most likely related to test environment setup.
#rm -f test/activerecord/render_partial_with_record_identification_test.rb || die

# Fix loading of activerecord integration tests. This avoids loading
# activerecord twice and thus redefining constants leading to
# failures. Bug #719342
sed -e '/abstract_unit/arequire "active_record/fixtures"' \
-e '/defined/ s/FixtureSet/ActiveRecord::FixtureSet/' \
-i test/active_record_unit.rb || die
}

0 comments on commit 64538b1

Please sign in to comment.