Skip to content

Commit

Permalink
app-cdr/gcdemu: Bump to 3.1.0
Browse files Browse the repository at this point in the history
  • Loading branch information
mgorny committed Jun 16, 2017
1 parent c14de13 commit 64796d3
Show file tree
Hide file tree
Showing 2 changed files with 57 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-cdr/gcdemu/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST gcdemu-3.0.0.tar.bz2 45506 SHA256 1357a02720f05644929bae167fcc64dc58784f406aa426bcd806955cc458aad4 SHA512 c4d0d64638e0f7ecccfe11ab1a8527ba2002a5bbb382b2d4e8b58eaaa0a10140ee85b8d62ba93fe4ecdc2882301dfe62a08373dbb9e5404d5ddf7592cd5f0b7d WHIRLPOOL 18c8615ad6ae166c2111e7dd2f1c1d46b4128d99bb11a3f7e2f297c58dfff3e38ad981547703b13af940b0d1e6e3bccb7098180fde51458bfe34e3b19a66a465
DIST gcdemu-3.0.1.tar.bz2 45508 SHA256 d9d9cd4270803a021d55205fad2c76f65b51f5b509dde21c70475bb8577896b6 SHA512 e5a1905642c08145669c5eb9e65159d5a9a2fbcd1657edd28ae091ee1d02673e56bb7007df2a9f95863cae1a1ab01916bb43b4d10fe054d52507beabd7dd532f WHIRLPOOL e4fd9e009cdbad1f79e1a579339e27225fa76e132d136c9dba5e9388551d0a3c27448bf870d9f4344e99d47f1a7b0cce3c712e26569fc77f0206671cbbef2553
DIST gcdemu-3.1.0.tar.bz2 48036 SHA256 025c801300aa6ef13b9da484d8bd1ec2774c53e898942d44a43b4d27c0e0b666 SHA512 e3e0369cc443bc47befa52989cc2bc5d62e4c9462bb8de1c3dd8563e1240ba7f59fc8cc54aed2e96bdb23a5f6e2fa11ca36073dfa066409f097a1dca619866fc WHIRLPOOL 17da254190e933e7677d021f7f5a06bbeb19e82b05249e8189d4fcb441b95b33e8b86a996a5ef9603a771e53a40ced5f12ef81d29e48f58684b7a02e4a7cac3a
56 changes: 56 additions & 0 deletions app-cdr/gcdemu/gcdemu-3.1.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,56 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="6"

PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )

inherit cmake-utils gnome2-utils python-single-r1 xdg-utils

DESCRIPTION="Gtk+ GUI for controlling cdemu-daemon"
HOMEPAGE="http://cdemu.org/"
SRC_URI="mirror://sourceforge/cdemu/${P}.tar.bz2"

LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
REQUIRED_USE="${PYTHON_REQUIRED_USE}"

# librsvg for pixbuf-loader
RDEPEND="${PYTHON_DEPS}
app-cdr/cdemu-daemon:0/7
dev-python/pygobject:3[${PYTHON_USEDEP}]
gnome-base/librsvg:2
x11-libs/gdk-pixbuf[introspection]
x11-libs/gtk+:3[introspection]
x11-libs/libnotify[introspection]"
DEPEND="${COMMON_DEPEND}
dev-util/desktop-file-utils
>=dev-util/intltool-0.21
sys-devel/gettext
virtual/pkgconfig"

DOCS=( AUTHORS README )

src_prepare() {
python_fix_shebang src/gcdemu
eapply_user
}

src_configure() {
local mycmakeargs=( -DPOST_INSTALL_HOOKS=OFF )
cmake-utils_src_configure
}

pkg_postinst() {
xdg_desktop_database_update
GNOME2_ECLASS_GLIB_SCHEMAS=1 \
gnome2_schemas_update
}

pkg_postrm() {
xdg_desktop_database_update
GNOME2_ECLASS_GLIB_SCHEMAS=1 \
gnome2_schemas_update
}

0 comments on commit 64796d3

Please sign in to comment.