Skip to content

Commit

Permalink
app-text/glosung: Version bump
Browse files Browse the repository at this point in the history
Gentoo-Bug: 571144

Package-Manager: portage-2.2.26
  • Loading branch information
Chris Reffett committed Jan 23, 2016
1 parent abf8c7b commit 64db96c
Show file tree
Hide file tree
Showing 3 changed files with 106 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-text/glosung/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST glosung-3.6.2.tar.bz2 65089 SHA256 5b46cd776b51ea3ace6ef901512c4100e79ce5225f7d7cf910b69d930b7df4c9 SHA512 a9e16f9202092e6b73ca640787785fd6985ea1ba914260b783bf8f4b6ebbd6ed807cbdec5381059a2f905fae31b7aa844844ae2f9df0379c60e1251140760b11 WHIRLPOOL 91bb6e08f149430edb41b901072b5fe4993590f7ef173b99f313d857539e1be40dd00797b8623312da8a2909be7577d39b5804523e3b79bce00eccf919ee5a8c
DIST glosung-3.6.4.tar.bz2 71887 SHA256 1104e61f04d1e9be5e7aa0ede7e9f7a415974b97222164e410d9828a81b233cc SHA512 c4f51d2569e0c74bddf6806551c314a337d573cd10ab1b6dc04c735c24e4e3e679af35b5d7340d7917e6f4c1fd2b4dec283205c5f744b8c020630ba428738349 WHIRLPOOL fd1643b0e602a8f38a0c64566b798e922b117bed50f46183faca0ec11696fc0567903af0ed9becd0d189571777968c5606b234ac9f9cb7972fcf9b6f9cf392e6
61 changes: 61 additions & 0 deletions app-text/glosung/files/glosung-3.6.4-scons-respectflags.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,61 @@
diff -ruN glosung-3.6.4-original/SConstruct glosung-3.6.4/SConstruct
--- glosung-3.6.4-original/SConstruct 2016-01-22 22:11:00.785053522 -0500
+++ glosung-3.6.4/SConstruct 2016-01-22 22:14:04.434058592 -0500
@@ -17,6 +17,7 @@


import os
+import SCons.Util

version = '3.6.4'

@@ -32,14 +33,23 @@
(this option is only for packaging)''')

env = Environment (
- LINK = 'gcc',
- CC = 'gcc',
CPPPATH = '',
LINKFLAGS = '',
CCFLAGS = '',
ENV = os.environ,
TARFLAGS = '-c -j')

+if os.environ.has_key('CC'):
+ env['CC'] = os.environ['CC']
+if os.environ.has_key('CFLAGS'):
+ env['CCFLAGS'] += SCons.Util.CLVar(os.environ['CFLAGS'])
+if os.environ.has_key('CXX'):
+ env['CXX'] = os.environ['CXX']
+if os.environ.has_key('CXXFLAGS'):
+ env['CXXFLAGS'] += SCons.Util.CLVar(os.environ['CXXFLAGS'])
+if os.environ.has_key('LDFLAGS'):
+ env['LINKFLAGS'] += SCons.Util.CLVar(os.environ['LDFLAGS'])
+
if env['PLATFORM'] == 'win32':
prefix = ARGUMENTS.get ('PREFIX', '')
install_dir = ARGUMENTS.get ('DESTDIR', '')
@@ -57,21 +67,18 @@
VariantDir('build', 'src')

cpppath = ['#', '#build']
-ccflags = ['-O2', '-std=c99', '-Wall', '-g',
+ccflags = ['-std=c99',
# '-DLIBXML_STATIC',
'-DVERSION=\\"' + version + '\\"',
'-DGLOSUNG_DATA_DIR=\\"' + data_dir + '\\"',
'-DPACKAGE_PIXMAPS_DIR=\\"' + pixmap_dir + '\\"']

-linkflags = ['-L.']
+linkflags = []

if ARGUMENTS.get ('profile'):
ccflags.append ('-pg', '-fprofile-arcs')
linkflags.append ('-pg', '-fprofile-arcs', '-Wl,--export-dynamic')

-if env['PLATFORM'] != 'win32':
- linkflags.append ('-Wl,--as-needed')
-
#if not (ARGUMENTS.get ('dev')):
if (ARGUMENTS.get ('dev')):
ccflags += [
44 changes: 44 additions & 0 deletions app-text/glosung/glosung-3.6.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit eutils toolchain-funcs
DESCRIPTION="Watch word program for the GNOME2 desktop (watch word (german): losung)"
HOMEPAGE="http://www.godehardt.org/losung.html"
SRC_URI="mirror://sourceforge/glosung/${P}.tar.bz2"

LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

PATCHES=("${FILESDIR}/${PN}-3.6.4-scons-respectflags.patch")

RDEPEND="
dev-libs/libxml2
>=gnome-base/gconf-2.0:2
>=gnome-base/libgnome-2
>=gnome-base/libgnomeui-2
net-misc/curl
>=x11-libs/gtk+-2.10:2
"

DEPEND="${RDEPEND}
>=dev-util/scons-0.93
>=dev-util/intltool-0.22
>=sys-devel/gettext-0.10
virtual/pkgconfig
"

src_compile() {
tc-export CC
scons ${MAKEOPTS} || die "scons make died"
}

src_install() {
scons install DESTDIR="${D}" || die "scons install died"
#Ships with an ISO-8859 encoded .desktop file, which causes validation to fail, so ship a UTF-8 version
cp "${FILESDIR}/glosung.desktop" "${D}/usr/share/applications"
}

0 comments on commit 64db96c

Please sign in to comment.