Skip to content

Commit

Permalink
app-emulation/virtualbox: Fixed build against dev-libs/libressl.
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/673800
Package-Manager: Portage-2.3.56, Repoman-2.3.12
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Jan 16, 2019
1 parent 18fd4cd commit 64ef1ea
Show file tree
Hide file tree
Showing 3 changed files with 27 additions and 1 deletion.
24 changes: 24 additions & 0 deletions app-emulation/virtualbox/files/virtualbox-6.0.0-libressl.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,24 @@
https://bugs.gentoo.org/673800

diff --git a/src/VBox/Runtime/common/crypto/ssl-openssl.cpp b/src/VBox/Runtime/common/crypto/ssl-openssl.cpp
index e6d58b75..b2422983 100644
--- a/src/VBox/Runtime/common/crypto/ssl-openssl.cpp
+++ b/src/VBox/Runtime/common/crypto/ssl-openssl.cpp
@@ -271,7 +271,7 @@ RTDECL(int) RTCrSslCreateSessionForNativeSocket(RTCRSSL hSsl, RTHCINTPTR hNative
pSession->pBio = BIO_new_socket(hNativeSocket, BIO_NOCLOSE);
if (pSession->pBio)
{
-# if OPENSSL_VERSION_NUMBER >= 0x10100000
+# if (OPENSSL_VERSION_NUMBER >= 0x10100000 && !defined(LIBRESSL_VERSION_NUMBER)) || LIBRESSL_VERSION_NUMBER >= 0x2070000f
BIO_up_ref(pSession->pBio); /* our reference. */
# endif
SSL_set_bio(pSession->pSsl, pSession->pBio, pSession->pBio);
@@ -319,7 +319,7 @@ static int rtCrSslSessionDestroy(RTCRSSLSESSIONINT *pThis)
ASMAtomicWriteU32(&pThis->u32Magic, ~RTCRSSLSESSIONINT_MAGIC);
SSL_free(pThis->pSsl);
pThis->pSsl = NULL;
-# if OPENSSL_VERSION_NUMBER >= 0x10100000
+# if (OPENSSL_VERSION_NUMBER >= 0x10100000 && !defined(LIBRESSL_VERSION_NUMBER)) || LIBRESSL_VERSION_NUMBER >= 0x2070000f
BIO_free(pThis->pBio);
# endif
pThis->pBio = NULL;
3 changes: 2 additions & 1 deletion app-emulation/virtualbox/virtualbox-6.0.0.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2018 Gentoo Authors
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
Expand Down Expand Up @@ -195,6 +195,7 @@ src_prepare() {
fi

eapply "${WORKDIR}/patches"
eapply "${FILESDIR}"/${PN}-6.0.0-libressl.patch #673800

eapply_user
}
Expand Down
1 change: 1 addition & 0 deletions app-emulation/virtualbox/virtualbox-6.0.2.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -199,6 +199,7 @@ src_prepare() {

rm "${WORKDIR}/patches/010_virtualbox-5.2.12-qt511.patch" || die
eapply "${WORKDIR}/patches"
eapply "${FILESDIR}"/${PN}-6.0.0-libressl.patch #673800

eapply_user
}
Expand Down

0 comments on commit 64ef1ea

Please sign in to comment.