Skip to content

Commit

Permalink
dev-vcs/tortoisehg: 5.7 version bump
Browse files Browse the repository at this point in the history
Signed-off-by: Sergey Torokhov <[email protected]>
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
band-a-prend authored and juippis committed Feb 18, 2021
1 parent 7902297 commit 65228ea
Show file tree
Hide file tree
Showing 2 changed files with 63 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-vcs/tortoisehg/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST tortoisehg-5.5.1.tar.gz 8918085 BLAKE2B 33aef61d97a34f45b10b291eb3a71bc46b7
DIST tortoisehg-5.5.2.tar.gz 8919653 BLAKE2B 33842e0df31efd4302e210119b098b9debcf1003d320f4b0d5d0c29796ae2149a4aca70871e5f5a82c635fb8e5a12eb56572b23f691152860a386ff8dde20ade SHA512 eaac888f1171d3e4bc1de49ccb5cff550ea859d702b65548040072e3805b54c93d38afdd1a132f6340275172cb456461d76bb4e53a477d0a6e180ac85783a1f4
DIST tortoisehg-5.6.tar.gz 8920111 BLAKE2B 3779ea89f196bbf49c5efdc957983ff674d3c70c6ef04d758b2946851300bb115173a82d3ee9d0a51df6db51ed30acfa33abdfb2e6b3c08177d9dd5416741a10 SHA512 30013a776ea7e8b1167280350b64a993ebccbf82486f93164a1eaa42e98587719503c3dd939f9ea682d4302532216575ad7a20e9e2122315f63af7d002d08b03
DIST tortoisehg-5.6.1.tar.gz 8904309 BLAKE2B 7faad055560560eeeb776349889b45ae8b1de72614f794de9a124b6293a549eeeed1276e9b8308e077f2d171efdfa695660ad7010edd2d8ab2804f28687715b2 SHA512 21a410277469803e1af45103bc5c7196bc7128e66ab297399b98731c32caa517da46bd06389f08ad740b78c22e58244757dbad4207b71d5643b9d1284ed9c936
DIST tortoisehg-5.7.tar.gz 8910721 BLAKE2B ebca9526fc39c94c26f28db6dd70527c528308d9003fca0d9cfb61f984a9a5d80f910d68d0d1449221bbb4e040d2919ed34fec1e0aee4d9f5ed55cbcdb8ba714 SHA512 d143c9e83d3b0771ffd4a3bd9cd50e8bc169e5d29e33a0681c3234898a7566427f070ff3ad8668709b5e4d63be92fd700211dee03e98ff16c7c23fc0870c9e4c
62 changes: 62 additions & 0 deletions dev-vcs/tortoisehg/tortoisehg-5.7.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,62 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
PYTHON_COMPAT=( python3_{7,8} )

DISTUTILS_USE_SETUPTOOLS=no

inherit desktop distutils-r1 xdg-utils

if [[ ${PV} != *9999* ]]; then
KEYWORDS="~amd64 ~arm64 ~x86"
SRC_URI="https://www.mercurial-scm.org/release/tortoisehg/targz/${P}.tar.gz"
HG_DEPEND=">=dev-vcs/mercurial-5.6[${PYTHON_USEDEP}]
<dev-vcs/mercurial-5.8[${PYTHON_USEDEP}]"
else
inherit mercurial
EHG_REPO_URI="https://foss.heptapod.net/mercurial/tortoisehg/thg"
EHG_REVISION="stable"
HG_DEPEND=">=dev-vcs/mercurial-5.6[${PYTHON_USEDEP}]"
fi

DESCRIPTION="Set of graphical tools for Mercurial"
HOMEPAGE="https://tortoisehg.bitbucket.io/"

LICENSE="GPL-2"
SLOT="0"

RDEPEND="
${HG_DEPEND}
dev-python/iniparse[${PYTHON_USEDEP}]
dev-python/pygments[${PYTHON_USEDEP}]
dev-python/PyQt5[network,svg,${PYTHON_USEDEP}]
>=dev-python/qscintilla-python-2.9.4[qt5(+),${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}"

distutils_enable_sphinx doc/source

python_prepare_all() {
# Remove file that collides with >=mercurial-4.0 (bug #599266).
rm "${S}"/hgext3rd/__init__.py || die "can't remove /hgext3rd/__init__.py"
distutils-r1_python_prepare_all
}

python_install_all() {
distutils-r1_python_install_all
dodoc doc/ReadMe*.txt doc/TODO contrib/mergetools.rc
newicon -s scalable icons/scalable/apps/thg.svg thg_logo.svg
domenu contrib/thg.desktop
}

pkg_postinst() {
xdg_icon_cache_update
elog "When startup of ${PN} fails with an API version mismatch error"
elog "between dev-python/sip and dev-python/PyQt5 please rebuild"
elog "dev-python/qscintilla-python."
}

pkg_postrm() {
xdg_icon_cache_update
}

0 comments on commit 65228ea

Please sign in to comment.