Skip to content

Commit

Permalink
app-shells/dash: Bump to version 0.5.11.4
Browse files Browse the repository at this point in the history
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Jun 5, 2021
1 parent 4b07acf commit 65e9f29
Show file tree
Hide file tree
Showing 2 changed files with 62 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-shells/dash/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST dash-0.5.11.3.tar.gz 244507 BLAKE2B 06d4bd9f4c93e76ddf895f5a0ebca0c18d9554f5d4fd30a948eafc862db0f4cd523f623dad75969ddb5f510ac85d174f3b3aac3726f9d3ca8fbdb4377715b244 SHA512 ffe69b8de3586aba298d936168c329524e385252e12979aa1db28761e882048eb5a80673e93a2a2227f61b52fd8b56546b78c5db9c21a022072f536267f8bc20
DIST dash-0.5.11.4.tar.gz 240652 BLAKE2B 67c8c148448b8d95d09e5229953a88d52338d71c8e647977b92c12c56f19ffc62f24c775409231409bde9f7e5cf05f97f131a4967dd93fbdc16f539846467e61 SHA512 2344782b80f69b74d00eb153a918c2293eec2316825bf83c1eb4ff787eddf78f67ca3026cfce39b1db8d5ede69c7268951eec1e5711903f2306714b665f84160
61 changes: 61 additions & 0 deletions app-shells/dash/dash-0.5.11.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,61 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit flag-o-matic toolchain-funcs

DESCRIPTION="Debian Almquist Shell"
HOMEPAGE="http://gondor.apana.org.au/~herbert/dash/"
SRC_URI="http://gondor.apana.org.au/~herbert/dash/files/${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="libedit static"

BDEPEND="virtual/pkgconfig"
RDEPEND="!static? ( libedit? ( dev-libs/libedit ) )"
DEPEND="${RDEPEND}
libedit? ( static? ( dev-libs/libedit[static-libs] ) )"

PATCHES=(
"${FILESDIR}/${PN}-0.5.11.3-check_nflag_in_evaltree.patch" #754267
)

src_prepare() {
default

# Fix the invalid sort
sed -i -e 's/LC_COLLATE=C/LC_ALL=C/g' src/mkbuiltins

# Use pkg-config for libedit linkage
sed -i \
-e "/LIBS/s:-ledit:\`$(tc-getPKG_CONFIG) --libs libedit $(usex static --static '')\`:" \
configure || die
}

src_configure() {
if [[ ${CHOST} == *-solaris* ]] ; then
# don't redefine stat, open, dirent, etc. on Solaris
export ac_cv_func_stat64=yes
export ac_cv_func_open64=yes

# if your headers strictly adhere to POSIX, you'll need this too
[[ ${CHOST##*solaris2.} -le 10 ]] && append-cppflags -DNAME_MAX=255
fi
if [[ ${CHOST} == powerpc-*-darwin* ]] ; then
sed -i -e 's/= stpncpy(s, \([^,]\+\), \([0-9]\+\))/+= snprintf(s, \2, "%s", \1)/' \
src/jobs.c || die
fi
append-cppflags -DJOBS=$(usex libedit 1 0)
use static && append-ldflags -static
# Do not pass --enable-glob due to #443552.
local myeconfargs=(
CC_FOR_BUILD="$(tc-getBUILD_CC)"
--bindir="${EPREFIX}"/bin
--enable-fnmatch
$(use_with libedit)
)
econf "${myeconfargs[@]}"
}

0 comments on commit 65e9f29

Please sign in to comment.