Skip to content

Commit

Permalink
mate-base/mate-menus: remove unnecessary postinst
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Göktürk Yüksek <[email protected]>
  • Loading branch information
NP-Hardass authored and gktrk committed May 12, 2019
1 parent 29ae4dc commit 6659bf9
Showing 1 changed file with 44 additions and 0 deletions.
44 changes: 44 additions & 0 deletions mate-base/mate-menus/mate-menus-1.22.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

GNOME2_LA_PUNT="yes"

inherit mate

if [[ ${PV} != 9999 ]]; then
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
fi

DESCRIPTION="MATE menu system, implementing the F.D.O cross-desktop spec"
LICENSE="GPL-2 LGPL-2"
SLOT="0"

IUSE="debug +introspection"

COMMON_DEPEND=">=dev-libs/glib-2.50:2
virtual/libintl
introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )"

RDEPEND="${COMMON_DEPEND}"

DEPEND="${COMMON_DEPEND}
>=dev-util/intltool-0.40
sys-devel/gettext:*
virtual/pkgconfig:*"

src_configure() {
# Do NOT compile with --disable-debug/--enable-debug=no as it disables API
# usage checks.
mate_src_configure \
--enable-debug=$(usex debug yes minimum) \
$(use_enable introspection)
}

src_install() {
mate_src_install

exeinto /etc/X11/xinit/xinitrc.d/
doexe "${FILESDIR}/10-xdg-menu-mate"
}

0 comments on commit 6659bf9

Please sign in to comment.