forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-i18n/man-pages-de: Version bump. Proxied commit for Markus Oehme
Gentoo-Bug: 571288 Package-Manager: portage-2.2.26
- Loading branch information
Showing
2 changed files
with
51 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST manpages-de-1.10.tar.xz 1440524 SHA256 5966b553881ff670ed8c43759a1b570c287ba3ba0588c0b8c93328a0232afc7c SHA512 ab5c351e7bc4a40568d954c6c6e9999cb526ab1d20ee73bf1cc5ee6d9bbe0ab34ba557a849b5a386613a19235b70a20303046a5abd02101ddc9ac6fdef62059b WHIRLPOOL 47df53610c7304e4ab9c811665049a82ee0c9a065ddc1bb550189d61fff19e5642fd8cc5324f4ac82e50978edd86c01e1da0e02c23ddc7545c69debc411bd23b | ||
DIST manpages-de-1.7.tar.xz 1300384 SHA256 7bb014f4ffdc7a303791bb0ee672d901348babcb4c23002cecd3fc145831728a SHA512 d70f25daf10e233358b705c06a7c9e123fffc492429b4b9e1717c5db3a47d92fefb5e628fc75056306bc8bf0da7146aabd2c80a77cb50a430d2e11d6ce9712e0 WHIRLPOOL d8198220f4998e2550166a4b79434c4c1031c1e320b4b858dbf1468c1b1f19aa1d6a02816acd470191546dd5b08b4d1fff4fe612652866db932ee5b4e3dae33a | ||
DIST manpages-de-1.8.tar.xz 1345324 SHA256 e9d82b7bf41accd492b66b7ef2cbaefb5ce30c5ab2a2ad9ae1833424a8b93d6f SHA512 284be71610ddc11f578179f809ecaf2d92eb77b4ba1281ce21f3486e312c2888fc2d830967589702f0df6cee28da6adb4737b416cf8214001ddd14de0292ecd3 WHIRLPOOL e5d2b4afc6cd1b9231f8d837d7507a494b152c30687540bc128994f56e70e29ce9c3918621fb4ed3e62a1be21cddf4a324dd0379160b631885cbce064e0201e3 | ||
DIST manpages-de-1.9.tar.xz 1415628 SHA256 2c6c02ecd428b9b3cb9298ea2ef0b4972c6e569479e7d5a969d7086c2d7150e8 SHA512 5f01e817274490a90118c875a46f2b5767e62dacc8904f6a327a0883f96c895c7e07d1a76ad2947404552ed93abddd21c16ab51f6f1d076403003dfa0ec34426 WHIRLPOOL d68a1fc0bbf6751c78e0b1beac94d32e7b83539a5571d3546018fc896b70f919ac751c467823796cba0fd59867ca8bcf06a4214beebb004e94551e6545bf2c4e |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,50 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
|
||
inherit eutils autotools | ||
|
||
MY_P="${PN/-/}-${PV}" | ||
|
||
DESCRIPTION="A somewhat comprehensive collection of Linux german man page translations" | ||
HOMEPAGE="http://alioth.debian.org/projects/manpages-de/" | ||
SRC_URI="http://manpages-de.alioth.debian.org/downloads/${MY_P}.tar.xz" | ||
|
||
LICENSE="GPL-3+ man-pages GPL-2+ GPL-2 BSD" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86" | ||
IUSE="" | ||
|
||
RDEPEND="virtual/man" | ||
DEPEND="${RDEPEND} | ||
app-text/po4a" | ||
|
||
S=${WORKDIR}/${MY_P} | ||
|
||
src_prepare() { | ||
epatch "${FILESDIR}"/${PN}-1.3-bzip2.patch | ||
|
||
# Use the same compression as every other manpage | ||
local PORTAGE_COMPRESS_LOCAL=${PORTAGE_COMPRESS-bzip2} | ||
if [[ ${PORTAGE_COMPRESS+set} == "set" ]] ; then | ||
PORTAGE_COMPRESS_LOCAL="#" | ||
fi | ||
if [[ ${PORTAGE_COMPRESS_FLAGS+set} != "set" ]] ; then | ||
case ${PORTAGE_COMPRESS_LOCAL} in | ||
bzip2|gzip) local PORTAGE_COMPRESS_FLAGS_LOCAL="-9" | ||
;; | ||
esac | ||
fi | ||
sed -i -e "s/gzip --best/${PORTAGE_COMPRESS_LOCAL} ${PORTAGE_COMPRESS_FLAGS_LOCAL}/"\ | ||
po/man{1,2,3,4,5,6,7,8}/Makefile.in po/common.mk || die | ||
eautoreconf | ||
} | ||
|
||
src_compile() { :; } | ||
|
||
src_install() { | ||
emake mandir="${ED}"/usr/share/man install | ||
dodoc CHANGES README | ||
} |