Skip to content

Commit

Permalink
dev-lisp/c2ffi: Version bump to c2ffi-9.0.0
Browse files Browse the repository at this point in the history
Bump to use c2ffi-9.0.0 branch. At the moment, we need to
supply our own patch to get it building, though the issue
has been reported upstream and a pull request has been sent:

rpav/c2ffi#71
rpav/c2ffi#70

This commit additionally provides a snapshot build because live-only
packages are not allowed. Additionally, multi-slot has been removed.

Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Harald Judt <[email protected]>
Closes: gentoo#13620
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
hjudt authored and juippis committed Dec 13, 2019
1 parent 4144d4b commit 6737395
Show file tree
Hide file tree
Showing 4 changed files with 98 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-lisp/c2ffi/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST c2ffi-9.0.0.20191017.tar.gz 35139 BLAKE2B a080f2cf7743aab630365fd305c106ada0318afb24093508c7667d8d702ec8dfd95a0ea9f54233a3a4b4c9b411e2f4aba5dacf7b2f35f1545b7ca63e765a7e55 SHA512 7a4743d89f431fd9ca42808358bdde03bbd85fc56f3350fddc94532c524ce373989671e706fadeb03eb240a81fb3f418176169acbf3ccd0f0f0c595d0f697832
26 changes: 26 additions & 0 deletions dev-lisp/c2ffi/c2ffi-9.0.0.20191017.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,26 @@
# Copyright 2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit cmake-utils llvm

MY_COMMIT="15fda06de0bad97bf91f5590f7f24623eab2f580"

DESCRIPTION="Clang-based FFI wrapper generator for Common Lisp"
HOMEPAGE="https://github.com/rpav/c2ffi"
SRC_URI="https://github.com/rpav/c2ffi/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"

LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""

DEPEND="sys-devel/clang:9=
sys-devel/llvm:9=
"
RDEPEND="${DEPEND}"

S="${WORKDIR}/c2ffi-${MY_COMMIT}"

PATCHES=( "${FILESDIR}"/${PN}-9.0.0.20191017-fix-lib-location.patch )
22 changes: 22 additions & 0 deletions dev-lisp/c2ffi/c2ffi-9.0.0.9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,22 @@
# Copyright 2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit cmake-utils git-r3 llvm

DESCRIPTION="Clang-based FFI wrapper generator for Common Lisp"
HOMEPAGE="https://github.com/rpav/c2ffi"
EGIT_REPO_URI="https://github.com/rpav/c2ffi.git"
EGIT_BRANCH="llvm-9.0.0"

LICENSE="LGPL-2.1"
SLOT="0"
IUSE=""

DEPEND="sys-devel/clang:9=
sys-devel/llvm:9=
"
RDEPEND="${DEPEND}"

PATCHES=( "${FILESDIR}"/${PN}-9.0.0.20191017-fix-lib-location.patch )
49 changes: 49 additions & 0 deletions dev-lisp/c2ffi/files/c2ffi-9.0.0.20191017-fix-lib-location.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,49 @@
From 3a496f89064de85af04ce101918c2ec5cebf7846 Mon Sep 17 00:00:00 2001
From: Harald Judt <[email protected]>
Date: Fri, 8 Nov 2019 10:35:02 +0100
Subject: Fix CLANG and LLVM libraries not found

This commit gets the build working again here on Gentoo.

Adding LLVM_LIBRARY_DIRS fixes the CLANG libs not found error.

Adding llvm_map_components_to_libnames fixes LLMV not found error.
---
CMakeLists.txt | 12 ++++++++++--
1 file changed, 10 insertions(+), 2 deletions(-)

diff --git a/CMakeLists.txt b/CMakeLists.txt
index 99dbe4b..f93b9b3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -39,6 +39,15 @@ target_include_directories(c2ffi PUBLIC
${LLVM_INCLUDE_DIRS}
${SOURCE_ROOT}/src/include
)
+target_link_directories(c2ffi PUBLIC
+ ${LLVM_LIBRARY_DIRS}
+)
+message(STATUS "LLVM_LIBRARY_DIRS=${LLVM_LIBRARY_DIRS}")
+
+llvm_map_components_to_libnames(llvm_libs core support mcparser bitreader profiledata)
+
+message(STATUS "llvm_libs=${llvm_libs}")
+
target_link_libraries(c2ffi PUBLIC
clangFrontendTool
clangFrontend
@@ -64,10 +73,9 @@ target_link_libraries(c2ffi PUBLIC
clangIndex
clangToolingCore
clangTooling
+ ${llvm_libs}
)

-llvm_config(c2ffi USE_SHARED core support mcparser bitreader profiledata)
-
set(APP_BIN_DIR "${CMAKE_BINARY_DIR}/bin")
set_target_properties(c2ffi PROPERTIES
RUNTIME_OUTPUT_DIRECTORY "${APP_BIN_DIR}"
--
2.23.0

0 comments on commit 6737395

Please sign in to comment.