Skip to content

Commit

Permalink
net-fs/netatalk: Properly use REPLACING_VERSIONS
Browse files Browse the repository at this point in the history
Drop old

Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=589486

Package-Manager: portage-2.3.2
Signed-off-by: Justin Lecher <[email protected]>
  • Loading branch information
jlec committed Oct 23, 2016
1 parent 2111bd4 commit 67c8fba
Show file tree
Hide file tree
Showing 5 changed files with 154 additions and 321 deletions.
73 changes: 38 additions & 35 deletions net-fs/netatalk/netatalk-3.1.10.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -140,40 +140,43 @@ src_install() {
}

pkg_postinst() {
local fle
if [[ ${REPLACING_VERSIONS} < 3 ]]; then
for fle in afp_signature.conf afp_voluuid.conf; do
if [[ -f "${ROOT}"etc/netatalk/${fle} ]]; then
if [[ ! -f "${ROOT}"var/lib/netatalk/${fle} ]]; then
mv \
"${ROOT}"etc/netatalk/${fle} \
"${ROOT}"var/lib/netatalk/
local fle v
for v in ${REPLACING_VERSIONS}; do
if ! version_is_at_least 3 ${v}; then
for fle in afp_signature.conf afp_voluuid.conf; do
if [[ -f "${ROOT}"etc/netatalk/${fle} ]]; then
if [[ ! -f "${ROOT}"var/lib/netatalk/${fle} ]]; then
mv \
"${ROOT}"etc/netatalk/${fle} \
"${ROOT}"var/lib/netatalk/
fi
fi
fi
done

echo ""
elog "Starting from version 3.0 only uses a single init script again"
elog "Please update your runlevels accordingly"
echo ""
elog "Dependencies should be resolved automatically depending on settings"
elog "but please report issues with this on https://bugs.gentoo.org/ if"
elog "you find any."
echo ""
elog "Following config files are obsolete now:"
elog "afpd.conf, netatalk.conf, AppleVolumes.default and afp_ldap.conf"
elog "in favour of"
elog "/etc/afp.conf"
echo ""
elog "Please convert your existing configs before you restart your daemon"
echo ""
elog "The new AppleDouble default backend is appledouble = ea"
elog "Existing entries will be updated on access, but can do an offline"
elog "conversion with"
elog "dbd -ruve /path/to/Volume"
echo ""
elog "For general notes on the upgrade, please visit"
elog "http://netatalk.sourceforge.net/3.0/htmldocs/upgrade.html"
echo ""
fi
done

echo ""
elog "Starting from version 3.0 only uses a single init script again"
elog "Please update your runlevels accordingly"
echo ""
elog "Dependencies should be resolved automatically depending on settings"
elog "but please report issues with this on https://bugs.gentoo.org/ if"
elog "you find any."
echo ""
elog "Following config files are obsolete now:"
elog "afpd.conf, netatalk.conf, AppleVolumes.default and afp_ldap.conf"
elog "in favour of"
elog "/etc/afp.conf"
echo ""
elog "Please convert your existing configs before you restart your daemon"
echo ""
elog "The new AppleDouble default backend is appledouble = ea"
elog "Existing entries will be updated on access, but can do an offline"
elog "conversion with"
elog "dbd -ruve /path/to/Volume"
echo ""
elog "For general notes on the upgrade, please visit"
elog "http://netatalk.sourceforge.net/3.0/htmldocs/upgrade.html"
echo ""
break
fi
done
}
75 changes: 39 additions & 36 deletions net-fs/netatalk/netatalk-3.1.6.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand Down Expand Up @@ -140,40 +140,43 @@ src_install() {
}

pkg_postinst() {
local fle
if [[ ${REPLACING_VERSIONS} < 3 ]]; then
for fle in afp_signature.conf afp_voluuid.conf; do
if [[ -f "${ROOT}"etc/netatalk/${fle} ]]; then
if [[ ! -f "${ROOT}"var/lib/netatalk/${fle} ]]; then
mv \
"${ROOT}"etc/netatalk/${fle} \
"${ROOT}"var/lib/netatalk/
local fle v
for v in ${REPLACING_VERSIONS}; do
if ! version_is_at_least 3 ${v}; then
for fle in afp_signature.conf afp_voluuid.conf; do
if [[ -f "${ROOT}"etc/netatalk/${fle} ]]; then
if [[ ! -f "${ROOT}"var/lib/netatalk/${fle} ]]; then
mv \
"${ROOT}"etc/netatalk/${fle} \
"${ROOT}"var/lib/netatalk/
fi
fi
fi
done

echo ""
elog "Starting from version 3.0 only uses a single init script again"
elog "Please update your runlevels accordingly"
echo ""
elog "Dependencies should be resolved automatically depending on settings"
elog "but please report issues with this on https://bugs.gentoo.org/ if"
elog "you find any."
echo ""
elog "Following config files are obsolete now:"
elog "afpd.conf, netatalk.conf, AppleVolumes.default and afp_ldap.conf"
elog "in favour of"
elog "/etc/afp.conf"
echo ""
elog "Please convert your existing configs before you restart your daemon"
echo ""
elog "The new AppleDouble default backend is appledouble = ea"
elog "Existing entries will be updated on access, but can do an offline"
elog "conversion with"
elog "dbd -ruve /path/to/Volume"
echo ""
elog "For general notes on the upgrade, please visit"
elog "http://netatalk.sourceforge.net/3.0/htmldocs/upgrade.html"
echo ""
fi
done

echo ""
elog "Starting from version 3.0 only uses a single init script again"
elog "Please update your runlevels accordingly"
echo ""
elog "Dependencies should be resolved automatically depending on settings"
elog "but please report issues with this on https://bugs.gentoo.org/ if"
elog "you find any."
echo ""
elog "Following config files are obsolete now:"
elog "afpd.conf, netatalk.conf, AppleVolumes.default and afp_ldap.conf"
elog "in favour of"
elog "/etc/afp.conf"
echo ""
elog "Please convert your existing configs before you restart your daemon"
echo ""
elog "The new AppleDouble default backend is appledouble = ea"
elog "Existing entries will be updated on access, but can do an offline"
elog "conversion with"
elog "dbd -ruve /path/to/Volume"
echo ""
elog "For general notes on the upgrade, please visit"
elog "http://netatalk.sourceforge.net/3.0/htmldocs/upgrade.html"
echo ""
break
fi
done
}
75 changes: 39 additions & 36 deletions net-fs/netatalk/netatalk-3.1.7-r1.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand Down Expand Up @@ -141,40 +141,43 @@ src_install() {
}

pkg_postinst() {
local fle
if [[ ${REPLACING_VERSIONS} < 3 ]]; then
for fle in afp_signature.conf afp_voluuid.conf; do
if [[ -f "${ROOT}"etc/netatalk/${fle} ]]; then
if [[ ! -f "${ROOT}"var/lib/netatalk/${fle} ]]; then
mv \
"${ROOT}"etc/netatalk/${fle} \
"${ROOT}"var/lib/netatalk/
local fle v
for v in ${REPLACING_VERSIONS}; do
if ! version_is_at_least 3 ${v}; then
for fle in afp_signature.conf afp_voluuid.conf; do
if [[ -f "${ROOT}"etc/netatalk/${fle} ]]; then
if [[ ! -f "${ROOT}"var/lib/netatalk/${fle} ]]; then
mv \
"${ROOT}"etc/netatalk/${fle} \
"${ROOT}"var/lib/netatalk/
fi
fi
fi
done

echo ""
elog "Starting from version 3.0 only uses a single init script again"
elog "Please update your runlevels accordingly"
echo ""
elog "Dependencies should be resolved automatically depending on settings"
elog "but please report issues with this on https://bugs.gentoo.org/ if"
elog "you find any."
echo ""
elog "Following config files are obsolete now:"
elog "afpd.conf, netatalk.conf, AppleVolumes.default and afp_ldap.conf"
elog "in favour of"
elog "/etc/afp.conf"
echo ""
elog "Please convert your existing configs before you restart your daemon"
echo ""
elog "The new AppleDouble default backend is appledouble = ea"
elog "Existing entries will be updated on access, but can do an offline"
elog "conversion with"
elog "dbd -ruve /path/to/Volume"
echo ""
elog "For general notes on the upgrade, please visit"
elog "http://netatalk.sourceforge.net/3.0/htmldocs/upgrade.html"
echo ""
fi
done

echo ""
elog "Starting from version 3.0 only uses a single init script again"
elog "Please update your runlevels accordingly"
echo ""
elog "Dependencies should be resolved automatically depending on settings"
elog "but please report issues with this on https://bugs.gentoo.org/ if"
elog "you find any."
echo ""
elog "Following config files are obsolete now:"
elog "afpd.conf, netatalk.conf, AppleVolumes.default and afp_ldap.conf"
elog "in favour of"
elog "/etc/afp.conf"
echo ""
elog "Please convert your existing configs before you restart your daemon"
echo ""
elog "The new AppleDouble default backend is appledouble = ea"
elog "Existing entries will be updated on access, but can do an offline"
elog "conversion with"
elog "dbd -ruve /path/to/Volume"
echo ""
elog "For general notes on the upgrade, please visit"
elog "http://netatalk.sourceforge.net/3.0/htmldocs/upgrade.html"
echo ""
break
fi
done
}
Loading

0 comments on commit 67c8fba

Please sign in to comment.