Skip to content

Commit

Permalink
dev-python/oslo-messaging: 5.35.1 bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.44, Repoman-2.3.10
  • Loading branch information
prometheanfire committed Aug 9, 2018
1 parent 7b92713 commit 6874af6
Show file tree
Hide file tree
Showing 2 changed files with 55 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/oslo-messaging/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST oslo.messaging-5.35.0.tar.gz 325918 BLAKE2B d219a630b0958930bdd84693f43030c34c7beddce42f017f7f5ffddf5a6530c59b3eb29c5110a468a4606715f766a62abe3bd2d77c79ce025beafee6f322321e SHA512 30989d9418d30570ce212110b263ac7227acc3d6cd05305f7df23844253a81265c76e3fd93228e13a25399f5188431fa2f959a2c15639162abb5297a6fb7d4a1
DIST oslo.messaging-5.35.1.tar.gz 325408 BLAKE2B 89d16f094962d3603634a0925d0d2f569fcff0e59da7ca99462d0c0faad7fa47b0eade2b7c24b29585901c1d04bc6f4bf91ee04b4dfad0a63eb3100261e99e39 SHA512 0022b394812384d13189cab9eb99f45eae2a134e50a4d7ec2473ea35fc2712d2bf7c2b2dd71caa01a38dc47f7f9793130176cbd1afc041675ecb20282e1a653f
54 changes: 54 additions & 0 deletions dev-python/oslo-messaging/oslo-messaging-5.35.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,54 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
PYTHON_COMPAT=( python2_7 python3_{4,5,6} )

inherit distutils-r1

DESCRIPTION="Messaging API for RPC and notifications over different messaging transports"
HOMEPAGE="https://pypi.org/project/oslo.messaging/"
SRC_URI="mirror://pypi/${PN:0:1}/oslo.messaging/oslo.messaging-${PV}.tar.gz"
S="${WORKDIR}/oslo.messaging-${PV}"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"

CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
!~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
${CDEPEND}"
RDEPEND="
${CDEPEND}
>=dev-python/futurist-1.2.0[${PYTHON_USEDEP}]
>=dev-python/oslo-config-5.1.0[${PYTHON_USEDEP}]
>=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
>=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
>=dev-python/oslo-serialization-1.18.0[${PYTHON_USEDEP}]
!~dev-python/oslo-serialization-2.19.1[${PYTHON_USEDEP}]
>=dev-python/oslo-service-1.24.0[${PYTHON_USEDEP}]
!~dev-python/oslo-service-1.28.1[${PYTHON_USEDEP}]
>=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
>=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
>=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
>=dev-python/monotonic-0.6[${PYTHON_USEDEP}]
>=dev-python/six-1.10.0[${PYTHON_USEDEP}]
>=dev-python/cachetools-2.0.0[${PYTHON_USEDEP}]
>=dev-python/webob-1.7.1[${PYTHON_USEDEP}]
>=dev-python/pyyaml-3.10.0[${PYTHON_USEDEP}]
>=dev-python/py-amqp-2.1.1[${PYTHON_USEDEP}]
!~dev-python/py-amqp-2.1.4[${PYTHON_USEDEP}]
>=dev-python/kombu-4.0.0[${PYTHON_USEDEP}]
!~dev-python/kombu-4.0.2[${PYTHON_USEDEP}]
>=dev-python/pika-0.10.0[${PYTHON_USEDEP}]
>=dev-python/pika-pool-0.1.3[${PYTHON_USEDEP}]
virtual/python-futures[${PYTHON_USEDEP}]
>=dev-python/tenacity-3.2.1[${PYTHON_USEDEP}]
>=dev-python/oslo-middleware-3.31.0[${PYTHON_USEDEP}]
"

python_prepare_all() {
sed -i '/^hacking/d' test-requirements.txt || die
distutils-r1_python_prepare_all
}

0 comments on commit 6874af6

Please sign in to comment.