Skip to content

Commit

Permalink
dev-vcs/git-lfs: Version bump to 2.0.2
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.3, Repoman-2.3.2
  • Loading branch information
mudler committed Mar 31, 2017
1 parent 5141995 commit 68a2573
Show file tree
Hide file tree
Showing 2 changed files with 48 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-vcs/git-lfs/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST git-lfs-1.5.6.tar.gz 604139 SHA256 4efbc806cde1ea6ab4e1d61db3e1f6939796fd53bf6e9c94ac564610147ea5cd SHA512 f5f2da9ac44647335b25cad3104027cf5476e25ef9763019744123f9e1ef81edadbf5b08a146b8070487b32a18aa202c799f910aee6f2f0144ca411ad6d7cfd2 WHIRLPOOL 2f785abffc917a322fe59f4354980d5f565572620569b9b53e85ecdf84b5d7ad407ced8853c897814daa816cac6efd1f85c9098cae9fe48b179cd3381c5f840d
DIST git-lfs-2.0.1.tar.gz 629218 SHA256 62887214d90f0c1d1ba3da45112dffcc1d6bd1d1fabc9ef1e1ab85341242b11f SHA512 09653a59ac2d53964f3ccf07610918b1b37a782df5a984bd9680ff53361795f3c652081da78f26d6efb47fd8d8c6032933ce62f76ae9b48a977aace064d7773e WHIRLPOOL 1a8a808d83fa93a85a4ab9433e5e629d651954bc38c3dcd45e4539d7ec05897e7b712d9eeaf2c9ec0e2f5c65a3ccf17c193bdecef80b83c5d8b1cc872cd65055
DIST git-lfs-2.0.2.tar.gz 633786 SHA256 e266bdffa53e947ba1d0bf8944d73029384bad2ed05af92bc10918d07eec6b63 SHA512 af5d82234b4136e8d5637c93f7786b56ef552ff30bff01c444ac6fa9685785225148f7a8714c108691195a6f720a7c22f3bcaccaed080cffecf011d8480781ed WHIRLPOOL e7706e7fe949c5d65b2acb34c73e9c1605d0cbe2c607baee93f3c6c67b183f8eb70be2abca3b3c549a26947aef32ddb65742aca33614b519611acdb6dae74f0c
47 changes: 47 additions & 0 deletions dev-vcs/git-lfs/git-lfs-2.0.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,47 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

EGO_PN="github.com/git-lfs/${PN}"

if [[ ${PV} == *9999 ]]; then
inherit golang-vcs
else
SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
inherit golang-vcs-snapshot
fi

DESCRIPTION="command line extension and specification for managing large files with Git"
HOMEPAGE="https://git-lfs.github.com/"

LICENSE="MIT BSD BSD-2 BSD-4 Apache-2.0"
SLOT="0"
IUSE="+doc"

# since version 2.0.2 git-lfs uses time.Until that was introduced in golang >=1.8
# https://github.com/golang/go/commit/67ea710792eabdae1182e2bf4845f512136cccce
DEPEND=">=dev-lang/go-1.8:=
doc? ( app-text/ronn )"

RDEPEND="dev-vcs/git"

S="${WORKDIR}/${P}/src/${EGO_PN}"

src_compile() {
# can't use golang-build_src_compile for go generate
# and others steps executed by build.go
GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" \
go run script/*.go -cmd build || die "build failed"

if use doc; then
ronn docs/man/*.ronn || die "man building failed"
fi
}

src_install() {
dobin bin/git-lfs

use doc && doman docs/man/*.1
}

0 comments on commit 68a2573

Please sign in to comment.