Skip to content

Commit

Permalink
kde-frameworks/kxmlgui: revision bump to add Qt subslot operator
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0_rc1
  • Loading branch information
kensington committed Jun 19, 2016
1 parent 5847c79 commit 69c06e0
Showing 1 changed file with 43 additions and 0 deletions.
43 changes: 43 additions & 0 deletions kde-frameworks/kxmlgui/kxmlgui-5.23.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,43 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

VIRTUALX_REQUIRED="test"
inherit kde5

DESCRIPTION="Framework for managing menu and toolbar actions in an abstract way"
KEYWORDS="~amd64 ~arm ~x86"
LICENSE="LGPL-2+"
IUSE="attica"

# drop qtgui subslot operator when QT_MINIMAL >= 5.6.0
RDEPEND="
$(add_frameworks_dep kconfig)
$(add_frameworks_dep kconfigwidgets)
$(add_frameworks_dep kcoreaddons)
$(add_frameworks_dep kglobalaccel)
$(add_frameworks_dep ki18n)
$(add_frameworks_dep kiconthemes)
$(add_frameworks_dep kitemviews)
$(add_frameworks_dep ktextwidgets)
$(add_frameworks_dep kwidgetsaddons)
$(add_frameworks_dep kwindowsystem)
$(add_qt_dep qtdbus)
$(add_qt_dep qtgui '' '' '5=')
$(add_qt_dep qtnetwork 'ssl')
$(add_qt_dep qtprintsupport)
$(add_qt_dep qtwidgets)
$(add_qt_dep qtxml)
attica? ( $(add_frameworks_dep attica) )
"
DEPEND="${RDEPEND}"

src_configure() {
local mycmakeargs=(
$(cmake-utils_use_find_package attica KF5Attica)
)

kde5_src_configure
}

0 comments on commit 69c06e0

Please sign in to comment.