Skip to content

Commit

Permalink
dev-ruby/rack: add 2.0.1
Browse files Browse the repository at this point in the history
Drop alpha, hppa, ppc64, prefix keywords due to new dependency
on concurrent-ruby: bug 587756

Drop other keywords silently due to bug 562452

Package-Manager: portage-2.2.28
  • Loading branch information
graaff committed Jul 2, 2016
1 parent 2ca1391 commit 6a3bd7e
Show file tree
Hide file tree
Showing 3 changed files with 94 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/rack/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST rack-1.4.7.gem 204800 SHA256 fa06e970605808834fc7e5a8b9babd4871d7d4c23a4d9d61cb94cbd4c15de5e6 SHA512 26391faec30b12981413eb1f433bfc9be5d124689bc3ae6e32de7d544917f2330fa4f9255c6879632f2edae5a05a4198454b8fe1310bcdb3d2e0b8b336a20359 WHIRLPOOL 3e20db05b829b8dadbcc9dbeff6e883cdf1a8b175bd0af0f9c511ab2dc1111036b5815abe8c342120b74a0727a79b18b5966ec90d073404489b2045b134c527a
DIST rack-1.5.5.gem 216576 SHA256 4ae4a74f555008ecc541060515c37baa9e16f131538447a668c0bf52117c43b7 SHA512 7b8ea669c55fa94801aae20612076db702837194bc602c64bec1085836712806a081504b37e4c545bcccf0337e7afc0ad9dca3c1258260fde5f3ec505247056a WHIRLPOOL 3eed7d4befb678d1b89f2dd8f03b119ab23f6155c9fdc55d545a02a23fd718d436ca5ff880bec1a17ee7927183aed1d298cef97c1737cf88a315161a2f4ab37e
DIST rack-1.6.4.gem 228864 SHA256 455ec4545a54b40dae9937bc5f61ee0e32134191cc1ef9a7959a19ec4b127a25 SHA512 304a6ae21bfd38008fd7d147f82c44397f3a1d2e689bd01de689aedc6ea0e8784605207fd314bc796974edc5dfcab81636664ea2becb0489302999f99501d41a WHIRLPOOL e99b545a783eaf09bc1c0cf3b4abfafa3341980cfebf1840e25ab25d5801d911da7dfbb232f70df291b7494cc8f8c089fe8a654502aa808850801c02b1e481c6
DIST rack-2.0.1.gem 253952 SHA256 61f78033bf5b1cd0221549ecce7c7b73205d4634b0e63c66e1f295dcf3c26b14 SHA512 6ad5060ce56e279eb01029a699e86ee3f3cd6fe15b282f4c38ecc095d8bdf359dee0ff3fbe699bcac0e4765da7758fa5161f3c939da71a77eaf3fe3bc79bea1d WHIRLPOOL 34c292aab8997f1a1d8ee0a8c228ecc0b517996d3c610ff4e07a1d535d065447af949d4f534cc94c746e976c4d5d4e9b1277306758d4a030450f6b68e37e4ea1
48 changes: 48 additions & 0 deletions dev-ruby/rack/rack-1.6.4-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
USE_RUBY="ruby20 ruby21 ruby22 ruby23"

RUBY_FAKEGEM_DOCDIR="doc"
RUBY_FAKEGEM_EXTRADOC="HISTORY.md KNOWN-ISSUES README.rdoc SPEC"

RUBY_FAKEGEM_BINWRAP=""

inherit ruby-fakegem eutils versionator

DESCRIPTION="A modular Ruby webserver interface"
HOMEPAGE="https://rack.github.com/"

LICENSE="MIT"
SLOT="$(get_version_component_range 1-2)"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""

RUBY_PATCHES=( ${PN}-1.2.1-gentoo.patch ${PN}-1.6-rewindable-ruby23.patch )

ruby_add_rdepend "virtual/ruby-ssl"

# The gem has automagic dependencies over mongrel, ruby-openid,
# memcache-client, thin, mongrel and camping; not sure if we should
# make them dependencies at all.
ruby_add_bdepend "test? ( dev-ruby/bacon )"

# Block against versions in older slots that also try to install a binary.
RDEPEND="${RDEPEND} !<dev-ruby/rack-1.4.5-r1:1.4 !<dev-ruby/rack-1.5.2-r4:1.5"

all_ruby_prepare() {
# The build system tries to generate the ChangeLog from git. Create
# an empty file to avoid a needless dependency on git.
touch ChangeLog || die
}

each_ruby_test() {
# Since the Rakefile calls specrb directly rather than loading it, we
# cannot use it to launch the tests or only the currently-selected
# RUBY interpreter will be tested.
${RUBY} -S bacon -Ilib -w -a \
-q -t '^(?!Rack::Handler|Rack::Adapter|Rack::Session::Memcache|Rack::Server)' \
|| die "test failed for ${RUBY}"
}
45 changes: 45 additions & 0 deletions dev-ruby/rack/rack-2.0.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,45 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
USE_RUBY="ruby21 ruby22 ruby23"

RUBY_FAKEGEM_DOCDIR="doc"
RUBY_FAKEGEM_EXTRADOC="HISTORY.md README.rdoc SPEC"

inherit ruby-fakegem eutils versionator

DESCRIPTION="A modular Ruby webserver interface"
HOMEPAGE="https://rack.github.com/"

LICENSE="MIT"
SLOT="$(get_version_component_range 1-2)"
KEYWORDS="~amd64 ~arm"
IUSE=""

RUBY_PATCHES=( ${PN}-1.2.1-gentoo.patch )

ruby_add_rdepend "virtual/ruby-ssl"

ruby_add_bdepend "test? ( dev-ruby/minitest:5 dev-ruby/concurrent-ruby )"

# The gem has automagic dependencies over mongrel, ruby-openid,
# memcache-client, thin, mongrel and camping; not sure if we should
# make them dependencies at all.

# Block against versions in older slots that also try to install a binary.
RDEPEND="${RDEPEND} !<dev-ruby/rack-1.4.5-r1:1.4 !<dev-ruby/rack-1.5.2-r4:1.5 !<dev-ruby/rack-1.6.4-r2"

all_ruby_prepare() {
# The build system tries to generate the ChangeLog from git. Create
# an empty file to avoid a needless dependency on git.
touch ChangeLog || die

# Avoid development dependency
sed -i -e '/minitest-sprint/ s:^:#:' rack.gemspec || die
}

each_ruby_test() {
${RUBY} -Ilib:test:. -e "require 'test/gemloader.rb'; Dir['test/spec_*.rb'].each{|f| require f}" || die
}

0 comments on commit 6a3bd7e

Please sign in to comment.