Skip to content

Commit

Permalink
kde-apps: Ensure rebuild against >=kde-apps/akonadi-18.12.3-r1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Apr 3, 2019
1 parent 3ea5b36 commit 6ab66a4
Show file tree
Hide file tree
Showing 33 changed files with 1,768 additions and 0 deletions.
46 changes: 46 additions & 0 deletions kde-apps/akonadi-calendar/akonadi-calendar-18.12.3-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

KDE_TEST="true"
inherit kde5

DESCRIPTION="Library for akonadi calendar integration"
LICENSE="GPL-2+ LGPL-2.1+"
KEYWORDS="~amd64 ~arm64 ~x86"
IUSE=""

DEPEND="
$(add_frameworks_dep kcodecs)
$(add_frameworks_dep kconfig)
$(add_frameworks_dep kconfigwidgets)
$(add_frameworks_dep kcoreaddons)
$(add_frameworks_dep kdbusaddons)
$(add_frameworks_dep ki18n)
$(add_frameworks_dep kiconthemes)
$(add_frameworks_dep kio)
$(add_frameworks_dep kitemmodels)
$(add_frameworks_dep kjobwidgets)
$(add_frameworks_dep kwidgetsaddons)
$(add_frameworks_dep kwallet)
$(add_frameworks_dep kxmlgui)
$(add_kdeapps_dep akonadi '' 18.12.3-r1)
$(add_kdeapps_dep akonadi-contacts)
$(add_kdeapps_dep akonadi-mime)
$(add_kdeapps_dep kcalcore)
$(add_kdeapps_dep kcalutils)
$(add_kdeapps_dep kcontacts)
$(add_kdeapps_dep kidentitymanagement)
$(add_kdeapps_dep kmailtransport)
$(add_kdeapps_dep kmime)
$(add_qt_dep qtdbus)
$(add_qt_dep qtgui)
$(add_qt_dep qtwidgets)
"
RDEPEND="${DEPEND}
!kde-apps/kdepim-l10n
!<kde-apps/kdepim-runtime-18.03.80
"

RESTRICT+=" test"
42 changes: 42 additions & 0 deletions kde-apps/akonadi-contacts/akonadi-contacts-18.12.3-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,42 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

KDE_TEST="forceoptional"
inherit kde5

DESCRIPTION="Library for akonadi contact integration"
KEYWORDS="~amd64 ~arm64 ~x86"
LICENSE="GPL-2+"
IUSE=""

# some akonadi tests time out, that probably needs more work as it's ~700 tests
RESTRICT+=" test"

DEPEND="
$(add_frameworks_dep kcodecs)
$(add_frameworks_dep kcompletion)
$(add_frameworks_dep kconfig)
$(add_frameworks_dep kconfigwidgets)
$(add_frameworks_dep kcoreaddons)
$(add_frameworks_dep kdbusaddons)
$(add_frameworks_dep kiconthemes)
$(add_frameworks_dep ki18n)
$(add_frameworks_dep kio)
$(add_frameworks_dep kservice)
$(add_frameworks_dep ktextwidgets)
$(add_frameworks_dep kwidgetsaddons)
$(add_frameworks_dep kxmlgui)
$(add_frameworks_dep prison)
$(add_kdeapps_dep akonadi '' 18.12.3-r1)
$(add_kdeapps_dep kcontacts)
$(add_kdeapps_dep kmime)
$(add_qt_dep qtdbus)
$(add_qt_dep qtgui)
$(add_qt_dep qtwidgets)
"
RDEPEND="${DEPEND}
!kde-apps/kdepim-l10n
!<kde-apps/kdepim-runtime-18.03.80
"
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

KDE_HANDBOOK="forceoptional"
inherit kde5

DESCRIPTION="Assistant to import PIM data from other applications into Akonadi"
HOMEPAGE+=" https://userbase.kde.org/Kmail/Import_Options"
LICENSE="GPL-2+ handbook? ( FDL-1.2+ )"
KEYWORDS="~amd64 ~arm64 ~x86"
IUSE=""

DEPEND="
$(add_frameworks_dep kcompletion)
$(add_frameworks_dep kconfig)
$(add_frameworks_dep kcoreaddons)
$(add_frameworks_dep kcrash)
$(add_frameworks_dep kdbusaddons)
$(add_frameworks_dep ki18n)
$(add_frameworks_dep kwallet)
$(add_frameworks_dep kwidgetsaddons)
$(add_frameworks_dep kxmlgui)
$(add_kdeapps_dep akonadi '' 18.12.3-r1)
$(add_kdeapps_dep kcontacts)
$(add_kdeapps_dep kidentitymanagement)
$(add_kdeapps_dep kmailtransport)
$(add_kdeapps_dep libkdepim)
$(add_kdeapps_dep mailcommon)
$(add_kdeapps_dep mailimporter)
$(add_kdeapps_dep messagelib)
$(add_kdeapps_dep pimcommon)
$(add_qt_dep qtgui)
$(add_qt_dep qtwidgets)
$(add_qt_dep qtxml)
"
RDEPEND="${DEPEND}
!kde-apps/kdepim-l10n
!kde-apps/kmail:4
"
37 changes: 37 additions & 0 deletions kde-apps/akonadi-mime/akonadi-mime-18.12.3-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,37 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

KDE_TEST="true"
inherit kde5

DESCRIPTION="Library for akonadi mime types"
KEYWORDS="~amd64 ~arm64 ~x86"
LICENSE="GPL-2+ LGPL-2.1+"
IUSE=""

# some akonadi tests time out, that probably needs more work as it's ~700 tests
RESTRICT+=" test"

DEPEND="
$(add_frameworks_dep kconfig)
$(add_frameworks_dep kcoreaddons)
$(add_frameworks_dep kdbusaddons)
$(add_frameworks_dep ki18n)
$(add_frameworks_dep kio)
$(add_frameworks_dep kitemmodels)
$(add_frameworks_dep kwidgetsaddons)
$(add_frameworks_dep kxmlgui)
$(add_kdeapps_dep akonadi '' 18.12.3-r1)
$(add_kdeapps_dep kmime)
$(add_qt_dep qtdbus)
$(add_qt_dep qtgui)
$(add_qt_dep qtwidgets)
dev-libs/libxslt
"
RDEPEND="${DEPEND}
!kde-apps/kdepim-l10n
!<kde-apps/kdepim-runtime-18.03.80
!kde-apps/kdepimlibs:4
"
28 changes: 28 additions & 0 deletions kde-apps/akonadi-notes/akonadi-notes-18.12.3-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,28 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

KDE_TEST="true"
inherit kde5

DESCRIPTION="Library for akonadi notes integration"
KEYWORDS="~amd64 ~arm64 ~x86"
LICENSE="GPL-2+"
IUSE=""

# some akonadi tests time out, that probably needs more work as it's ~700 tests
RESTRICT+=" test"

COMMON_DEPEND="
$(add_frameworks_dep ki18n)
$(add_kdeapps_dep kmime)
$(add_qt_dep qtgui)
$(add_qt_dep qtxml)
"
DEPEND="${COMMON_DEPEND}
$(add_kdeapps_dep akonadi '' 18.12.3-r1)
"
RDEPEND="${COMMON_DEPEND}
!kde-apps/kdepim-l10n
"
47 changes: 47 additions & 0 deletions kde-apps/akonadi-search/akonadi-search-18.12.3-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,47 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

KDE_TEST="forceoptional"
VIRTUALX_REQUIRED="test"
inherit kde5

DESCRIPTION="Libraries and daemons to implement searching in Akonadi"
HOMEPAGE="https://cgit.kde.org/akonadi-search.git"
LICENSE="GPL-2+ LGPL-2.1+"
KEYWORDS="~amd64 ~arm64 ~x86"
IUSE=""

BDEPEND="
test? ( $(add_kdeapps_dep akonadi 'tools' 18.12.3-r1) )
"
COMMON_DEPEND="
$(add_frameworks_dep kcmutils)
$(add_frameworks_dep kcodecs)
$(add_frameworks_dep kconfig)
$(add_frameworks_dep kconfigwidgets)
$(add_frameworks_dep kcoreaddons)
$(add_frameworks_dep kdbusaddons)
$(add_frameworks_dep kio)
$(add_frameworks_dep ki18n)
$(add_frameworks_dep krunner)
$(add_kdeapps_dep akonadi '' 18.12.3-r1)
$(add_kdeapps_dep akonadi-mime)
$(add_kdeapps_dep kcalcore)
$(add_kdeapps_dep kcontacts)
$(add_kdeapps_dep kmime)
$(add_qt_dep qtdbus)
$(add_qt_dep qtgui)
$(add_qt_dep qtwidgets)
>=dev-libs/xapian-1.3:=[chert(+)]
"
DEPEND="${COMMON_DEPEND}
dev-libs/boost
test? ( $(add_kdeapps_dep akonadi 'mysql,postgres,sqlite' 18.12.3-r1) )
"
RDEPEND="${COMMON_DEPEND}
!kde-apps/kdepim-l10n
"

PATCHES=( "${FILESDIR}/${PN}-18.12.0-cmake.patch" )
45 changes: 45 additions & 0 deletions kde-apps/akonadiconsole/akonadiconsole-18.12.3-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,45 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

KDE_HANDBOOK="forceoptional" # FIXME: Check back for doc in release
inherit kde5

DESCRIPTION="Application for debugging Akonadi Resources"
LICENSE="GPL-2+ LGPL-2.1+ handbook? ( FDL-1.2+ )"
HOMEPAGE="https://www.kde.org/"
KEYWORDS="~amd64 ~arm64 ~x86"

IUSE=""

DEPEND="
$(add_frameworks_dep kcompletion)
$(add_frameworks_dep kconfig)
$(add_frameworks_dep kconfigwidgets)
$(add_frameworks_dep kcoreaddons)
$(add_frameworks_dep kcrash)
$(add_frameworks_dep kdbusaddons)
$(add_frameworks_dep kio)
$(add_frameworks_dep ki18n)
$(add_frameworks_dep kitemmodels)
$(add_frameworks_dep kitemviews)
$(add_frameworks_dep ktextwidgets)
$(add_frameworks_dep kwidgetsaddons)
$(add_frameworks_dep kxmlgui)
$(add_kdeapps_dep akonadi '' 18.12.3-r1)
$(add_kdeapps_dep akonadi-contacts)
$(add_kdeapps_dep akonadi-search)
$(add_kdeapps_dep calendarsupport)
$(add_kdeapps_dep kcalcore)
$(add_kdeapps_dep kcontacts)
$(add_kdeapps_dep kmime)
$(add_kdeapps_dep libkdepim)
$(add_kdeapps_dep messagelib)
$(add_qt_dep qtdbus)
$(add_qt_dep qtgui)
$(add_qt_dep qtsql)
$(add_qt_dep qtwidgets)
dev-libs/xapian:=
"
RDEPEND="${DEPEND}"
42 changes: 42 additions & 0 deletions kde-apps/calendarjanitor/calendarjanitor-18.12.3-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,42 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

KDE_HANDBOOK="forceoptional" # FIXME: Check back for doc in release
KDE_TEST="false"
KMNAME="akonadi-calendar-tools"
inherit kde5

DESCRIPTION="Tool to scan calendar data for buggy instances"
LICENSE="GPL-2+ handbook? ( FDL-1.2+ )"
KEYWORDS="~amd64 ~arm64 ~x86"

IUSE=""

DEPEND="
$(add_frameworks_dep kcoreaddons)
$(add_frameworks_dep kdelibs4support)
$(add_frameworks_dep ki18n)
$(add_kdeapps_dep akonadi '' 18.12.3-r1)
$(add_kdeapps_dep akonadi-calendar)
$(add_kdeapps_dep calendarsupport)
$(add_kdeapps_dep kcalcore)
$(add_qt_dep qtwidgets)
"
RDEPEND="${DEPEND}
!kde-apps/kdepim-l10n
"

src_prepare() {
kde5_src_prepare

cmake_comment_add_subdirectory doc konsolekalendar
sed -i -e "/console\.categories/ s/^/#DONT/" CMakeLists.txt || die

# delete colliding konsolekalendar translations
if [[ ${KDE_BUILD_TYPE} = release ]]; then
rm -f po/*/konsolekalendar.po || die
rm -rf po/*/docs/konsolekalendar || die
fi
}
44 changes: 44 additions & 0 deletions kde-apps/calendarsupport/calendarsupport-18.12.3-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

KDE_TEST="false"
inherit kde5

DESCRIPTION="Calendar support library"
LICENSE="GPL-2+ LGPL-2.1+"
KEYWORDS="~amd64 ~arm64 ~x86"
IUSE=""

DEPEND="
$(add_frameworks_dep kcodecs)
$(add_frameworks_dep kcompletion)
$(add_frameworks_dep kconfig)
$(add_frameworks_dep kcoreaddons)
$(add_frameworks_dep kguiaddons)
$(add_frameworks_dep kholidays)
$(add_frameworks_dep ki18n)
$(add_frameworks_dep kiconthemes)
$(add_frameworks_dep kio)
$(add_frameworks_dep kjobwidgets)
$(add_frameworks_dep kwidgetsaddons)
$(add_kdeapps_dep akonadi '' 18.12.3-r1)
$(add_kdeapps_dep akonadi-calendar)
$(add_kdeapps_dep akonadi-mime)
$(add_kdeapps_dep kcalcore)
$(add_kdeapps_dep kcalutils)
$(add_kdeapps_dep kdepim-apps-libs)
$(add_kdeapps_dep kidentitymanagement)
$(add_kdeapps_dep kmime)
$(add_kdeapps_dep libkdepim)
$(add_kdeapps_dep pimcommon)
$(add_qt_dep designer)
$(add_qt_dep qtgui)
$(add_qt_dep qtprintsupport)
$(add_qt_dep qtwidgets)
dev-libs/libical
"
RDEPEND="${DEPEND}
!kde-apps/kdepim-l10n
"
Loading

0 comments on commit 6ab66a4

Please sign in to comment.