Skip to content

Commit

Permalink
dev-libs/libzia: Version bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.30, Repoman-3.0.3
Signed-off-by: Thomas Beierlein <[email protected]>
  • Loading branch information
dl1jbe committed Dec 23, 2021
1 parent a804c3a commit 6b42e83
Show file tree
Hide file tree
Showing 2 changed files with 49 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/libzia/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST libzia-4.30.tar.gz 633287 BLAKE2B 7ca2fa4eb4e887e77658dc66b455ab830da31634a121d2fc58ec4e038a62d09d2c392ca70dbe7df3740592d82e9861086f398d82fba1af8e4d6066c395dca3fd SHA512 ba04206427c6bfd63c4799e2728fd5487a75757a42281daf87c8aee87d3c685e5fa60a0c77409fa774e4fddaaa3336f96bce002e88e6ad54f9af2c2cc939b9fa
DIST libzia-4.32.tar.gz 633444 BLAKE2B 60fbc85297b06e109f6c989798b6c5629d6f2d861b52388b134f896ee5232f75dc362fd847fd557d4aacced1c2264554c2861c9af7acfbb1e6837d9348aac30e SHA512 e426626d54c97dbce88e11eaefcee84a4e0a23e17a196f46ed4319a22d0f55bf9524c542bd4d41c376b26b51553d4cf7e0d994125cb2321549620f4b4aea5912
DIST libzia-4.34.tar.gz 636023 BLAKE2B c521047f5675b93acb4d04d015ff79e1b292cc71218080c2c56452c4dcbb55adb64295cfc935982e12d311c6fa4419388d4a250c4b08e9c30d8f0446adbe49b8 SHA512 edc62d771ef966524cac969e1f3b1f7b4b8960155887b6f1b22894fc3dcc3cc876e673fdec7a6fd2a312c2a39e181a5e4c0fe548ab828b2d4453be697b0afe08
48 changes: 48 additions & 0 deletions dev-libs/libzia/libzia-4.34.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit autotools

DESCRIPTION="Platform abstraction code for tucnak package"
HOMEPAGE="http://tucnak.nagano.cz"
SRC_URI="http://tucnak.nagano.cz/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="ftdi"

RDEPEND="dev-libs/glib:2
x11-libs/gtk+:2
media-libs/libsdl
media-libs/libpng:0
ftdi? ( dev-embedded/libftdi:1 )"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"

MAKEOPTS+=" -j1"

src_prepare() {
eapply_user
sed -i -e "s/docsdir/#docsdir/g" \
-e "s/docs_/#docs_/g" Makefile.am || die

# Fix QA-Warning "QA Notice: pkg-config files with wrong LDFLAGS detected"
sed -i -e 's/@LDFLAGS@//' libzia.pc.in || die

eautoreconf
}

src_configure() {
econf \
$(use_with ftdi) --with-sdl \
--with-png --without-bfd \
--disable-static
}

src_install() {
emake DESTDIR="${D}" install
find "${D}" -name '*.la' -type f -delete || die
}

0 comments on commit 6b42e83

Please sign in to comment.