forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <[email protected]>
- Loading branch information
Showing
2 changed files
with
31 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST ScriptTest-1.2.tar.gz 7208 SHA256 158c34cfa736288c33177588572c2bb3372b836eb4c90b05222911b4ff976942 SHA512 0dc09e6af5554f38aca6ee45b9afad2fa4c1c53a4d3c43edff95bbd6ea8d57e94bf6b7bdcfd26afff6bf2b10690795bd2816013801911f726c67e8171546cad2 WHIRLPOOL 2d23a9fec63c34bd6cf4a06fa01167a9fc05017950fa05bf39a14b5f44393ca38b11d4c7b6c8285ba49cd1a535520ebd83901fadc41497ce7513899356d935d3 | ||
DIST scripttest-1.3.tar.gz 7546 SHA256 951cfc25219b0cd003493a565f2e621fd791beaae9f9a3bdd7024d8626419c38 SHA512 a54aab83e102a8aa9fdbbcbaff5e8b758886c2db2d1eefee9448895b5ebd8d10115a86d810a39acc82917c17664d9225403cb8fdb2a7631ab1b601a791897a0e WHIRLPOOL d48c2d05920450a022de68af69c1120a8b2f843d7430a6be6a3a6d2ea6f99850d28576ba82b13167595f09fab5d803ba765e406182a83283eb0bd1c00ee0b701 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,30 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
PYTHON_COMPAT=( python2_7 python3_{3,4} ) | ||
|
||
inherit distutils-r1 | ||
|
||
MY_PN="${PN}" | ||
MY_P="${MY_PN}-${PV}" | ||
|
||
DESCRIPTION="A very small text templating language" | ||
HOMEPAGE="http://pythonpaste.org/scripttest/ http://pypi.python.org/pypi/ScriptTest" | ||
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz" | ||
|
||
LICENSE="MIT" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="test" | ||
|
||
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}] | ||
test? ( dev-python/pytest[${PYTHON_USEDEP}] )" | ||
RDEPEND="" | ||
|
||
S="${WORKDIR}/${MY_P}" | ||
|
||
python_test() { | ||
esetup.py test | ||
} |