Skip to content

Commit

Permalink
sys-kernel/linux-headers: add musl patch for 5.10
Browse files Browse the repository at this point in the history
Stable revbump given this is exactly what's already applied in ::musl
and we're only applying this new patch conditionally. We want installs
done with the new stages to not have to "downgrade" to the ::gentoo
version which lacks the header fixes that this patch _now_ adds.

Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Nov 21, 2021
1 parent a0663b3 commit 6beda97
Show file tree
Hide file tree
Showing 2 changed files with 77 additions and 0 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,27 @@
Needed for musl.

From 9eb3c31415686ae1296d7d450f886eeba5861ec1 Mon Sep 17 00:00:00 2001
From: Jory Pratt <[email protected]>
Date: Thu, 3 Jun 2021 18:41:28 -0500
Subject: [PATCH] Use stddefs.h instead of compiler.h

---
include/uapi/linux/swab.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/include/uapi/linux/swab.h b/include/uapi/linux/swab.h
index 7272f85..3736f2f 100644
--- a/include/uapi/linux/swab.h
+++ b/include/uapi/linux/swab.h
@@ -3,7 +3,7 @@
#define _UAPI_LINUX_SWAB_H

#include <linux/types.h>
-#include <linux/compiler.h>
+#include <linux/stddef.h>
#include <asm/bitsperlong.h>
#include <asm/swab.h>

--
2.31.1

50 changes: 50 additions & 0 deletions sys-kernel/linux-headers/linux-headers-5.10-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,50 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="6"

ETYPE="headers"
H_SUPPORTEDARCH="alpha amd64 arc arm arm64 avr32 cris frv hexagon hppa ia64 m68k metag microblaze mips mn10300 nios2 openrisc ppc ppc64 riscv s390 score sh sparc x86 xtensa"
inherit kernel-2 toolchain-funcs
detect_version

PATCH_PV=${PV} # to ease testing new versions against not existing patches
PATCH_VER="1"
SRC_URI="${KERNEL_URI}
${PATCH_VER:+mirror://gentoo/gentoo-headers-${PATCH_PV}-${PATCH_VER}.tar.xz}
${PATCH_VER:+https://dev.gentoo.org/~sam/distfiles/gentoo-headers-${PATCH_PV}-${PATCH_VER}.tar.xz}
"

KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"

DEPEND="app-arch/xz-utils
dev-lang/perl"
RDEPEND=""

S=${WORKDIR}/linux-${PV}

src_unpack() {
unpack ${A}
}

src_prepare() {
[[ -n ${PATCH_VER} ]] && eapply "${WORKDIR}"/${PATCH_PV}/*.patch

if use elibc_musl ; then
# TODO: May need forward porting to newer versions
eapply "${FILESDIR}"/${PN}-5.10-Use-stddefs.h-instead-of-compiler.h.patch
fi

default
}

src_test() {
emake headers_check ${xmakeopts}
}

src_install() {
kernel-2_src_install

find "${ED}" '(' -name '.install' -o -name '*.cmd' ')' -delete
find "${ED}" -depth -type d -delete 2>/dev/null
}

0 comments on commit 6beda97

Please sign in to comment.