Skip to content

Commit

Permalink
app-forensics/volatility: EAPI7, add missing die.
Browse files Browse the repository at this point in the history
  • Loading branch information
mm1ke authored and monsieurp committed Aug 7, 2018
1 parent 40dff0e commit 6bf6979
Showing 1 changed file with 35 additions and 0 deletions.
35 changes: 35 additions & 0 deletions app-forensics/volatility/volatility-2.6-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python2_7 )
inherit distutils-r1

DESCRIPTION="Framework for analyzing volatile memory"
HOMEPAGE="https://www.volatilityfoundation.org/"
SRC_URI="https://downloads.volatilityfoundation.org/releases/${PV}/${P}.zip"

LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

S=${WORKDIR}/${PN}-master

DEPEND="app-arch/unzip"
RDEPEND=">=dev-libs/distorm64-3[${PYTHON_USEDEP}]
dev-libs/libpcre
|| (
dev-python/pycryptodome[${PYTHON_USEDEP}]
dev-python/pycrypto[${PYTHON_USEDEP}]
)"

src_install() {
distutils-r1_src_install
mkdir "${D}/usr/share/${PN}" || die
mv "${D}/usr/contrib/plugins" "${D}/usr/share/${PN}/" || die
rmdir --ignore-fail-on-non-empty "${D}/usr/contrib" || die
mv "${D}/usr/tools" "${D}/usr/share/${PN}/" || die
dosym vol.py /usr/bin/volatility
}

0 comments on commit 6bf6979

Please sign in to comment.