Skip to content

Commit

Permalink
dev-python/versioneer: Bump to 0.19
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Nov 11, 2020
1 parent 90c1e9a commit 6e165c5
Show file tree
Hide file tree
Showing 2 changed files with 36 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/versioneer/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST versioneer-0.18.tar.gz 40552 BLAKE2B 640c010958a0178ec5ec5f06c986d83e3bc2f49df95583c4c90d3058449dcca5c7b5421ee5f2f56905b1d949bfe3bfbd87fb23ebc868ede591d078d811ccc2b3 SHA512 8d4522932b1f6aa1c13211008a57a572d54ea677cbdecd7d563ef8f77c76ed5d59f58f2e3be38a01e8cd102c264baf5c8949e9c17ea98d686ac497f8ad8b0011
DIST versioneer-0.19.tar.gz 47005 BLAKE2B cd4ce82bdb17cd10b628cf6013d1be171cc21115d9a065b845227fd6e5d1e988f8ab6fb001e2eeb6c1bfeda8a4afc8420937b0ec7437554d87e207713ccef381 SHA512 919c2e52e32b2fa1661ab2e10e3a698eb3f7c5102e66175d465d1a29237b86efa1520435ca581e321802cffeaa0ccd21fb66ba66946d72a05d13743c87a3e333
35 changes: 35 additions & 0 deletions dev-python/versioneer/versioneer-0.19.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

DISTUTILS_USE_SETUPTOOLS=rdepend
PYTHON_COMPAT=( python3_{6..9} )

inherit distutils-r1

DESCRIPTION="Easy VCS-based management of project version strings"
HOMEPAGE="https://pypi.org/project/versioneer/ https://github.com/warner/python-versioneer"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

SLOT="0"
LICENSE="public-domain"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="test"
RESTRICT="!test? ( test )"

BDEPEND="
test? (
dev-python/packaging[${PYTHON_USEDEP}]
dev-vcs/git
)
"

python_test() {
esetup.py make_versioneer

git config --global user.email "[email protected]" || die
git config --global user.name "Your Name" || die

${PYTHON} test/git/test_git.py -v || die
}

0 comments on commit 6e165c5

Please sign in to comment.