Skip to content

Commit

Permalink
www-apps/nanoc: add 4.11.9
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Hans de Graaff <[email protected]>
  • Loading branch information
graaff committed Aug 18, 2019
1 parent 7418192 commit 6e3de25
Show file tree
Hide file tree
Showing 2 changed files with 99 additions and 0 deletions.
1 change: 1 addition & 0 deletions www-apps/nanoc/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST nanoc-4.10.4.tar.gz 290367 BLAKE2B 0b5cf03938af1f971fccddb6bed4fa6b67da3aaf93cb7666c52e3ff8fc524f17ff10bf1a60ccf7f7b59f840d4c445ef57677349f5b83bc55e754e7078ac4b8d9 SHA512 5446e351906b5b6bbe5c9059dab86490d5deef5e1197adf5827fe201f2932d5cf79c65bfd9d9370ce57c35d965e013098d39d53fa96db8b4d1c6017977683ea2
DIST nanoc-4.11.7.tar.gz 307042 BLAKE2B b1144c80ea80ccf5bf713f93469061fbfb8a74890c3b9563ee8d88cd85375810fa6161a53d9221d817985b870426cafb52257403d05245b735855aecd76356a3 SHA512 d82d89dcd9f056e711cb722b6fbe22045eecf9fd61e3541529b89c8eb916ca850ef498148f1065b792e1a1d786e6d2f1477b41713753ff9d7b283ecc3cf2649c
DIST nanoc-4.11.8.tar.gz 307102 BLAKE2B 615dfc1e2a6424343327888d4d5c577652d8480178769accc15f86ae8f64f7dc8aecbfd98b16791f98dc3f5fbf1a9e88ed6ca38354aa5277aea13dec42a6404b SHA512 939e54a55ffeca9ea392d2e4ad49564761dc7497052a8bc367a9df9d7dd2fbc1943bc363e7df82da988d6897ed24d9a5db1c869ce063dd7dd6ae03d0da8d19b5
DIST nanoc-4.11.9.tar.gz 307441 BLAKE2B 9357a78412056eb62b8aac04ff2d02238bd02786bf6d3a1d0d4cc738b833f596122f55d325779760d2afa579b2864561701ccf107c9f0bd1a04e6aacd6d2b64d SHA512 34b6a52e16d04d69e3016ae9b77080d96860ab406ada8a597d5cf721761d82ec5e6d4dcc64193b6804315f3731618cc6286b5d6844f55c8d20dabed1a8251579
98 changes: 98 additions & 0 deletions www-apps/nanoc/nanoc-4.11.9.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,98 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
USE_RUBY="ruby24 ruby25 ruby26"

RUBY_FAKEGEM_EXTRADOC="NEWS.md README.md"

RUBY_FAKEGEM_GEMSPEC="nanoc.gemspec"

inherit ruby-fakegem

DESCRIPTION="nanoc is a simple but very flexible static site generator written in Ruby"
HOMEPAGE="https://nanoc.ws/"
SRC_URI="https://github.com/nanoc/nanoc/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"

KEYWORDS="~amd64"
SLOT="0"
IUSE="${IUSE} minimal"

DEPEND+="test? ( app-text/asciidoc app-text/highlight )"

RUBY_S="${P}/nanoc"

ruby_add_rdepend "!minimal? (
dev-ruby/mime-types:*
dev-ruby/rack:*
www-servers/adsf
)
>=dev-ruby/addressable-2.5
>=dev-ruby/colored-1.2:0
>=dev-ruby/cri-2.15:0
~www-apps/nanoc-core-${PV}
>=dev-ruby/parallel-1.12:1
>=dev-ruby/tomlrb-1.2:1
>=dev-ruby/tty-command-0.8:0
>=dev-ruby/tty-file-0.7:0
>=dev-ruby/tty-platform-0.2:0
>=dev-ruby/tty-which-0.4:0
"

ruby_add_bdepend "test? (
dev-ruby/rspec:3
dev-ruby/asciidoctor
dev-ruby/fuubar
dev-ruby/haml
dev-ruby/maruku
>=dev-ruby/mocha-0.13
dev-ruby/minitest
dev-ruby/mustache
dev-ruby/pry
dev-ruby/rdoc
>=dev-ruby/rouge-3.5.1:2
dev-ruby/rubypants
dev-ruby/systemu
dev-ruby/timecop
dev-ruby/vcr
dev-ruby/webmock
dev-ruby/yard
)
doc? (
dev-ruby/kramdown
dev-ruby/rdiscount
dev-ruby/yard
)"

all_ruby_prepare() {
# Avoid unneeded development dependencies
sed -i -e '/simplecov/,/SimpleCov.formatter/ s:^:#:' test/helper.rb || die
sed -i -e '/simplecov/I s:^:#:' \
-e '/codecov/I s:^:#:' ../common/spec/spec_helper_head_core.rb || die
sed -i -e '/coverall/I s:^:#:' \
-e '/rubocop/ s:^:#:' Rakefile || die

echo "-r ./spec/spec_helper.rb" > .rspec || die

# Avoid basepath issues when generating gemspec
sed -i -e "s:require_relative ':require './:" ${RUBY_FAKEGEM_GEMSPEC} || die

# Avoid tests requiring a network connection or make assumptions
# about the local network environment.
rm -f test/checking/checks/test_{css,html}.rb spec/nanoc/cli/commands/view_spec.rb || die

# Avoid tests for unpackaged dependencies
rm spec/nanoc/deploying/fog_spec.rb \
spec/nanoc/filters/less_spec.rb \
test/filters/test_{markaby,rainpress}.rb || die

# Avoid non-fatal failing tests due to specifics in the environment
sed -i -e '145askip "gentoo"' spec/nanoc/cli/error_handler_spec.rb || die
sed -i -e '/watches with --watch/askip "gentoo"' spec/nanoc/cli/commands/compile_spec.rb || die
sed -i -e '124askip "ordering issues"' -e '168askip "ordering issues"' spec/nanoc/data_sources/filesystem_spec.rb || die
}

each_ruby_test() {
RUBYLIB="${S}/lib" ${RUBY} -S rake spec test_all || die
}

0 comments on commit 6e3de25

Please sign in to comment.