Skip to content

Commit

Permalink
kde-frameworks/kservice: avoid breaking the menu
Browse files Browse the repository at this point in the history
Gentoo-bug: 596316

Package-Manager: portage-2.3.2
  • Loading branch information
kensington committed Nov 17, 2016
1 parent 8591131 commit 6e4af63
Showing 1 changed file with 47 additions and 0 deletions.
47 changes: 47 additions & 0 deletions kde-frameworks/kservice/kservice-5.28.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,47 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit kde5

DESCRIPTION="Advanced plugin and service introspection"
LICENSE="LGPL-2 LGPL-2.1+"
KEYWORDS="~amd64 ~arm ~x86"
IUSE="+man"

RDEPEND="
$(add_frameworks_dep kconfig)
$(add_frameworks_dep kcoreaddons)
$(add_frameworks_dep kcrash)
$(add_frameworks_dep kdbusaddons)
$(add_frameworks_dep ki18n)
$(add_qt_dep qtdbus)
$(add_qt_dep qtxml)
"
DEPEND="${RDEPEND}
sys-devel/bison
sys-devel/flex
man? ( $(add_frameworks_dep kdoctools) )
test? ( $(add_qt_dep qtconcurrent) )
"

# requires running kde environment
RESTRICT+=" test"

src_configure() {
local mycmakeargs=(
-DAPPLICATIONS_MENU_NAME=kf5-applications.menu
$(cmake-utils_use_find_package man KF5DocTools)
)

kde5_src_configure
}

src_install() {
kde5_src_install

# bug 596316
dosym /etc/xdg/menus/kf5-applications.menu /etc/xdg/menus/applications.menu
}

0 comments on commit 6e4af63

Please sign in to comment.