Skip to content

Commit

Permalink
dev-vcs/tortoisehg: Bump to version 3.8.4
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Jul 21, 2016
1 parent 556c360 commit 6e71636
Show file tree
Hide file tree
Showing 2 changed files with 79 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-vcs/tortoisehg/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST tortoisehg-3.3.2.tar.gz 8226128 SHA256 779beb06588897d1c42fc463fecc4b61498f
DIST tortoisehg-3.7.3.tar.gz 7806350 SHA256 b0055ef6bee59244356179d5af98ffe200388133b17cd4ab5831b979b78a50ed SHA512 5ff57b98b93083cc78e161566f045474e70d474dab98ee99eaa6f453ac2521276a8384563a2e738a786a3c9cbe4c118837a8c534cfd4671c323eab261252e6f9 WHIRLPOOL 9a6e573b22b6dcf328a656dcd9e4f2bd500fc74f03f6d9ee8d350ec35cd7a02f239f6aa290b6ff9414d4b7aedde0b3003296f3520463669ce4f9b75a85a820ba
DIST tortoisehg-3.8.1.tar.gz 7807685 SHA256 e64639768ec22e45966b6799257ebad4a98dbb6cfaa39b74ccc08c95be2fb0ec SHA512 1ab9328462035ab78c4ffadba3bf60a58e641947a69be10cc6c7892a71de4f8436f0225806fa898c7de95593dd4e7b7b76aa9ef3dc8115bbd8bbadc20fe82612 WHIRLPOOL e9bce9a316c0f226f2c5a9a5e3a65664c0ae12f1c7628beb6edea229a9bd9924b15b848bd26d20975e852701c1fa3dfca9b3a0db5031b918a2cb12ade4f19bae
DIST tortoisehg-3.8.3.tar.gz 7817490 SHA256 63045857067120b3e5d4bb3ff87985b9caeac27ca2e69df5946ab1a0282d08c8 SHA512 1c1d0e7d3eae0a894b09d13223eae3eb43555ea0136372c881f35c4ff1beeb768a059be2484fed72588cadc90a0f83f4dffc6dd7a75a91433751eb4bb37f115f WHIRLPOOL 9049db76419a8cc658180e4d8d4ce7c416850830d8a71add07ac6cf441cb10229572914bddee1643d618f70d54b6d6cbad5f9356a7b580e090f4137f98aef738
DIST tortoisehg-3.8.4.tar.gz 7817508 SHA256 c8608ab7f063d0edd46c1fdae3181ef8216ea029bca34f180f0adeefc50274f7 SHA512 d9d83007588e8e62a03976a229a7c325e6e7f203d4f8fc74cc32b3f2880a1873237b4c333cfdb0ece6acde51019f6f62a75d863f1f99e8a5930ad17c38c6358b WHIRLPOOL 0ae8136f8de546a50998672bfd892774d4e8497268ffaf1198c84ce725c02080e8631c203103f8c646ef3ad7b69c832124042d6d0c207e90d13e08b532d33862
78 changes: 78 additions & 0 deletions dev-vcs/tortoisehg/tortoisehg-3.8.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,78 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
PYTHON_COMPAT=( python2_7 )

inherit distutils-r1 eutils

if [[ ${PV} != *9999* ]]; then
KEYWORDS="~amd64 ~x86"
SRC_URI="https://www.bitbucket.org/${PN}/targz/downloads/${P}.tar.gz"
HG_DEPEND=">=dev-vcs/mercurial-3.7 <dev-vcs/mercurial-3.9"
else
inherit mercurial
EHG_REPO_URI="https://bitbucket.org/tortoisehg/thg"
EHG_REVISION="stable"
KEYWORDS=""
SRC_URI=""
HG_DEPEND="dev-vcs/mercurial"
fi

DESCRIPTION="Set of graphical tools for Mercurial"
HOMEPAGE="https://tortoisehg.bitbucket.org"

LICENSE="GPL-2"
SLOT="0"
IUSE="doc"

RDEPEND="${HG_DEPEND}
dev-python/iniparse[${PYTHON_USEDEP}]
dev-python/pygments[${PYTHON_USEDEP}]
dev-python/PyQt4[svg,${PYTHON_USEDEP}]
dev-python/qscintilla-python[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
doc? ( >=dev-python/sphinx-1.0.3 )"

# Workaround race condition in build_qt
DISTUTILS_IN_SOURCE_BUILD=1

python_prepare_all() {
if [[ ${LINGUAS+set} ]]; then
cd i18n/tortoisehg || die
local x y keep
for x in *.po; do
keep=false
for y in ${LINGUAS}; do
if [[ ${y} == ${x%.po}* ]]; then
keep=true
break
fi
done
${keep} || rm "${x}" || die
done
cd "${S}" || die
fi
distutils-r1_python_prepare_all
}

python_compile_all() {
use doc && emake -C doc html
}

python_install_all() {
distutils-r1_python_install_all
dodoc doc/ReadMe*.txt doc/TODO contrib/mergetools.rc
if use doc ; then
dohtml -r doc/build/html/
fi
newicon -s scalable icons/scalable/apps/thg.svg thg_logo.svg
domenu contrib/thg.desktop
}

pkg_postinst() {
elog "When startup of ${PN} fails with an API version mismatch error"
elog "between dev-python/sip and dev-python/PyQt4 please rebuild"
elog "dev-python/qscintilla-python."
}

0 comments on commit 6e71636

Please sign in to comment.