Skip to content

Commit

Permalink
dev-python/progressbar2: bump to 3.53.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.9, Repoman-3.0.2
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Dec 3, 2020
1 parent 0606afa commit 6f5185a
Show file tree
Hide file tree
Showing 2 changed files with 33 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/progressbar2/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST progressbar2-3.39.3.tar.gz 131839 BLAKE2B 2cbf1ecf04947b3a393b5cc473a696528cdaf38f132a1b0faab5e45dff76aecdee497ca1b2810b9ec5e3b180acfa8e2af1d195e5804c058a7d8880fc3b0a330f SHA512 b8944b319f1133fe7abdd256bed8803e9f426208af5ddc58935121845e81b9f65878e536bd5a1e4810eaa6906b24d114e8681dddf1f77c1bf96cb231f6473a5e
DIST progressbar2-3.53.1.tar.gz 44741 BLAKE2B 80f406adf42c5c57ecad87002426115e1254339d5cd310dd42f560f48a1123702dffbba8f26114a01f2bd5be75a29cb12cc1c091d5554509b6282ceb2b66fb76 SHA512 4817bbb45d0f51ee2b3feceec56b3177ed5d0561894a13eea53a30e8b9aad5805483b5b669af93f3fd0cc958984b8a5c2a14ba3591e0a85be12180d057bc2f81
32 changes: 32 additions & 0 deletions dev-python/progressbar2/progressbar2-3.53.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,32 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
PYTHON_COMPAT=( python3_{6,7,8,9} pypy3)

inherit distutils-r1

DESCRIPTION="Text progressbar library for python"
HOMEPAGE="https://pypi.org/project/progressbar2/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"

CDEPEND="!dev-python/progressbar[${PYTHON_USEDEP}]
dev-python/python-utils[${PYTHON_USEDEP}]"
RDEPEND="${CDEPEND}"
BDEPEND="${CDEPEND}"

distutils_enable_tests pytest

src_prepare() {
sed -i -e '/cov/d' pytest.ini || die
default
}

python_test() {
cd tests || die
PYTHONDONTWRITEBYTECODE=1 pytest -vv || die "Tests failed with ${EPYTHON}"
}

0 comments on commit 6f5185a

Please sign in to comment.