Skip to content

Commit

Permalink
app-editors/nano: Bump to version 4.8
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.87, Repoman-2.3.20
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Feb 7, 2020
1 parent d71c4ff commit 71205f3
Show file tree
Hide file tree
Showing 2 changed files with 81 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-editors/nano/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST nano-4.2.tar.gz 2928595 BLAKE2B 42bb0ccbf4961706c6c645eb2310a646a7decd3617117a079ffe9e3718c8054ab823a5aff3e543c06c4c398f83579a679267a9ad6f113ba451b76d67e14b07cc SHA512 a5dd9ce96cd09d12c65108ea6a18b2cf1c2b055929e58d3e84beb0725607b4b5a3f8ae3fda0ab658c853cc4cac70c089fee716e1bb5a700f2506a7a3e1bea1bd
DIST nano-4.6.tar.gz 2970798 BLAKE2B d6dfc702d374d1cbcd61080c8e0082b7931dc8c593c97eb705d878d25487a78dc1ebcb8004f742f5ecc3af1b5a31abcf6577e87aba96fb95d16029ff55e7af58 SHA512 76fb43495ca1f88ee8864eee5d023b6cd86bc35fba00151b4c6af53ae06e6b3828379e7d52a16c7df0956e9e04602a86ff8e8a7c1997320507ca041195bf004b
DIST nano-4.7.tar.gz 2977920 BLAKE2B 8373ebf3f4e98ba204ed00678ba1e8791c9ffc11226baa98b7dac9ff9389cc465dc6574833ce222570301232a97f87e1b8d505dcce617f6c8bd915f4a662df4d SHA512 2cbe2341bba46f57a692d6deb20003d992da0230fdec3a2dc485d3b03d2ec2a70e66d05299bbc719fca658c8a8060dd64d4b52e68aadfd73980b82445761615f
DIST nano-4.8.tar.gz 2995765 BLAKE2B 80acb19758c4bedfa1fa52ef9ede7125bdd3844df6932912899ba2f5c4471859ac6d044b2c67d43afcfc416d0b6bf0b5d023e79645c5d6207c5ed4a0857305a4 SHA512 3e6f8f2a7ce55df0eb2d96459a22f0a40808b4ffc67eb5a35937437f5c1cb193046b02d123597981066b872ffacf345bf0f4c72f546323324ebb66aa751d11f9
80 changes: 80 additions & 0 deletions app-editors/nano/nano-4.8.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,80 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit flag-o-matic
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://git.sv.gnu.org/nano.git"
inherit git-r3 autotools
else
MY_P="${PN}-${PV/_}"
SRC_URI="https://www.nano-editor.org/dist/v${PV:0:1}/${MY_P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi

DESCRIPTION="GNU GPL'd Pico clone with more functionality"
HOMEPAGE="https://www.nano-editor.org/ https://wiki.gentoo.org/wiki/Nano/Basics_Guide"

LICENSE="GPL-3"
SLOT="0"
IUSE="debug justify +magic minimal ncurses nls slang +spell +split-usr static unicode"

LIB_DEPEND=">=sys-libs/ncurses-5.9-r1:0=[unicode?]
sys-libs/ncurses:0=[static-libs(+)]
magic? ( sys-apps/file[static-libs(+)] )
nls? ( virtual/libintl )
!ncurses? ( slang? ( sys-libs/slang[static-libs(+)] ) )"
RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
DEPEND="${RDEPEND}
static? ( ${LIB_DEPEND} )"
BDEPEND="
nls? ( sys-devel/gettext )
virtual/pkgconfig
"
src_prepare() {
default
if [[ ${PV} == "9999" ]] ; then
eautoreconf
fi
}

src_configure() {
use static && append-ldflags -static
local myconf=(
--bindir="${EPREFIX}"/bin
--htmldir=/trash
$(use_enable !minimal color)
$(use_enable !minimal multibuffer)
$(use_enable !minimal nanorc)
$(use_enable magic libmagic)
$(use_enable spell speller)
$(use_enable justify)
$(use_enable debug)
$(use_enable nls)
$(use_enable unicode utf8)
$(use_enable minimal tiny)
$(usex ncurses --without-slang $(use_with slang))
)
econf "${myconf[@]}"
}

src_install() {
default
# don't use "${ED}" here or things break (#654534)
rm -r "${D}"/trash || die

dodoc doc/sample.nanorc
docinto html
dodoc doc/faq.html
insinto /etc
newins doc/sample.nanorc nanorc
if ! use minimal ; then
# Enable colorization by default.
sed -i \
-e '/^# include /s:# *::' \
"${ED}"/etc/nanorc || die
fi

use split-usr && dosym ../../bin/nano /usr/bin/nano
}

0 comments on commit 71205f3

Please sign in to comment.