Skip to content

Commit

Permalink
dev-php/symfony-filesystem: bump to v3.4.28
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.68, Repoman-2.3.16
Signed-off-by: Thomas Deutschmann <[email protected]>
  • Loading branch information
Whissi committed Jul 18, 2019
1 parent 73805a5 commit 71d9adf
Show file tree
Hide file tree
Showing 2 changed files with 39 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-php/symfony-filesystem/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST symfony-filesystem-3.2.8.tar.gz 17361 BLAKE2B 8ce4fd987ee7e0609433de8428b849645a9c8372029e0a075d3070786441577c5413e1a2f13e1581afc90cb69fe04c2b64e75de3e23ea532dd7ffd63e2bd8ee2 SHA512 b9464dec0c5100877bb7178a118ab34e9893307df371e9a9f8df8d69e59b6e14c9f7143e4eaf5b47662f69dce1b5fa975b6bb78e93a5c7455eb44dacfaab82e8
DIST symfony-filesystem-3.4.28.tar.gz 19238 BLAKE2B dcb9752a5691834aa87b3866b6c2f53b54d5953cf721547cf3ae8aa03e826bcacb2393f324bf9a767013a2daebcf9654c7ce18822ac40758d96b35b174b8ab6d SHA512 4a2e19bf6df69396e503e11112d9b37e9deaaba5eb4fa95857b7b19e1ce073462d2ca18442b6cc1c30021f925d0878f635aa9bc1c5de55318f0c521a291efcc8
38 changes: 38 additions & 0 deletions dev-php/symfony-filesystem/symfony-filesystem-3.4.28.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,38 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

DESCRIPTION="Symfony Filesystem Component"
HOMEPAGE="https://github.com/symfony/filesystem"
SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"

RDEPEND="dev-lang/php:*
dev-php/fedora-autoloader"
DEPEND="test? ( ${RDEPEND} >=dev-php/phpunit-5.7.15 )"

S="${WORKDIR}/filesystem-${PV}"

src_prepare() {
default
if use test; then
cp "${FILESDIR}/autoload.php" "${S}/autoload-test.php" || die
fi
}

src_install() {
insinto "/usr/share/php/Symfony/Component/Filesystem"
doins -r Exception
doins *.php "${FILESDIR}/autoload.php"
dodoc CHANGELOG.md README.md
}

src_test() {
phpunit --bootstrap "${S}/autoload-test.php" \
--exclude-group network || die 'test suite failed'
}

0 comments on commit 71d9adf

Please sign in to comment.