Skip to content

Commit

Permalink
dev-ada/gnatcoll-db: bump to 2019 version
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Alfredo Tupone <[email protected]>
  • Loading branch information
atupone committed Sep 20, 2019
1 parent 6b9b60a commit 7237b02
Show file tree
Hide file tree
Showing 3 changed files with 116 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ada/gnatcoll-db/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST gnatcoll-db-2019-src.tar.gz 2405755 BLAKE2B 70db599e8fe90a1312c2078379c6cddf518159fd8eea8c958d1abf4f4ccc504c8296e0018b03fe7f145619b6f73d6ce38b7a43cfd73dd5e1df7eb1949aa81043 SHA512 89e941a786b1d9591f4cb9f5f7db02875bb37638be7efb88e31087900c8c10ac52680f1246f90cda6fbac1b9ab213bf364d88bf583ad262f17c0a647492019a3
DIST gnatcoll-db-gpl-2018-src.tar.gz 2375712 BLAKE2B d5678bdc0993b67d93bdd4cb33ee3ecba15f7cdeead173caaaa08312103505d97099037215a3b0699296aadfa0ef68327f28e01c6229db1fefc5b7d7ebf93187 SHA512 02c967b5951ef0e17e58874e03c9a6252f9c4b28100c9530fb88212e91bc692545f3acc8623477942db220bd54d56b494150b088d05c40f6a24aad8cf6a8f8de
114 changes: 114 additions & 0 deletions dev-ada/gnatcoll-db/gnatcoll-db-2019.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,114 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
PYTHON_COMPAT=( python2_7 )
ADA_COMPAT=( gnat_201{6,7,8,9} )
inherit ada multilib multiprocessing autotools python-single-r1

commitId="fbc46346dc67dfa83ae5132ef72fdd64fbe7e199"
DESCRIPTION="GNAT Component Collection"
HOMEPAGE="http://libre.adacore.com"
SRC_URI="https://github.com/AdaCore/${PN}/archive/${commitId}.tar.gz
-> ${P}-src.tar.gz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="db2ada gnatinspect postgres
+shared sql sqlite static-libs static-pic xref"

RDEPEND="dev-ada/gnatcoll-core[${ADA_USEDEP},shared?,static-libs?,static-pic?]
sqlite? ( dev-db/sqlite:3 )
postgres? ( dev-db/postgresql:* )
xref? (
dev-ada/gnatcoll-bindings[${ADA_USEDEP},iconv,shared?,static-libs?,static-pic?]
)
${ADA_DEPS}
${PYTHON_DEPS}"
DEPEND="${RDEPEND}
dev-ada/gprbuild[${ADA_USEDEP}]"

REQUIRED_USE="gnatinspect? ( xref )
xref? ( sqlite )
sqlite? ( sql )
db2ada? ( sql )
${ADA_REQUIRED_USE}
${PYTHON_REQUIRED_USE}"

S="${WORKDIR}"/${PN}-${commitId}

PATCHES=( "${FILESDIR}"/${PN}-2018-gentoo.patch )

src_compile() {
build () {
GPR_PROJECT_PATH="${S}/sql":"${S}/sqlite":"${S}/xref" \
gprbuild -p -m -v -j$(makeopts_jobs) -XGNATCOLL_SQLITE=external \
-XGNATCOLL_VERSION=2018 \
-XBUILD=PROD -XLIBRARY_TYPE=$2 -XXMLADA_BUILD=$2 -XGPR_BUILD=$2 \
-P $1/$3.gpr \
-cargs:Ada ${ADAFLAGS} -cargs:C ${CFLAGS} || die "gprbuild failed"
}
local lib
for kind in shared static-libs static-pic ; do
if use $kind; then
lib=${kind%-libs}
lib=${lib/shared/relocatable}
for dir in sql sqlite xref postgres ; do
if use $dir; then
build $dir $lib gnatcoll_${dir}
fi
done
fi
done
if use shared; then
lib=relocatable
elif use static-libs; then
lib=static
else
lib=static-pic
fi
if use gnatinspect; then
build gnatinspect ${lib} gnatinspect
fi
if use db2ada; then
build gnatcoll_db2ada ${lib} gnatcoll_db2ada
fi
}

src_install() {
build () {
GPR_PROJECT_PATH="${D}/usr/share/gpr" gprinstall -p -f \
-XBUILD=PROD -XGNATCOLL_VERSION=2018 \
--prefix="${D}"/usr -XLIBRARY_TYPE=$2 -XXMLADA_BUILD=$2 \
-XGPR_BUILD=$2 --build-name=$2 --build-var=LIBRARY_TYPE \
-P $1/$3.gpr
}
local lib
for kind in shared static-libs static-pic ; do
if use $kind; then
lib=${kind%-libs}
lib=${lib/shared/relocatable}
for dir in sql sqlite xref postgres ; do
if use $dir; then
build $dir $lib gnatcoll_${dir}
fi
done
fi
done
if use shared; then
lib=relocatable
elif use static-libs; then
lib=static
else
lib=static-pic
fi
if use gnatinspect; then
build gnatinspect ${lib} gnatinspect
fi
if use db2ada; then
build gnatcoll_db2ada ${lib} gnatcoll_db2ada
fi
rm -rf "${D}"/usr/share/gpr/manifests
einstalldocs
}
1 change: 1 addition & 0 deletions dev-ada/gnatcoll-db/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -6,6 +6,7 @@
</maintainer>
<use>
<flag name="gnatcoll_db2ada">Build gnatcoll_db2ada</flag>
<flag name="db2ada">Build gnatcoll_db2ada</flag>
<flag name="gnatinspect">Build gnatinspect</flag>
<flag name="shared">Build shared library</flag>
<flag name="sql">Build sql library</flag>
Expand Down

0 comments on commit 7237b02

Please sign in to comment.