Skip to content

Commit

Permalink
sys-devel/gdb-apple: epatch->PATCHES=()
Browse files Browse the repository at this point in the history
Also reworked patches to be -p1 (tricky due to the wierd ${S} setting.

Package-Manager: Portage-2.3.31, Repoman-2.3.9
  • Loading branch information
hanetzer authored and Zlogene committed Apr 23, 2018
1 parent 271533b commit 723fdaf
Show file tree
Hide file tree
Showing 6 changed files with 56 additions and 50 deletions.
28 changes: 14 additions & 14 deletions sys-devel/gdb-apple/files/gdb-apple-1461-darwin8.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- gdb-1461.2/src/gdb/macosx/macosx-nat-inferior.c
+++ gdb-1461.2/src/gdb/macosx/macosx-nat-inferior.c
--- a/gdb/macosx/macosx-nat-inferior.c
+++ b/gdb/macosx/macosx-nat-inferior.c
@@ -60,13 +60,17 @@
#include <sys/sysctl.h>
#include <sys/proc.h>
Expand All @@ -18,8 +18,8 @@

#include "macosx-nat-dyld.h"
#include "macosx-nat-inferior.h"
--- gdb-1461.2/src/gdb/macosx/macosx-nat-info.c
+++ gdb-1461.2/src/gdb/macosx/macosx-nat-info.c
--- a/gdb/macosx/macosx-nat-info.c
+++ b/gdb/macosx/macosx-nat-info.c
@@ -45,6 +45,22 @@
#include "macosx-nat-inferior.h"
#include "macosx-nat-inferior-debug.h"
Expand All @@ -43,8 +43,8 @@
extern macosx_inferior_status *macosx_status;

#define CHECK_ARGS(what, args) \
--- gdb-1461.2/src/gdb/macosx/macosx-nat-infthread.c
+++ gdb-1461.2/src/gdb/macosx/macosx-nat-infthread.c
--- a/gdb/macosx/macosx-nat-infthread.c
+++ b/gdb/macosx/macosx-nat-infthread.c
@@ -36,8 +36,10 @@
#include <sys/dir.h>
#include <inttypes.h>
Expand All @@ -56,8 +56,8 @@

#include "macosx-nat-inferior.h"
#include "macosx-nat-inferior-util.h"
--- gdb-1461.2/src/gdb/macosx/macosx-tdep.c
+++ gdb-1461.2/src/gdb/macosx/macosx-tdep.c
--- a/gdb/macosx/macosx-tdep.c
+++ b/gdb/macosx/macosx-tdep.c
@@ -63,7 +63,6 @@
#include "gdbcore.h"

Expand All @@ -66,8 +66,8 @@
#include <sys/types.h>
#include <sys/stat.h>
#include <sys/param.h>
--- gdb-1461.2/src/gdb/remote.c
+++ gdb-1461.2/src/gdb/remote.c
--- a/gdb/remote.c
+++ b/gdb/remote.c
@@ -62,7 +62,6 @@
#include "macosx-nat-dyld.h"
#include "macosx-nat-dyld-process.h"
Expand All @@ -90,8 +90,8 @@
}

static void
--- gdb-1461.2/src/gdb/symfile.c
+++ gdb-1461.2/src/gdb/symfile.c
--- a/gdb/symfile.c
+++ b/gdb/symfile.c
@@ -67,7 +67,6 @@
#include <ctype.h>
#include <time.h>
Expand All @@ -100,8 +100,8 @@

#include <sys/mman.h>

--- gdb-1461.2/src/gdb/utils.c
+++ gdb-1461.2/src/gdb/utils.c
--- a/gdb/utils.c
+++ b/gdb/utils.c
@@ -27,7 +27,6 @@
#include "gdb_string.h"
#include "event-top.h"
Expand Down
4 changes: 2 additions & 2 deletions sys-devel/gdb-apple/files/gdb-apple-1461-dyld-info.patch
Original file line number Diff line number Diff line change
@@ -1,8 +1,8 @@
If dyld-info is not available, don't try to compile unreachable code
using it either.

--- gdb-1461.2/src/gdb/macosx/macosx-nat-dyld.c
+++ gdb-1461.2/src/gdb/macosx/macosx-nat-dyld.c
--- a/gdb/macosx/macosx-nat-dyld.c
+++ b/gdb/macosx/macosx-nat-dyld.c
@@ -731,7 +731,7 @@
{
#if !defined (TASK_DYLD_INFO) || !defined (NM_NEXTSTEP)
Expand Down
18 changes: 10 additions & 8 deletions sys-devel/gdb-apple/gdb-apple-1461.ebuild
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# Copyright 1999-2017 Gentoo Foundation
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="6"
EAPI=6

inherit eutils flag-o-matic

Expand All @@ -24,16 +24,18 @@ DEPEND="${RDEPEND}

S=${WORKDIR}/gdb-${APPLE_PV}/src

PATCHES=(
"${FILESDIR}"/${PN}-no-global-gdbinit.patch
"${FILESDIR}"/${PN}-768-texinfo.patch
"${FILESDIR}"/${P}-dyld-info.patch
)

src_prepare() {
epatch "${FILESDIR}"/${PN}-no-global-gdbinit.patch
epatch "${FILESDIR}"/${PN}-768-texinfo.patch
epatch "${FILESDIR}"/${P}-dyld-info.patch
[[ ${CHOST} == *-darwin8 ]] && epatch "${FILESDIR}"/${P}-darwin8.patch
default
[[ ${CHOST} == *-darwin8 ]] && eapply "${FILESDIR}"/${P}-darwin8.patch

# for FSF gcc / gcc-apple:42
sed -e 's/-Wno-long-double//' -i gdb/config/*/macosx.mh

eapply_user
}

src_configure() {
Expand Down
20 changes: 11 additions & 9 deletions sys-devel/gdb-apple/gdb-apple-1752.ebuild
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# Copyright 1999-2017 Gentoo Foundation
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="6"
EAPI=6

inherit eutils flag-o-matic

Expand All @@ -24,14 +24,16 @@ DEPEND="${RDEPEND}

S=${WORKDIR}/gdb-${APPLE_PV}/src

src_prepare() {
epatch "${FILESDIR}"/${PN}-no-global-gdbinit.patch
epatch "${FILESDIR}"/${PN}-768-texinfo.patch
epatch "${FILESDIR}"/${PN}-1518-darwin8-9.patch
epatch "${FILESDIR}"/${PN}-1705-darwin8-10.patch
[[ ${CHOST} == *-darwin8 ]] && epatch "${FILESDIR}"/${PN}-1518-darwin8.patch
PATCHES=(
"${FILESDIR}"/${PN}-no-global-gdbinit.patch
"${FILESDIR}"/${PN}-768-texinfo.patch
"${FILESDIR}"/${PN}-1518-darwin8-9.patch
"${FILESDIR}"/${PN}-1705-darwin8-10.patch
)

eapply_user
src_prepare() {
default
[[ ${CHOST} == *-darwin8 ]] && eapply "${FILESDIR}"/${PN}-1518-darwin8.patch
}

src_configure() {
Expand Down
15 changes: 8 additions & 7 deletions sys-devel/gdb-apple/gdb-apple-768-r1.ebuild
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# Copyright 1999-2017 Gentoo Foundation
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="6"
EAPI=6

inherit eutils flag-o-matic

Expand All @@ -23,14 +23,15 @@ DEPEND="${RDEPEND}

S=${WORKDIR}/gdb-${PV}/src

src_prepare() {
epatch "${FILESDIR}"/${P}-texinfo.patch
epatch "${FILESDIR}"/${P}-darwin-arch.patch
PATCHES=(
"${FILESDIR}"/${P}-texinfo.patch
"${FILESDIR}"/${P}-darwin-arch.patch
)

src_prepare() {
default
# for FSF gcc / gcc-apple:42
sed -e 's/-Wno-long-double//' -i gdb/config/*/macosx.mh

eapply_user
}

src_configure() {
Expand Down
21 changes: 11 additions & 10 deletions sys-devel/gdb-apple/gdb-apple-966.ebuild
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# Copyright 1999-2017 Gentoo Foundation
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="6"
EAPI=6

inherit eutils flag-o-matic

Expand All @@ -23,17 +23,18 @@ DEPEND="${RDEPEND}

S=${WORKDIR}/gdb-${PV}/src

src_prepare() {
epatch "${FILESDIR}"/${PN}-768-texinfo.patch
epatch "${FILESDIR}"/${PN}-768-darwin-arch.patch
epatch "${FILESDIR}"/${PN}-962-darwin8.patch
epatch "${FILESDIR}"/${PN}-962-darwin64.patch
epatch "${FILESDIR}"/${PN}-962-demangle.patch
PATCHES=(
"${FILESDIR}"/${PN}-768-texinfo.patch
"${FILESDIR}"/${PN}-768-darwin-arch.patch
"${FILESDIR}"/${PN}-962-darwin8.patch
"${FILESDIR}"/${PN}-962-darwin64.patch
"${FILESDIR}"/${PN}-962-demangle.patch
)

src_prepare() {
default
# for FSF gcc / gcc-apple:42
sed -e 's/-Wno-long-double//' -i gdb/config/*/macosx.mh

eapply_user
}

src_configure() {
Expand Down

0 comments on commit 723fdaf

Please sign in to comment.