Skip to content

Commit

Permalink
dev-python/colorama: version bump to 0.4.1
Browse files Browse the repository at this point in the history
Signed-off-by: Tim Harder <[email protected]>
  • Loading branch information
radhermit committed Dec 27, 2018
1 parent 89b05bf commit 7268535
Show file tree
Hide file tree
Showing 2 changed files with 44 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/colorama/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST colorama-0.3.3.tar.gz 22765 BLAKE2B 3dc399c3a073fba825e85c667c6af1a5b8777dc
DIST colorama-0.3.9.github.tar.gz 122180 BLAKE2B 0ef1b2876a8d790e434548649d34bc38940eb48883080168d11cca79fc17c2cab258831ac2660be69eca28000864d617cb4a448558f8e473bca22cce090a8e03 SHA512 7bf6ec19181431d91f5c7a5334d01f9934d4555004e985f82ad74fc325c465339a4c3fdf017af6e0682e0b22e2bf78938cd222b670e5035f305d2d616b03d1d1
DIST colorama-0.3.9.tar.gz 25053 BLAKE2B f633a188d032c41d0b6de60540ca1774dd8f3e8fe2e558333baf09855db30fa7a7ade5944ff12e4ca1a3685930d10a02009162733666d711ad25a16ee96ace55 SHA512 248e3d3d1f95cb85baf55ef4d705508213b81edfb04b39fe9a7bc9c7ac564986726ab6e9d9f73d64ee02e1c9b86d4c6bba40543590dbd170180a37d69e07b627
DIST colorama-0.4.0.github.tar.gz 104679 BLAKE2B 416a8bc5af470dc22b71a84279e4d984b57fad7ddb617c80c9104830127efa4f545eb08c003d263e48edbc0db39bc150e74f64f68f22075e759c11a6e84c75d5 SHA512 e2214c0a4ce1dd5515cf12cbb91220d2314da747b1a1246641117e70ea81b162cb4748b2b5dff049e102540470617a0076a3afff64bfe67158bf7bd95e1cc6f8
DIST colorama-0.4.1.github.tar.gz 104708 BLAKE2B 625c6ff325ff0de8113c5c9abe9dd296eb614b0483a2dce59b163431ec4ef1992073719160143b68e76d3ad77f77b975a110ce19496be1d8f6ee90b3f66b6e7b SHA512 006069859ca05ec8a6808860ca73ab541b246e6e6443b1bc8426973beaa5268660b48994f21edb6492fe97c4b9d29949b874b861ec200b1756d40e8abda8dee0
43 changes: 43 additions & 0 deletions dev-python/colorama/colorama-0.4.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,43 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6,7}} )

inherit distutils-r1

DESCRIPTION="ANSI escape character sequences for colored terminal text & cursor positioning"
HOMEPAGE="
https://pypi.org/project/colorama/
https://github.com/tartley/colorama
"
# https://github.com/tartley/colorama/pull/183
SRC_URI="https://github.com/tartley/${PN}/archive/${PV}.tar.gz -> ${P}.github.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="examples test"

BDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/pytest[${PYTHON_USEDEP}] )
"

python_install_all() {
distutils-r1_python_install_all

if use examples; then
docinto examples
dodoc -r demos/.
docompress -x /usr/share/doc/${PF}/examples
fi
}

python_test() {
# Some tests require stdout to be a TTY
# https://github.com/tartley/colorama/issues/169
script -eqc "pytest -vv -s" /dev/null \
|| die "tests failed with ${EPYTHON}"
}

0 comments on commit 7268535

Please sign in to comment.