forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Signed-off-by: Alon Bar-Lev <[email protected]> Package-Manager: Portage-2.3.66, Repoman-2.3.11
- Loading branch information
Showing
2 changed files
with
61 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST nettle-3.4.1.tar.gz 1947053 BLAKE2B 354318c46c28aeaaca611abe70298024ec12ff70aed53c741e43c1b5373361e5cffb03df7b8e86ef103a3b7770b2b4fe39fbca00b128f2b7ec810b3a4d9fd0fd SHA512 26aefbbe9927e90e28f271e56d2ba876611831222d0e1e1a58bdb75bbd50934fcd84418a4fe47b845f557e60a9786a72a4de2676c930447b104f2256aca7a54f | ||
DIST nettle-3.5.tar.gz 1989543 BLAKE2B db2a4c8deed2e99e746c702cc686385fc1ae87aab67d94ca67a4d9dfea4e10990f2a3fed81010c78364271c8a08e2208e5a479298ab5e9bc10a5c676fe7a3cbc SHA512 0aaac4b678fede9f462e0c71e5926b02e82aa7a54b15ab34d159315a36b99bd8f17c3ad89a1ffae7bc8333668fe9793c041637ffe8000175bb20b14047bef907 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,60 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
inherit autotools multilib-build multilib-minimal multilib toolchain-funcs | ||
|
||
DESCRIPTION="Low-level cryptographic library" | ||
HOMEPAGE="http://www.lysator.liu.se/~nisse/nettle/" | ||
SRC_URI="mirror://gnu/${PN}/${P}.tar.gz" | ||
|
||
LICENSE="|| ( LGPL-3 LGPL-2.1 )" | ||
SLOT="0/7" # subslot = libnettle soname version | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris" | ||
IUSE="doc +gmp neon static-libs test cpu_flags_x86_aes" | ||
|
||
DEPEND="gmp? ( >=dev-libs/gmp-6.0:0=[static-libs?,${MULTILIB_USEDEP}] )" | ||
RDEPEND="${DEPEND}" | ||
|
||
MULTILIB_WRAPPED_HEADERS=( | ||
/usr/include/nettle/version.h | ||
) | ||
|
||
DOCS=() | ||
HTML_DOCS=() | ||
|
||
pkg_setup() { | ||
use doc && DOCS+=( | ||
nettle.pdf | ||
) | ||
use doc && HTML_DOCS+=( | ||
nettle.html | ||
) | ||
} | ||
|
||
src_prepare() { | ||
default | ||
|
||
sed -e '/CFLAGS=/s: -ggdb3::' \ | ||
-e 's/solaris\*)/sunldsolaris*)/' \ | ||
-i configure.ac || die | ||
|
||
# conditionally build tests and examples required by tests | ||
use test || sed -i '/SUBDIRS/s/testsuite examples//' Makefile.in || die | ||
|
||
eautoreconf | ||
} | ||
|
||
multilib_src_configure() { | ||
# --disable-openssl bug #427526 | ||
ECONF_SOURCE="${S}" econf \ | ||
$(tc-is-static-only && echo --disable-shared) \ | ||
$(use_enable cpu_flags_x86_aes x86-aesni) \ | ||
$(use_enable doc documentation) \ | ||
$(use_enable gmp public-key) \ | ||
$(use_enable neon arm-neon) \ | ||
$(use_enable static-libs static) \ | ||
--disable-fat \ | ||
--disable-openssl | ||
} |