forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-crypt/eid-mw: bump to 4.1.9 wrt the gentoo bug, missed in previou…
…s commit Also Reduced DESCRIPTION to < 80 chars fixing the QA violation in only recent two versions. ebuild by proxy maintainer via the gentoo bug Gentoo bug: #564582 Package-Manager: portage-2.2.24
- Loading branch information
Ian Delaney
committed
Nov 11, 2015
1 parent
ef51f92
commit 729b379
Showing
3 changed files
with
81 additions
and
1 deletion.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST eid-mw-4.0.6-1480.tar.gz 4292450 SHA256 1ff3a7740a30891df2da12fca66cb5324dc286f9490ee839d61d9f1028b9127c SHA512 4b6ba684a43183e11cf29a73bee7bc6ecda24aa15029e55593d6ad3cc9f58726d551089c3c9f95f07d03847df70f2662a0ea9e3db5dd5591cc9b8b0e839d364b WHIRLPOOL cca8b871a2780dae282f5eed12cd79df0bb9d57c3c968ca740b7063ca3c48425be492d3dfcb7bee5c0037b14571df8b76b825540f52025b14afed8f718d56c22 | ||
DIST eid-mw-4.0.6-1620.tar.gz 4335514 SHA256 1ecb30f9f318bdb61a8d774fe76b948eb5841d4de6fee106029ed78daa7efbf2 SHA512 511bf6cf7a9a4d0a2232d95f1a6ba6f4fa8ee174cf919f88e1fa0c71357b9717544a6006ad412d7a0b4090c4c56ca86f8e6f69dabc6912bfd77a2e948cae8104 WHIRLPOOL b89ae4ba659e8dedd93f70368af1e058468cfd3761bec099276fadc017dcf21d245ceb8db001c3e82f30c7e6f670e13ab6c17e221c8c8ee02a45cc5833f39867 | ||
DIST eid-mw-4.1.4-v4.1.4.tar.gz 3475913 SHA256 2996960ea92504c7cee1953ccf4520ba78979c7771645e2b2c1207f94be0a308 SHA512 efcc4dbd0fa383896df9f5a7492b18beb5259cfa368a919ae18bd996e5976a67d0570c0fbccd5ab38ea95c31f48b92c145c526aa59866217a418a80a550d502f WHIRLPOOL 11e35b3649a0c3bd40e4c901ba4d922305dc2b4098018bd018ee71b963b08898e6295e4f71cb7180b0fc8e64d1afe01ce49bcaa36a60c065c2de84b81d19e398 | ||
DIST eid-mw-4.1.9-v4.1.9.tar.gz 3475708 SHA256 0c46c73b805884dd4ae739eb6025c137c1055ad119eac1ab37cb83eb32d92953 SHA512 bc61b3f212bfedf6f47f2841bc6c9b1198be5e3c7b382e3e28635c9e6f5c4ed8ccb118b105f668969fba31e49750cb1c5b129cd5b67a2725af122a8eae491b1c WHIRLPOOL 06b1f9780e984ac6c562bacab03936cd759ea1fce45687f09ae314d4fa77edce02c7ba4db5a9bc3fd739392f8b7b182b19b2734c1d21d63f6995c3cd572695d9 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,79 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
|
||
inherit eutils autotools mozextension multilib | ||
|
||
if [[ ${PV} == "9999" ]] ; then | ||
EGIT_REPO_URI="git://github.com/Fedict/${PN}.git | ||
https://github.com/Fedict/${PN}.git" | ||
inherit git-2 | ||
SRC_URI="" | ||
else | ||
MY_P="${P}-v${PV}" | ||
SRC_URI="https://downloads.services.belgium.be/eid/${MY_P}.tar.gz" | ||
KEYWORDS="~x86 ~amd64 ~arm" | ||
S="${WORKDIR}/${MY_P}" | ||
fi | ||
|
||
SLOT="0" | ||
LICENSE="LGPL-3" | ||
DESCRIPTION="Belgian Electronic Identity Card middleware by the Belgian Federal Government" | ||
|
||
HOMEPAGE="http://eid.belgium.be" | ||
|
||
IUSE="+gtk +xpi +dialogs" | ||
|
||
REQUIRED_USE=" | ||
dialogs? ( gtk )" | ||
|
||
RDEPEND="gtk? ( x11-libs/gtk+:* ) | ||
>=sys-apps/pcsc-lite-1.2.9 | ||
xpi? ( || ( >=www-client/firefox-bin-3.6.24 | ||
>=www-client/firefox-3.6.20 ) ) | ||
!app-misc/beid-runtime" | ||
|
||
DEPEND="${RDEPEND} | ||
virtual/pkgconfig" | ||
|
||
src_prepare() { | ||
use gtk || epatch "${FILESDIR}"/gtk_not_required_4.1.4.patch | ||
|
||
if [[ ${PV} == "9999" ]] ; then | ||
# Only in current git. Hopefully, in next release. | ||
sed -i -e 's:/beid/rsaref220:/rsaref220:' configure.ac | ||
sed -i -e 's:/beid::' cardcomm/pkcs11/src/libbeidpkcs11.pc.in | ||
fi | ||
|
||
if [[ ${PV} == "9999" ]] || ! use gtk ; then | ||
eautoreconf | ||
fi | ||
} | ||
|
||
src_configure() { | ||
econf $(use_enable dialogs) --disable-static | ||
} | ||
|
||
src_install() { | ||
emake DESTDIR="${D}" install | ||
|
||
if [[ ${PV} != "9999" ]] ; then | ||
# Automatically done in current git. Hopefully, in next release. | ||
rm doc/sdk/include/rsaref220/win32.h | ||
doheader -r doc/sdk/include/* | ||
fi | ||
if use xpi; then | ||
declare MOZILLA_FIVE_HOME | ||
if has_version '>=www-client/firefox-3.6.20'; then | ||
MOZILLA_FIVE_HOME="/usr/$(get_libdir)/firefox" | ||
xpi_install "${D}/usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/[email protected]" | ||
fi | ||
if has_version '>=www-client/firefox-bin-3.6.24'; then | ||
MOZILLA_FIVE_HOME="/opt/firefox" | ||
xpi_install "${D}/usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/[email protected]" | ||
fi | ||
fi | ||
rm -r "${D}/usr/share" "${D}"/usr/lib*/*.la | ||
} |