Skip to content

Commit

Permalink
mail-client/alot: version bump to 0.7.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Closes: https://bugs.gentoo.org/648592
Closes: gentoo#7262
  • Loading branch information
GuillaumeSeren authored and monsieurp committed Feb 23, 2018
1 parent 8408944 commit 72f7a18
Show file tree
Hide file tree
Showing 2 changed files with 89 additions and 0 deletions.
1 change: 1 addition & 0 deletions mail-client/alot/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST alot-0.3.7.tar.gz 1475759 BLAKE2B d14ba03f86dfb04f16644f27286e6a7314d0559b345d0430226d45430e99f5ed72eb35cad9c576bf88cdccbc83c5265eb09a30efb2254b79d6b85e5a30ef5a49 SHA512 a0b7e5a7b77f8cdee38c273eec2822bee2e7c409ab4b8803817a49d679dd53ff29750ba7f8a9214368cc7b0b17bd76a40b0263b4701b2ef695c7669316b1b116
DIST alot-0.5.1.tar.gz 1490645 BLAKE2B fd63ff7191fba3ee7fa3cf362cad9d684513fd6180263a2b888ee2cc00d55ca5442e273ed1b4e4012106db67404715eff4302ea25b89343ca0f467953402de33 SHA512 0194f163724fc5485aa89fe5354d16bdfdd3f539f6f3cfdb715e61835f3e632b8ac0daed44983a95c20eb0244c44c1d7801d262a5fd16ad63c3efd046e05b787
DIST alot-0.6.tar.gz 1527183 BLAKE2B 60e06d806bf5bfacdec485c3bcde6a5473bce2093abcc20d5e105b40f6d78bf93773c3b54311fdbbb632abe724a410d8941cfb0018842ee445ccea64c73a5033 SHA512 300b99d4919dd59d569de49195e33a3224bc28fbddf0b2aa6e3b419e030a22ec2d9acf389d67eb062cad9f2cd85f019cd6dff23e724491718e246397e70ed059
DIST alot-0.7.tar.gz 1539283 BLAKE2B 33e77f815c4f83fc08f1834a89a984309c1d4b89454d9bb0df625d00725c64769ce4989fa8df8f38d40d1c35fb78202880fedc0a0a5e7134f1938a03c79e7721 SHA512 542827c94e6cfc57699613b352527582dc2e365d957ba6b7e835584e8b83d0704452acd5ab8e4e1e408c283ec3400a8bbe465b2a8fad9f95fb330328c4fe81f8
88 changes: 88 additions & 0 deletions mail-client/alot/alot-0.7.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,88 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python2_7 )

inherit distutils-r1 vcs-snapshot

DESCRIPTION="Experimental terminal UI for net-mail/notmuch written in Python"
HOMEPAGE="https://github.com/pazz/alot"
SRC_URI="https://github.com/pazz/alot/tarball/${PV} -> ${P}.tar.gz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc test"

DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? ( dev-python/mock[${PYTHON_USEDEP}] )
"
RDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/configobj-4.7.0[${PYTHON_USEDEP}]
>=app-crypt/gpgme-1.9.0[python,${PYTHON_USEDEP}]
dev-python/python-magic[${PYTHON_USEDEP}]
>=dev-python/twisted-core-10.2.0[${PYTHON_USEDEP}]
>=dev-python/urwid-1.1.0[${PYTHON_USEDEP}]
>=dev-python/urwidtrees-1.0[${PYTHON_USEDEP}]
net-mail/mailbase
>=net-mail/notmuch-0.13[crypt,python]
"

python_prepare_all() {
find "${S}" -name '*.py' -exec sed -e '1i# -*- coding: utf-8 -*-' -i '{}' +

distutils-r1_python_prepare_all
}

python_compile_all() {
if use doc; then
emake -C docs html
HTML_DOCS=( docs/build/html/. )
fi
}

python_install_all() {
distutils-r1_python_install_all

insinto /usr/share/alot
doins -r extra
}

pkg_postinst() {
if [[ -z ${REPLACING_VERSIONS} ]] ; then
echo
elog "If you are new to Alot you may want to take a look at"
elog "the user manual:"
elog " https://alot.readthedocs.io/en/latest/"
echo
else
local rv
for rv in ${REPLACING_VERSIONS} ; do
if [[ "0.3.2" == "${rv}" ]]; then
ewarn ""
ewarn "The syntax of theme-files and custom tags-sections of the config"
ewarn "has been changed. You have to revise your config. There are"
ewarn "converter scripts in /usr/share/alot/extra to help you out with"
ewarn "this:"
ewarn ""
ewarn " * tagsections_convert.py for your ~/.config/alot/config"
ewarn " * theme_convert.py to update your custom theme files"
break;
fi
if [[ "0.5.1" == "${rv}" ]]; then
ewarn ""
ewarn "Since 0.6 version the GPG engine has switched to app-crypt/gpgme"
ewarn "to use GPG signing operations, you can pass the key id has arg"
ewarn "or setup the gpg_key value in your config file, see"
ewarn " https://alot.readthedocs.io/en/latest/usage/crypto.html?highlight=gpg"
ewarn ""
break;
fi
done
fi
}

0 comments on commit 72f7a18

Please sign in to comment.