forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
gnome-extra/gnome-shell-extension-applications-overview-tooltip: Bump…
… to v14 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Pacho Ramos <[email protected]>
- Loading branch information
Showing
2 changed files
with
50 additions
and
0 deletions.
There are no files selected for viewing
1 change: 1 addition & 0 deletions
1
gnome-extra/gnome-shell-extension-applications-overview-tooltip/Manifest
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST gnome-shell-extension-applications-overview-tooltip-12.tar.gz 27394 BLAKE2B 169460c7063fda0f664688303984c4a5c7fcd8a6b32281c2eb630ebea8143b95e96038f130b09c939371474b5ef27656cf77eec942412fcf3908a5d9fb8ae202 SHA512 4c993256d1f6d7d3a2c72c88f6f88facf7ff8237d489950484f54a68f09741e526f0e0a7c2862251fc2579fd3cdd496c9136bb222374abfacbace1615e263239 | ||
DIST gnome-shell-extension-applications-overview-tooltip-14.tar.gz 27058 BLAKE2B 442e1b144358c40c6132ab2a067bb29439e826ccd540583a6e95d35841bca3eda53ac9b6004285c8ab63006d9e71dbdb46f0fb77310366cf976381bb70b50223 SHA512 6e5805f720e262181e4519ec8a19cf57dae41e3dcff3da4a4a1bc4a132bcc23aae575cc15aa0a0f5f04fe1a25a9ff3e03d5bcacb326c7bbc8d0b28351e0ecbfe |
49 changes: 49 additions & 0 deletions
49
...plications-overview-tooltip/gnome-shell-extension-applications-overview-tooltip-14.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,49 @@ | ||
# Copyright 1999-2021 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
inherit gnome2-utils | ||
|
||
DESCRIPTION="Show tooltip with full name and description" | ||
HOMEPAGE="https://github.com/RaphaelRochet/applications-overview-tooltip" | ||
SRC_URI="https://github.com/RaphaelRochet/applications-overview-tooltip/archive/v${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
# https://github.com/RaphaelRochet/applications-overview-tooltip/issues/7 | ||
LICENSE="public-domain" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="" | ||
|
||
RDEPEND=" | ||
app-eselect/eselect-gnome-shell-extensions | ||
>=gnome-base/gnome-shell-40 | ||
" | ||
DEPEND="" | ||
BDEPEND="" | ||
|
||
S="${WORKDIR}/${P/gnome-shell-extension-}" | ||
extension_uuid="applications-overview-tooltip@RaphaelRochet" | ||
|
||
src_install() { | ||
einstalldocs | ||
insinto /usr/share/glib-2.0/schemas | ||
doins schemas/*.xml | ||
rm -rf README.md schemas || die | ||
insinto /usr/share/gnome-shell/extensions/"${extension_uuid}" | ||
doins -r * | ||
} | ||
|
||
pkg_preinst() { | ||
gnome2_schemas_savelist | ||
} | ||
|
||
pkg_postinst() { | ||
gnome2_schemas_update | ||
ebegin "Updating list of installed extensions" | ||
eselect gnome-shell-extensions update | ||
eend $? | ||
} | ||
|
||
pkg_postrm() { | ||
gnome2_schemas_update | ||
} |