Skip to content

Commit

Permalink
app-metrics/prometheus-bin: new package, binary version of prometheus
Browse files Browse the repository at this point in the history
This is needed because prometheus now includes nodejs and the build
system uses yarn.

Signed-off-by: William Hubbs <[email protected]>
  • Loading branch information
william-hubbs authored and williamh committed Jan 27, 2020
1 parent 1904268 commit 7642d02
Show file tree
Hide file tree
Showing 6 changed files with 94 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-metrics/prometheus-bin/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST prometheus-2.15.2.linux-amd64.tar.gz 59204993 BLAKE2B 700d61063cddea02ca4445257b11b782c3b6fc84ed3d48f8d196c5602819f0d44b218d15b870281293bf0661929b02930b937e66fec34918b81cd3d010a6fa21 SHA512 a3b95fe6101d5587329d84adb18c0c261babe5a909e62ab1a39f42df28c058d311b0b2ea9ecbdad9227789ed83c0fae4a12776348999cda3a70cdc457f6d3611
2 changes: 2 additions & 0 deletions app-metrics/prometheus-bin/files/prometheus.confd
Original file line number Diff line number Diff line change
@@ -0,0 +1,2 @@
# arguments for Prometheus
command_args=""
34 changes: 34 additions & 0 deletions app-metrics/prometheus-bin/files/prometheus.initd
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
#!/sbin/openrc-run
# Copyright 2016-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

description="Prometheus monitoring system and time series database"
pidfile=/var/run/${RC_SVCNAME}.pid
user=${user:-${RC_SVCNAME}}
group=${group:-${RC_SVCNAME}}
command_user=${user}:${group}

command="/usr/bin/prometheus"
command_args="${command_args:---config.file=/etc/prometheus/prometheus.yml --storage.tsdb.path=/var/lib/prometheus/data}"
command_background="true"
error_log=/var/log/${RC_SVCNAME}/${RC_SVCNAME}.log
output_log=/var/log/${RC_SVCNAME}/${RC_SVCNAME}.log

extra_started_commands="reload"

depend() {
after net
}

reload() {
ebegin "Reloading configuration for ${RC_SVCNAME}"
case "$supervisor" in
supervise-daemon)
supervise-daemon ${RC_SVCNAME} --signal HUP
;;
*)
start-stop-daemon --signal HUP --pidfile "${pidfile}"
;;
esac
eend $? "Failed to reload ${RC_SVCNAME}"
}
8 changes: 8 additions & 0 deletions app-metrics/prometheus-bin/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>William Hubbs</name>
</maintainer>
</pkgmetadata>
48 changes: 48 additions & 0 deletions app-metrics/prometheus-bin/prometheus-bin-2.15.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
# Copyright 2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

DESCRIPTION="prometheus monitoring system and time series database"
HOMEPAGE="http://prometheus.io"
MY_PN=${PN%%-bin}
MY_P=${MY_PN}-${PV}
SRC_URI="https://github.com/prometheus/prometheus/releases/download/v${PV}/${MY_P}.linux-amd64.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"

QA_PREBUILT=".*"
RESTRICT="strip"

DEPEND="acct-group/prometheus
acct-user/prometheus
!app-metrics/prometheus"
RDEPEND="${DEPEND}"

S="${WORKDIR}/${MY_P}.linux-amd64"

src_install() {
dobin prometheus promtool tsdb
insinto /usr/share/prometheus
doins -r console_libraries consoles
insinto /etc/prometheus
doins prometheus.yml
dosym ../../usr/share/prometheus/console_libraries /etc/prometheus/console_libraries
dosym ../../usr/share/prometheus/consoles /etc/prometheus/consoles

newinitd "${FILESDIR}"/prometheus.initd prometheus
newconfd "${FILESDIR}"/prometheus.confd prometheus
keepdir /var/log/prometheus /var/lib/prometheus
fowners prometheus:prometheus /var/log/prometheus /var/lib/prometheus
}

pkg_postinst() {
if has_version '<net-analyzer/prometheus-2.0.0_rc0'; then
ewarn "Old prometheus 1.x TSDB won't be converted to the new prometheus 2.0 format"
ewarn "Be aware that the old data currently cannot be accessed with prometheus 2.0"
ewarn "This release requires a clean storage directory and is not compatible with"
ewarn "files created by previous beta releases"
fi
}
1 change: 1 addition & 0 deletions app-metrics/prometheus/prometheus-2.13.1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -17,6 +17,7 @@ SLOT="0"
IUSE=""

DEPEND="
!app-metrics/prometheus-bin
>=dev-lang/go-1.12
>=dev-util/promu-0.3.0"

Expand Down

0 comments on commit 7642d02

Please sign in to comment.