Skip to content

Commit

Permalink
dev-libs/libarcus: Version bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.2
  • Loading branch information
alexxy committed Dec 5, 2016
1 parent 425e4e9 commit 77af84d
Show file tree
Hide file tree
Showing 2 changed files with 42 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/libarcus/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST libarcus-1.0.0_pre20160307.tar.gz 40461 SHA256 ca4f286cc8bae08ddf166fa470f8381f25cf61629168ca965a2f4079e758ebfc SHA512 ec654fbe2d34ad60afd0c1f3745e9f0ef5709e3698ea78d17089dad5e86cb686f38a0ea4cca07b6911058ebdf61c17b51a89c002cbf74cbbd4a68a133d8984e5 WHIRLPOOL 0c688c0fb20022a14bce6870fd1da84c891b2f68f335d9f6ebcc25432dab51823b3e9d20be8a3a51a69bc1832c3cd55576c91e0246fcc15fc4456916d5278b28
DIST libarcus-2.3.1.tar.gz 41641 SHA256 084061c6b19effbc86648915f0df3e4a8e64356487d111ac75dd2ee052ad43e8 SHA512 24ac5dd784993658e823dc7111e0ff31e77f8d95c4f024a84a7db731577ba595427de0917911fe7e0ba5848241ad33237fe6edb90a5191741e9523f616dd06a6 WHIRLPOOL 912893ee2314bb16ac580169ecc39e2f23470500b699b6d2f9b3e7dda62341268754c05774693305bbfb4a5bbcaee9aeec7695f61eaa86eab6ff1494720445de
41 changes: 41 additions & 0 deletions dev-libs/libarcus/libarcus-2.3.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="6"

PYTHON_COMPAT=( python3_4 python3_5 )
inherit cmake-utils python-single-r1

MY_PN="libArcus"

DESCRIPTION="This library facilitates communication between Cura and its backend"
HOMEPAGE="https://github.com/Ultimaker/libArcus"
SRC_URI="https://github.com/Ultimaker/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="AGPL-3+"
SLOT="0/2"
IUSE="examples python static-libs"
KEYWORDS="~amd64 ~x86"

RDEPEND="${PYTHON_DEPS}
dev-python/sip[${PYTHON_USEDEP}]
>=dev-libs/protobuf-3:=
>=dev-python/protobuf-python-3:*[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}"
S="${WORKDIR}/${MY_PN}-${PV}"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"

pkg_setup() {
use python && python-single-r1_pkg_setup
}

src_configure() {
local mycmakeargs=(
-DBUILD_PYTHON=$(usex python ON OFF)
-DBUILD_EXAMPLES=$(usex examples ON OFF)
-DBUILD_STATIC=$(usex static-libs ON OFF)
)
use python && mycmakeargs+=( -DPYTHON_SITE_PACKAGES_DIR="$(python_get_sitedir)" )
cmake-utils_src_configure
}

0 comments on commit 77af84d

Please sign in to comment.