forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
kde-frameworks: Add KDE Frameworks 5.70.0
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <[email protected]>
- Loading branch information
Showing
166 changed files
with
3,218 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST attica-5.67.0.tar.xz 64580 BLAKE2B 8add0188c07192eb9dd0597c31410cc7f81f73ad588927622f5320dbeb0f5e8cabb88fef5cd854b75c8d0f45639804327d2f5ab2c617cb53b2601d936f0dc0ca SHA512 59965df4eea792563cb46fd6d6ae8604dff5547917ea22a0ae00659d692ec05851768f66860de15c37631f918c1b54fc07264e9df123da3235c5a43576105cd7 | ||
DIST attica-5.69.0.tar.xz 67600 BLAKE2B b98d9be0910ca006b0d3da21c38eb56c130053c443e2948989d62e5de5f4c7a81b472f70e474bcdd4b5a6c75b9b3daf557fa567c05c3a410031aa81c95e3d91e SHA512 b7d191c6e42e7e139bee18e69c7f5572333ce0eec0c845a2514016b1ab83bbae0cbbb67909139c29b7b78b8849a68d630d04fdcc9d3f454daa610ff07c290f86 | ||
DIST attica-5.70.0.tar.xz 67620 BLAKE2B 3773e6b8442d671429d904b5fc6ef82d5ea58f37b494a86d7647e1692a71da5d6539239f9b74011897e358d13ab2d1ed47926c37f2c93c8f7140bc8df3ee31e6 SHA512 bb88e7bf34b1d3c958e31ad1591bdc5620361a300fcba957ecb017c31227b4ac80a94523d7b40f9a62a4a5d45a2840d37aa199c7305e6da471d4ebaee84c9630 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,26 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
QTMIN=5.12.3 | ||
inherit ecm kde.org | ||
|
||
DESCRIPTION="Framework providing access to Open Collaboration Services" | ||
LICENSE="LGPL-2.1+" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86" | ||
IUSE="" | ||
|
||
RDEPEND=" | ||
>=dev-qt/qtnetwork-${QTMIN}:5 | ||
" | ||
DEPEND="${RDEPEND}" | ||
|
||
src_test() { | ||
# requires network access, bug #661230 | ||
local myctestargs=( | ||
-E "(providertest)" | ||
) | ||
|
||
ecm_src_test | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST baloo-5.67.0.tar.xz 273900 BLAKE2B 059ae680e887b5fcdbeb6d68c6760f035660919d727f2d46cf838e6426b0f83625faecbc754518e6968262ef3efb2fb9ea9852ab652e0d80629de9dc59db781f SHA512 065fb29c86e29a848c0bcac68851eb6b02b46e9f32269175a6d8cae80325dc619e020ac1c1f564998381a678d8918c1d7ddb81697e475663816eecb127831d5c | ||
DIST baloo-5.69.0.tar.xz 278212 BLAKE2B 39492dc8094b718f864971146d6e332f7f04e3890a1518870095fb3a92eaff45a08c099cb4bea68405ad490fea3aa3941d85d3b7ed0bbeb939cc5be6933e326d SHA512 0716208265b141c9e4cf4920c310b73f26e3abb56bddd60d8ea426f2e26b0cfe66c8b93cab09707ef7b94444d43b8336a1274e862a811e20c0437faf65cccc66 | ||
DIST baloo-5.70.0.tar.xz 273108 BLAKE2B 9ece044d50462f19b4c27543f5e108c80031dd9d1782ebfbf46c7b71ce9e96e0160adb5b072afbff239e5a43fb04a33905c906a3f6784bd87274cd0982cb42d1 SHA512 9d2455c29f7f5609897d06271a62c285e03370fdb8d842be252953f8b1644351b6bf8f5dc2f685bfa1cab9ed494747b59eccfd4f0f616625822c72e97692a390 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,35 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
ECM_TEST="forceoptional" | ||
PVCUT=$(ver_cut 1-2) | ||
QTMIN=5.12.3 | ||
VIRTUALX_REQUIRED="test" | ||
inherit ecm kde.org | ||
|
||
DESCRIPTION="Framework for searching and managing metadata" | ||
LICENSE="LGPL-2+" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86" | ||
IUSE="" | ||
|
||
DEPEND=" | ||
>=dev-db/lmdb-0.9.17 | ||
>=dev-qt/qtdbus-${QTMIN}:5 | ||
>=dev-qt/qtdeclarative-${QTMIN}:5 | ||
>=dev-qt/qtgui-${QTMIN}:5 | ||
>=dev-qt/qtwidgets-${QTMIN}:5 | ||
=kde-frameworks/kconfig-${PVCUT}*:5 | ||
=kde-frameworks/kcoreaddons-${PVCUT}*:5 | ||
=kde-frameworks/kcrash-${PVCUT}*:5 | ||
=kde-frameworks/kdbusaddons-${PVCUT}*:5 | ||
=kde-frameworks/kfilemetadata-${PVCUT}*:5 | ||
=kde-frameworks/ki18n-${PVCUT}*:5 | ||
=kde-frameworks/kidletime-${PVCUT}*:5 | ||
=kde-frameworks/kio-${PVCUT}*:5 | ||
=kde-frameworks/solid-${PVCUT}*:5 | ||
" | ||
RDEPEND="${DEPEND}" | ||
|
||
RESTRICT+=" test" # bug 624250 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST bluez-qt-5.67.0.tar.xz 100760 BLAKE2B 67420b4ed6e8109071caf4f5f350fcd83234e6f2ac91f73702027346c418d638eb3a26031646ac626ea97d59d10ece6ea16a0215e66ba76dd7c778edb87dec44 SHA512 a90f79960d22ff3fb939d09df226bb5ae8a66e93963b0ff73f6eafcf4d21d003b2e690843527bcfca66208f1e4c1da04d2bf368ce09ba2112a35c2af5cde2787 | ||
DIST bluez-qt-5.69.0.tar.xz 102764 BLAKE2B 9289bef38f1c87702e0a84a6f5f2806a4bbe3fe323a46743e693d62e729ed103ab9b28c376abc823603892679f6e73fe4e7ef17779915253175b663744fcec2e SHA512 d59f12c750c0f47f1ce855f3787629c4a43977d32dd7fdebe1ab57ca1d08eab30da063e827d5266f8b0e316bc3d479857407875e1e1d6e51fd9379e1ff41bd1e | ||
DIST bluez-qt-5.70.0.tar.xz 102992 BLAKE2B 01a2368018a31502634f3dda2054a0d1bf2c0c55a09995e3257a1950d780beebcfe66def2efa8c3b1cb5ce9eefe0166183fa75460a91cfbeafd4687673a361f6 SHA512 e9ed0c53c1100109ba02c7fcfb81bbc2162b0904219ae35a7455b7653086b1761820168a0bb959f65369dd7b8ac4b6726351e0e6a1fa98fac2bc513f0fbd9df0 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,38 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
QTMIN=5.12.3 | ||
VIRTUALX_REQUIRED="test" | ||
inherit ecm kde.org udev | ||
|
||
DESCRIPTION="Qt wrapper for Bluez 5 DBus API" | ||
LICENSE="LGPL-2" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86" | ||
IUSE="" | ||
|
||
DEPEND=" | ||
>=dev-qt/qtdbus-${QTMIN}:5 | ||
>=dev-qt/qtdeclarative-${QTMIN}:5 | ||
>=dev-qt/qtnetwork-${QTMIN}:5 | ||
" | ||
RDEPEND="${DEPEND}" | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DUDEV_RULES_INSTALL_DIR="$(get_udevdir)/rules.d" | ||
) | ||
|
||
ecm_src_configure | ||
} | ||
|
||
src_test() { | ||
# parallel tests fail, bug 609248; managertest hangs, bug 668196 | ||
local myctestargs=( | ||
-j1 | ||
-E "(managertest)" | ||
) | ||
|
||
ecm_src_test | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST breeze-icons-5.67.0.tar.xz 2731080 BLAKE2B 9e8333c17ffc31d2ebd0b7f1b08712125f6904182ced3588bf97232ce93c1f4a96a7a1516666526ebeddb7ed9dec57e6657cb07da6939b3c1dd6b83f08a329ee SHA512 2b35f780888f21600230ed29b4e7d1f3b06981fb5f899f267a895d0d8a3aa3b85c915b3a262bf2864989202d0130fb7f79df76c1c856fdf7e97170b5a7ced9af | ||
DIST breeze-icons-5.69.0.tar.xz 2683836 BLAKE2B 16298f8932b3f7968c1fba4e26832396b03ea19d39997f6bef7b0b040a166300e712f09fd9db822f9bad2e9463fb7198f7492030d8a149e692b9fe5ee5135a54 SHA512 6fb05d8e150d7c3d7262eec260cdc762fae71ae25207423bb45523290369e9568f430e392a56dd119c62a93026deaa829e21ed7300028fac9fdaee6dc8cb5a3d | ||
DIST breeze-icons-5.70.0.tar.xz 2647980 BLAKE2B 133bf41012b0eb981193efa6a3b9e770ee19eca0aed4003bf9c201794944eda1c19afcb0070bf1294f95b339fc7db8c94e56d4f03543942ed8f8514ed29ad47a SHA512 fc82e736fde136d7207e5ce05e276df73d1b419da70a709c882142a232f9fcc91cb157b103b6208e132b12748b8fee487d95e08f87f4111f5a174221bb9c85b9 |
35 changes: 35 additions & 0 deletions
35
kde-frameworks/breeze-icons-rcc/breeze-icons-rcc-5.70.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,35 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
KDE_ORG_NAME="breeze-icons" | ||
PVCUT=$(ver_cut 1-2) | ||
inherit cmake kde.org | ||
|
||
DESCRIPTION="Breeze SVG icon theme binary resource" | ||
LICENSE="LGPL-3" | ||
KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86" | ||
IUSE="test" | ||
|
||
BDEPEND=" | ||
dev-qt/qtcore:5 | ||
>=kde-frameworks/extra-cmake-modules-${PVCUT}:5 | ||
test? ( app-misc/fdupes ) | ||
" | ||
DEPEND="test? ( dev-qt/qttest:5 )" | ||
|
||
RESTRICT+=" !test? ( test )" | ||
|
||
src_prepare() { | ||
cmake_src_prepare | ||
use test || cmake_comment_add_subdirectory autotests | ||
} | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DBINARY_ICONS_RESOURCE=ON | ||
-DSKIP_INSTALL_ICONS=ON | ||
) | ||
cmake_src_configure | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST breeze-icons-5.67.0.tar.xz 2731080 BLAKE2B 9e8333c17ffc31d2ebd0b7f1b08712125f6904182ced3588bf97232ce93c1f4a96a7a1516666526ebeddb7ed9dec57e6657cb07da6939b3c1dd6b83f08a329ee SHA512 2b35f780888f21600230ed29b4e7d1f3b06981fb5f899f267a895d0d8a3aa3b85c915b3a262bf2864989202d0130fb7f79df76c1c856fdf7e97170b5a7ced9af | ||
DIST breeze-icons-5.69.0.tar.xz 2683836 BLAKE2B 16298f8932b3f7968c1fba4e26832396b03ea19d39997f6bef7b0b040a166300e712f09fd9db822f9bad2e9463fb7198f7492030d8a149e692b9fe5ee5135a54 SHA512 6fb05d8e150d7c3d7262eec260cdc762fae71ae25207423bb45523290369e9568f430e392a56dd119c62a93026deaa829e21ed7300028fac9fdaee6dc8cb5a3d | ||
DIST breeze-icons-5.70.0.tar.xz 2647980 BLAKE2B 133bf41012b0eb981193efa6a3b9e770ee19eca0aed4003bf9c201794944eda1c19afcb0070bf1294f95b339fc7db8c94e56d4f03543942ed8f8514ed29ad47a SHA512 fc82e736fde136d7207e5ce05e276df73d1b419da70a709c882142a232f9fcc91cb157b103b6208e132b12748b8fee487d95e08f87f4111f5a174221bb9c85b9 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,33 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
PVCUT=$(ver_cut 1-2) | ||
inherit cmake kde.org | ||
|
||
DESCRIPTION="Breeze SVG icon theme" | ||
LICENSE="LGPL-3" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86" | ||
IUSE="test" | ||
|
||
BDEPEND=" | ||
dev-qt/qtcore:5 | ||
>=kde-frameworks/extra-cmake-modules-${PVCUT}:5 | ||
test? ( app-misc/fdupes ) | ||
" | ||
DEPEND="test? ( dev-qt/qttest:5 )" | ||
|
||
RESTRICT+=" !test? ( test )" | ||
|
||
src_prepare() { | ||
cmake_src_prepare | ||
use test || cmake_comment_add_subdirectory autotests | ||
} | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DBINARY_ICONS_RESOURCE=OFF | ||
) | ||
cmake_src_configure | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST extra-cmake-modules-5.67.0.tar.xz 339812 BLAKE2B 9fa1c93e512341f6ae91dd2bb7126bdc55b5d1df6390a54f1fa7506f1f903a005103d1259f7962e94c0f2e27bf82d8d4c5320053b197c18305d32ba870ced67e SHA512 1a0e185ea4eac16d57c34f140a4709c0bcd9baaa7e0727ab5c1bfee88fe08efe23dc3634d8f73abade98ad6f2dbf529563e0778f0fbeddaa50b435e12b674229 | ||
DIST extra-cmake-modules-5.69.0.tar.xz 342704 BLAKE2B 1be871480bc6b61e6b69d6ee11bff047dc491a0300c8c1a6d99e870bb9a0c50affef1a2b973831a2ee1d8154e288952d643b873bdee206ea5e71fb6fa086c4b7 SHA512 e79be580b3254331fd8008be36c9e537e18f0d2b8100f59ae0ccf003a8e15560432cc31e59b232b413f34e79e0a30bc45990ffc3cf259de34af8134fda76606d | ||
DIST extra-cmake-modules-5.70.0.tar.xz 343476 BLAKE2B efcf47af54decc383c150aff14628408f6e77001ba4c6bc8a6f1636e62e20c06fb435a0bf7d93ce610ed7404ae186b732d994d2a530f2d65207cee70cdac8af8 SHA512 cbee488db0ccef4c876770ec073408208037d791ea67d9f72937c4fa20765f69d9312a3f9e2106526d4fb0a76e25d7fed13178209f8e0b1b3f01b76be17d4784 |
76 changes: 76 additions & 0 deletions
76
kde-frameworks/extra-cmake-modules/extra-cmake-modules-5.70.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,76 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
PYTHON_COMPAT=( python3_{6,7,8} ) | ||
QTMIN=5.12.3 | ||
inherit cmake kde.org python-any-r1 | ||
|
||
DESCRIPTION="Extra modules and scripts for CMake" | ||
HOMEPAGE="https://cgit.kde.org/extra-cmake-modules.git" | ||
|
||
LICENSE="BSD" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86" | ||
IUSE="doc test" | ||
|
||
BDEPEND=" | ||
doc? ( | ||
${PYTHON_DEPS} | ||
$(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]') | ||
>=dev-qt/qthelp-${QTMIN}:5 | ||
) | ||
test? ( | ||
>=dev-qt/linguist-tools-${QTMIN}:5 | ||
>=dev-qt/qtcore-${QTMIN}:5 | ||
) | ||
" | ||
RDEPEND=" | ||
app-arch/libarchive[bzip2] | ||
" | ||
|
||
RESTRICT+=" !test? ( test )" | ||
|
||
PATCHES=( | ||
"${FILESDIR}/${PN}-5.49.0-no-fatal-warnings.patch" | ||
"${FILESDIR}/${PN}-5.65.0-disable-qmlplugindump.patch" | ||
) | ||
|
||
python_check_deps() { | ||
has_version "dev-python/sphinx[${PYTHON_USEDEP}]" | ||
} | ||
|
||
pkg_setup() { | ||
use doc && python-any-r1_pkg_setup | ||
} | ||
|
||
src_prepare() { | ||
cmake_src_prepare | ||
# Requires PyQt5, bug #680256 | ||
sed -i -e "/^if(NOT SIP_Qt5Core_Mod_FILE)/s/NOT SIP_Qt5Core_Mod_FILE/TRUE/" \ | ||
tests/CMakeLists.txt || die "failed to disable GenerateSipBindings tests" | ||
} | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DDOC_INSTALL_DIR=/usr/share/doc/"${PF}" | ||
-DBUILD_QTHELP_DOCS=$(usex doc) | ||
-DBUILD_HTML_DOCS=$(usex doc) | ||
-DBUILD_MAN_DOCS=$(usex doc) | ||
-DBUILD_TESTING=$(usex test) | ||
) | ||
|
||
cmake_src_configure | ||
} | ||
|
||
src_test() { | ||
# ECMToolchainAndroidTest passes but then breaks src_install | ||
# ECMPoQmToolsTest is broken, bug #627806 | ||
# possible race condition with multiple jobs, bug #701854 | ||
local myctestargs=( | ||
-j1 | ||
-E "(ECMToolchainAndroidTest|ECMPoQmToolsTest)" | ||
) | ||
|
||
cmake_src_test | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST frameworkintegration-5.67.0.tar.xz 1753624 BLAKE2B cf70bed5acf65240568aafe7b025db339550abc0226d1f560d24636e4368955028148d9dbdf47afbe2e0f98850c9112aaf7ffc02966ffb48e27814adfc7cb65c SHA512 47ec7ebc2b1067074620a5a9e39f5aa664595569fc2d4a1c591e34e9ac52502fffd51f7707a522bf4028f50064f82dfafe2c6b46faa3b0f212b766e6f2ac2186 | ||
DIST frameworkintegration-5.69.0.tar.xz 1754048 BLAKE2B 8809b3cdf5f2c61d4370266b12c50bb0673ea4a83c8677d44a9d510392e5ddc5b8f2e77e4bd70d5b2de62753dc8661d3f4dd5995bea73f77f59198349715f0e4 SHA512 2c217182a083cc7adde2460716e4ee8cb02a1583d002b5fdbd1e3a570e92ee8faf8fc6520f8debccf3dc8fc143352379054b7a15fad05c21cd658969c5bfdf17 | ||
DIST frameworkintegration-5.70.0.tar.xz 1753940 BLAKE2B 5da86d4b7fe8a696e217273ff468c668ec1e04c138dd756a0a9280fbd6acb99f9cbd3bbce1790886de50335d036e7a99a83f1ea4ad4103101ecc46878d0e071b SHA512 70a72388315c0ca1625bb279b15a9df1693aed9a6dd470af8744b856e5c7cc458b0ffcc384489889e8c3e753edb03062b41cc688361498e45ac3a26d7be70a34 |
44 changes: 44 additions & 0 deletions
44
kde-frameworks/frameworkintegration/frameworkintegration-5.70.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,44 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
ECM_QTHELP="false" | ||
PVCUT=$(ver_cut 1-2) | ||
QTMIN=5.12.3 | ||
VIRTUALX_REQUIRED="test" | ||
inherit ecm kde.org | ||
|
||
DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces" | ||
|
||
LICENSE="LGPL-2+" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86" | ||
IUSE="" | ||
|
||
# drop qtwidgets subslot operator when QT_MINIMAL >= 5.14.0 | ||
RDEPEND=" | ||
>=dev-qt/qtgui-${QTMIN}:5 | ||
>=dev-qt/qtwidgets-${QTMIN}:5= | ||
=kde-frameworks/kconfig-${PVCUT}*:5 | ||
=kde-frameworks/kconfigwidgets-${PVCUT}*:5 | ||
=kde-frameworks/ki18n-${PVCUT}*:5 | ||
=kde-frameworks/kiconthemes-${PVCUT}*:5 | ||
=kde-frameworks/knewstuff-${PVCUT}*:5 | ||
=kde-frameworks/knotifications-${PVCUT}*:5 | ||
" | ||
DEPEND="${RDEPEND} | ||
=kde-frameworks/kpackage-${PVCUT}*:5 | ||
=kde-frameworks/kwidgetsaddons-${PVCUT}*:5 | ||
" | ||
|
||
# requires running Plasma environment | ||
RESTRICT+=" test" | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DCMAKE_DISABLE_FIND_PACKAGE_AppStreamQt=ON | ||
-DCMAKE_DISABLE_FIND_PACKAGE_packagekitqt5=ON | ||
) | ||
|
||
ecm_src_configure | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST kactivities-stats-5.67.0.tar.xz 63124 BLAKE2B 4645d4bdd5e9cc4b17105f3dee61993441aee849ff31392f3e53db4a0ba1685d1d28fdaa69f2a1882869c46ac0ad7d7a5641ac0a801d7846289fa63a9a66fe2f SHA512 ccd66e179efb5ecc4569ac7fb6897793b6b172cc2b6a458d8610fc1fb35fc1a817a56de8e27b290beb2f941847a0da568c9bf213029cb0dd0a4f0fa5d03c9c55 | ||
DIST kactivities-stats-5.69.0.tar.xz 63064 BLAKE2B ed027d0a2b6a0d1f3ed2718a5526db3b1dae35df9d544de4e0473f39cfc5b4362a7d7dbef73b9918fee14c161c89b698742cc09bad894cacc7167b62330f7ad5 SHA512 9b7e4e2feaec4e68db7b30617f11934cd31b3f15a73ac882664dba3c895fc75bce84bfa6de52e1c86a894d836a3ee7821d6b9f9cff93acdf67609e597612df59 | ||
DIST kactivities-stats-5.70.0.tar.xz 63188 BLAKE2B 44c7505ff689feff668f53f2b2af5cc57838348520ea55eb4cc7c82d0bbe9503295b13d10325375cb1ae2e1b36424f2f29306b4f9f6eeaf1bde7740d6a6d98a0 SHA512 4d04fbb381fbc878d92315e5ba4809b607e54c48f99ecafddf9e77efcf485335f7b364c70e45184c7af4618620a8806f3abcd1c0b56c1de4d75f23f4bbf7e4db |
23 changes: 23 additions & 0 deletions
23
kde-frameworks/kactivities-stats/kactivities-stats-5.70.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,23 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
PVCUT=$(ver_cut 1-2) | ||
QTMIN=5.12.3 | ||
inherit ecm kde.org | ||
|
||
DESCRIPTION="Framework for getting the usage statistics collected by the activities service" | ||
LICENSE="LGPL-2+" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86" | ||
IUSE="" | ||
|
||
RDEPEND=" | ||
>=dev-qt/qtdbus-${QTMIN}:5 | ||
>=dev-qt/qtsql-${QTMIN}:5 | ||
=kde-frameworks/kactivities-${PVCUT}*:5 | ||
=kde-frameworks/kconfig-${PVCUT}*:5 | ||
" | ||
DEPEND="${RDEPEND} | ||
>=dev-libs/boost-1.54 | ||
" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST kactivities-5.67.0.tar.xz 61204 BLAKE2B 6d9d25126317e763da4fa572ed0495fa1d8f1b5c6a675892753278d55479e0db55e1aa288bc4bb289488199f0857fe72cc206b79edf33e7e6e3676af568227d5 SHA512 d66413643b04bf10941db0fb61e106f0153eb23afdb7cb33814d4000e64ce5973c0f2b9098fe89d95168f4058dcfa9d2f6031d319692fd3aba46b671da8a4df7 | ||
DIST kactivities-5.69.0.tar.xz 61500 BLAKE2B 4ec675dfc20040847f7ec30b3d0c663285e4373db63baaebfa5ed1445be3fa62d5f6718e27881c62bd3de015e6597c82a8ed8117a0476bd54624559244d0d803 SHA512 e74f914289145a58f5334672062e1a2fb36ca161f60472bf3ee68e86f741e672aac6ec5d5e790ee216f0a9f9c3e1ec301c5f1b8c2112defdcfffd70c30af11cd | ||
DIST kactivities-5.70.0.tar.xz 61384 BLAKE2B b98fe9d53893250478adb8d89df2ddb9c27ab8f59c1586adc0343bd407e180fb7b78f1d989d07ac0ebe21f55c79d4005edfd8cac46566cb66193eee93e6d3b74 SHA512 da5f10f4b255cf38f87b7fb2fc24273b00f571ec138ccbfcb72a08079240ca92bf0c816129c30fb23b4636e79bf6c5bc53d2d14cf337130528568809723b2346 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,29 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
PVCUT=$(ver_cut 1-2) | ||
PLASMA_MINIMAL=5.16.5 | ||
QTMIN=5.12.3 | ||
inherit ecm kde.org | ||
|
||
DESCRIPTION="Framework for working with KDE activities" | ||
LICENSE="|| ( LGPL-2.1 LGPL-3 )" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86" | ||
IUSE="" | ||
|
||
COMMON_DEPEND=" | ||
=kde-frameworks/kconfig-${PVCUT}*:5 | ||
=kde-frameworks/kcoreaddons-${PVCUT}*:5 | ||
>=dev-qt/qtdbus-${QTMIN}:5 | ||
>=dev-qt/qtdeclarative-${QTMIN}:5[widgets] | ||
>=dev-qt/qtgui-${QTMIN}:5 | ||
>=dev-qt/qtsql-${QTMIN}:5 | ||
" | ||
RDEPEND="${COMMON_DEPEND} | ||
>=kde-plasma/kactivitymanagerd-${PLASMA_MINIMAL}:5 | ||
" | ||
DEPEND="${COMMON_DEPEND} | ||
>=dev-libs/boost-1.54 | ||
" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST kapidox-5.67.0.tar.xz 396744 BLAKE2B ab7fe4609199182dff558f339010ef13ac8ce927fc2c57bf84734b39b2a5253dc1432eed2ab5affd9d1b9648f25919fa112786f8e4b2b5b8cadc9112ecdf41f6 SHA512 2ca39fb6413b4c6fa8026f67b3e46ccfd65043c07d6a3ac678bc0ad6b4855a2e370fe51105d4d07bfe9ca6c10936650848ef2d2d5e91c5445d8cf575fcc84121 | ||
DIST kapidox-5.69.0.tar.xz 397340 BLAKE2B ad406738dd4aa719189552602991403856914a12902e909b7ec5e3d235bcfd6b55727fa4207d4f7d9f8930a246a06863b9e9eb4271a208062092eaf6b6923382 SHA512 5bb049cc33a87ad71fe94f23d3b374d19798e19415d926d4339567224223fd11c7c50b5d8a7312e1ac6f3a7b99ede5d18110a72f1164ed0061dda93b2f7de71e | ||
DIST kapidox-5.70.0.tar.xz 158572 BLAKE2B 25b8deaec2ee02290b1eb5c24d85e9b2c66bc01cd073f415b11b46ea73aeb0ec2d44da8099291bad3c6f41b34504d118b89c55ba6f0de74fa6f66b85273022f6 SHA512 846d4b555808052f58d1bc073fe7f67c9bb7f1444950f50f019bde481de7c56e04a10661ce00335508cae252a3a73a15ae46addca2839bc59468e51a12e21b13 |
Oops, something went wrong.