Skip to content

Commit

Permalink
dev-python/python-dateutil: 2.7.4
Browse files Browse the repository at this point in the history
Signed-off-by: Sebastian Pipping <[email protected]>
Package-Manager: Portage-2.3.50, Repoman-2.3.11
  • Loading branch information
hartwork committed Oct 25, 2018
1 parent 7302c7d commit 7976fe3
Show file tree
Hide file tree
Showing 2 changed files with 51 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/python-dateutil/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST python-dateutil-2.6.1.tar.gz 241428 BLAKE2B 93b1d43dacdfbf528b085864b04231c
DIST python-dateutil-2.7.1.tar.gz 298061 BLAKE2B a6bc2a3bf83ff234ddc53db5a3353b19303dd9e0c6d2d702537643e134508f96ccc69b962fd957d4cc754b07cd24b3c3c2ce07becc0add7db925b841d6a32b5d SHA512 3dbadeac3dd22bf51279c4237df96a925ed4063384a82e756a41e314c216751f2c90f8909a20ba96fdb065966034e9c7e40c1ea152876ca733a2176893c4deb2
DIST python-dateutil-2.7.2.tar.gz 298000 BLAKE2B 4091108b125eb080809c74cdb53daa27973b2dc4b2c4f79eba2afb295fce7b6c21a8589d4643ad5af212900f55dc4139711929d5c7c4a2b094ac749d76125761 SHA512 b8fdc867aa67c4e5602bb3e9bf906dd4d32a6616fcdfd5f39d146d849a46d13c266bc9c2eae28490399fe608ba19dcb824d05ce96d556de07999449eaece7dfc
DIST python-dateutil-2.7.3.tar.gz 302871 BLAKE2B 8b6cff6f977d52b64665f33d10513a638addada91a00192eb1f522aa9b239d5fb051bff3cfb837871ea61d7ab69994cfe5b42bb3b00851b5f15368c26db06fd7 SHA512 6b9973fa7db69d931bc6e772201c67bb7bbfa693ba35484d34960bd7e6227f2a2343df814a9fdbbff253e750299c48e7cdb2a609bf4522595df8a7fc595784fd
DIST python-dateutil-2.7.4.tar.gz 302229 BLAKE2B e2a43d8587f895a9a72ca5ab5c18a5c471497c8f8e89459450219e9f5ecb55223f36f219d77df8da4c04d55fb5feb3a17f9a5c2318c077dac4307da7c0bd9645 SHA512 3b02b397e3138dc755f34a2f7a50464f96a73b7be1f335ce7da3fa99e6d59f34a0643dfb1c933d4ef4fbaab88364fab6e760e4b1e7040b8cbbfebdd75e7e9a4f
50 changes: 50 additions & 0 deletions dev-python/python-dateutil/python-dateutil-2.7.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,50 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )

inherit distutils-r1

DESCRIPTION="Extensions to the standard Python datetime module"
HOMEPAGE="
https://dateutil.readthedocs.org/
https://pypi.org/project/python-dateutil
https://github.com/dateutil/dateutil/
"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="test"

RDEPEND="
>=dev-python/six-1.5[${PYTHON_USEDEP}]
sys-libs/timezone-data
"
DEPEND="${RDEPEND}
dev-python/setuptools_scm[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/freezegun[${PYTHON_USEDEP}]
dev-python/hypothesis[${PYTHON_USEDEP}]
)
"

python_prepare_all() {
local PATCHES=(
"${FILESDIR}"/0001-zoneinfo-Get-timezone-data-from-system-tzdata.patch
)

# don't install zoneinfo tarball
sed -i '/package_data=/d' setup.py || die

distutils-r1_python_prepare_all
}

python_test() {
py.test -v || die "Tests failed under ${EPYTHON}"
}

0 comments on commit 7976fe3

Please sign in to comment.