Skip to content

Commit

Permalink
sci-electronics/klayout: Fix "error: throw will always call terminate…
Browse files Browse the repository at this point in the history
…()" (bug #612978)

Package-Manager: Portage-2.3.5, Repoman-2.3.2
Closes: gentoo#4267
  • Loading branch information
Peter-Levine authored and SoapGentoo committed Apr 16, 2017
1 parent 97ac77b commit 7ad2c40
Show file tree
Hide file tree
Showing 2 changed files with 37 additions and 1 deletion.
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
# Fixes "error: throw will always call terminate() [-Werror=terminate]". Gentoo bug 612978.

--- a/src/tlAssert.h.old
+++ b/src/tlAssert.h
@@ -27,6 +27,16 @@

#include "config.h"

+// For >=C++11, mark assertion_failed() with attribute [[noreturn]] and call std::terminate().
+// Or else, throw int(0) to tell the compiler that the assertion will not return.
+#if __cplusplus < 201103L
+#define ATTRIB_ASSERT KLAYOUT_DLL
+#define END_ASSERT throw int(0)
+#else
+#define ATTRIB_ASSERT [[noreturn]] KLAYOUT_DLL
+#define END_ASSERT std::terminate()
+#endif
+
namespace tl
{

@@ -34,10 +44,10 @@
* @brief The corresponding assert macro
*/

-KLAYOUT_DLL void assertion_failed (const char *filename, unsigned int line, const char *condition);
+ATTRIB_ASSERT void assertion_failed (const char *filename, unsigned int line, const char *condition);

// the throw int(0) instruction will tell the compiler that the assertion will not return
-#define tl_assert(COND) if (!(COND)) { tl::assertion_failed (__FILE__, __LINE__, #COND); throw int(0); }
+#define tl_assert(COND) if (!(COND)) { tl::assertion_failed (__FILE__, __LINE__, #COND); END_ASSERT; }

} // namespace tl

4 changes: 3 additions & 1 deletion sci-electronics/klayout/klayout-0.24.9.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5
Expand Down Expand Up @@ -27,6 +27,8 @@ RDEPEND="
DEPEND="${RDEPEND}"

all_ruby_prepare() {
epatch "${FILESDIR}"/${P}-c++11-no-throw-in-destuctor.patch

# now we generate the stub build configuration file for the home-brew build system
cp "${FILESDIR}/${PN}-0.23.10-Makefile.conf.linux-gentoo" "${S}/config/Makefile.conf.linux-gentoo" || die
}
Expand Down

0 comments on commit 7ad2c40

Please sign in to comment.