Skip to content

Commit

Permalink
mate-extra/mate-screensaver: Version bump to 1.14.1
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0
  • Loading branch information
NP-Hardass authored and mudler committed Nov 21, 2016
1 parent 3282d4f commit 7b83c72
Show file tree
Hide file tree
Showing 2 changed files with 120 additions and 0 deletions.
1 change: 1 addition & 0 deletions mate-extra/mate-screensaver/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST mate-screensaver-1.10.2.tar.xz 4888108 SHA256 19b79dc4b4b5a6dcd407daf5b8f310b6da8210445a6271d265458e79a58d539d SHA512 474d0db2aa42bce2ab6185badc8a10d921ec1450d2b873c167047e7f29d5f9d5dd3ef608f8a9d232221fc4be82171343cba45c5598cb745b38d85f5baf900f47 WHIRLPOOL 7ba45db491251942ce0373a80a47268a0c2c9f5315495d3621174a07b580722a785193da7f2a47bf0c65f22312c91813480205e1ad9117b1d36c04fbab5994ff
DIST mate-screensaver-1.12.0.tar.xz 4868924 SHA256 198cb5159bd6321c90e0069115909be52eb4382de25cb9c4ba33fa29e3fdc693 SHA512 01bdef496560eb8e9118b0ff66863568aaa6df872e7947d0a92fe9fcb1d305618b28928ea95c65a3367e3e4e79e9bdab7a8266287c8e3db2a5210b955d412c8d WHIRLPOOL 2cf7db69a1609cd785eef50c070743722cd190633a3b34b4cc87c11aa46164106a785dd027e728121e18a671c1b36cd5d20d30f232011a1ac6a4ff5f37953dc4
DIST mate-screensaver-1.14.1.tar.xz 4912772 SHA256 e903932d9e3b01b527abf8b4957d68797afd1b6b035854bcbbd5e4e6934da5c6 SHA512 28b5834450da9d7d2fd3a77504f244e69212e751435bd41a957f30a5231db312dba37ee39442c63a40098bb3d1e1fade81ea423f9d59b29fc5d1201522d1d8f8 WHIRLPOOL c39b1f2ee9bb3082a038c765c9c007c500470ab4c73d5221d3d5e49de9c54fa950e9eeabec9f02f4791f7ade984076574ad8c25357af43bf5ff39d3623cff74b
119 changes: 119 additions & 0 deletions mate-extra/mate-screensaver/mate-screensaver-1.14.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,119 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit mate multilib readme.gentoo-r1

if [[ ${PV} != 9999 ]]; then
KEYWORDS="~amd64 ~arm ~x86"
fi

DESCRIPTION="Replaces xscreensaver, integrating with the MATE desktop"
LICENSE="GPL-2"
SLOT="0"

IUSE="X debug consolekit gtk3 kernel_linux libnotify opengl pam systemd"

DOC_CONTENTS="
Information for converting screensavers is located in
/usr/share/doc/${PF}/xss-conversion.txt*
"

COMMON_DEPEND="
>=dev-libs/dbus-glib-0.71:0
>=dev-libs/glib-2.36:2
gnome-base/dconf:0
>=mate-base/libmatekbd-1.7.1[gtk3(-)=]
>=mate-base/mate-desktop-1.9.4[gtk3(-)=]
>=mate-base/mate-menus-1.6
>=sys-apps/dbus-0.30:0
>=x11-libs/gdk-pixbuf-2.14:2
>=x11-libs/libX11-1:0
x11-libs/cairo:0
x11-libs/libXext:0
x11-libs/libXrandr:0
x11-libs/libXScrnSaver:0
x11-libs/libXxf86misc:0
x11-libs/libXxf86vm:0
x11-libs/libxklavier:0
x11-libs/pango:0
virtual/libintl:0
consolekit? ( sys-auth/consolekit:0 )
!gtk3? ( >=x11-libs/gtk+-2.24:2 )
gtk3? ( >=x11-libs/gtk+-3.0:3 )
libnotify? ( >=x11-libs/libnotify-0.7:0 )
opengl? ( virtual/opengl:0 )
pam? ( gnome-base/gnome-keyring:0 virtual/pam:0 )
!pam? ( kernel_linux? ( sys-apps/shadow:0 ) )
systemd? ( sys-apps/systemd:0= )
!!<gnome-extra/gnome-screensaver-3:0"

RDEPEND="${COMMON_DEPEND}
>=mate-base/mate-session-manager-1.6"

DEPEND="${COMMON_DEPEND}
>=dev-util/intltool-0.50.1:*
sys-devel/gettext:*
x11-proto/randrproto:0
x11-proto/scrnsaverproto:0
x11-proto/xextproto:0
x11-proto/xf86miscproto:0
virtual/pkgconfig:*"

src_configure() {
mate_src_configure \
--enable-locking \
--with-kbd-layout-indicator \
--with-xf86gamma-ext \
--with-xscreensaverdir=/usr/share/xscreensaver/config \
--with-xscreensaverhackdir=/usr/$(get_libdir)/misc/xscreensaver \
--with-gtk=$(usex gtk3 3.0 2.0) \
$(use_with X x) \
$(use_with consolekit console-kit) \
$(use_with libnotify) \
$(use_with opengl libgl) \
$(use_with systemd) \
$(use_enable debug) \
$(use_enable pam)
}

src_install() {
mate_src_install

# Install the conversion script in the documentation.
dodoc "${S}"/data/migrate-xscreensaver-config.sh
dodoc "${S}"/data/xscreensaver-config.xsl
dodoc "${FILESDIR}"/xss-conversion.txt

# Non PAM users will need this suid to read the password hashes.
# OpenPAM users will probably need this too when
# http://bugzilla.gnome.org/show_bug.cgi?id=370847
# is fixed.
if ! use pam ; then
fperms u+s /usr/libexec/mate-screensaver-dialog
fi

readme.gentoo_create_doc
}

pkg_postinst() {
mate_pkg_postinst

if has_version "<x11-base/xorg-server-1.5.3-r4" ; then
ewarn "You have a too old xorg-server installation. This will cause"
ewarn "mate-screensaver to eat up your CPU. Please consider upgrading."
echo
fi

if has_version "<x11-misc/xscreensaver-4.22-r2" ; then
ewarn "You have xscreensaver installed, you probably want to disable it."
ewarn "To prevent a duplicate screensaver entry in the menu, you need to"
ewarn "build xscreensaver with -gnome in the USE flags."
ewarn "echo \"x11-misc/xscreensaver -gnome\" >> /etc/portage/package.use"
echo
fi

readme.gentoo_print_elog
}

0 comments on commit 7b83c72

Please sign in to comment.