Skip to content

Commit

Permalink
gnome-base/gvfs: Version bump to 1.48.1
Browse files Browse the repository at this point in the history
Signed-off-by: Matt Turner <[email protected]>
  • Loading branch information
mattst88 committed Apr 30, 2021
1 parent 94a6d31 commit 7bbdcff
Show file tree
Hide file tree
Showing 2 changed files with 141 additions and 0 deletions.
1 change: 1 addition & 0 deletions gnome-base/gvfs/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST gvfs-1.44.1.tar.xz 1222040 BLAKE2B 5a412395cf0edbdb78aea43eabd4fc0ec68f53b9f681cd6181b1c2ee09a01f90e024f75d44302eefdd9d3888512ec4fe672125eec3c79fe691d0f66dacde7bce SHA512 d936e70e6daa6a7494e5cc333a53afe82b601e34e2e54b207d9a4aefdc35dd068997832be750a6857144a48fa37065cb7e6b25378952007b06988ad07dfc6006
DIST gvfs-1.48.0.tar.xz 1225852 BLAKE2B b1d9554183c1c79a02bd36f04399ee73ad6590b01e8a909c31fd6806f1929132e3146b24cd5caa9e0d703ac54861179c9bc7bb1021ffe263be90e2f833ed2738 SHA512 fe57da85c5e7b6dc8b2ffa69f5f8f1e45e307a05c787c5eee4afdfac82fd796ec9f319eb0615622f72286327cbb5d169abcf35c6d21d4f8293cbf70e2a941e17
DIST gvfs-1.48.1.tar.xz 1225916 BLAKE2B f2c46d94ba68065fcaef93cfaf25d5d6cc2fbbf4c1842452d30a9fec2ac5259b440fe569411cf3a874d3464f8d001ef2d04a705230a21b381ff1c3abe9c0f16e SHA512 19a642bcfce37eaa0d2d9f509fed6c67abfea0f79f5be9a17074d20e9ba71252a13583a2e08de88718cb141c5e79e34c84c765c87160351fe21291a8f88abe8c
140 changes: 140 additions & 0 deletions gnome-base/gvfs/gvfs-1.48.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,140 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit gnome.org gnome2-utils meson systemd xdg

DESCRIPTION="Virtual filesystem implementation for GIO"
HOMEPAGE="https://wiki.gnome.org/Projects/gvfs"

LICENSE="LGPL-2+"
SLOT="0"

IUSE="afp archive bluray cdda elogind fuse google gnome-keyring gnome-online-accounts gphoto2 +http ios mtp nfs policykit samba systemd test +udev udisks zeroconf"
RESTRICT="!test? ( test )"
# elogind/systemd only relevant to udisks (in v1.38.1)
REQUIRED_USE="
?? ( elogind systemd )
cdda? ( udev )
google? ( gnome-online-accounts )
gphoto2? ( udev )
mtp? ( udev )
udisks? ( udev )
"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"

RDEPEND="
>=dev-libs/glib-2.65.1:2
>=gnome-base/gsettings-desktop-schemas-3.33.0
afp? ( >=dev-libs/libgcrypt-1.2.2:0= )
sys-apps/dbus
app-crypt/gcr:=
policykit? (
>=sys-auth/polkit-0.114
sys-libs/libcap
)
http? (
dev-libs/libxml2:2
>=net-libs/libsoup-2.58.0:2.4
)
zeroconf? ( >=net-dns/avahi-0.6[dbus] )
udev? ( >=dev-libs/libgudev-147:= )
fuse? ( >=sys-fs/fuse-3.0.0:3 )
udisks? ( >=sys-fs/udisks-1.97:2 )
systemd? ( >=sys-apps/systemd-206:0= )
elogind? ( >=sys-auth/elogind-229:0= )
ios? (
>=app-pda/libimobiledevice-1.2:=
>=app-pda/libplist-1:=
)
gnome-online-accounts? ( >=net-libs/gnome-online-accounts-3.17.1:= )
gnome-keyring? ( app-crypt/libsecret )
bluray? ( media-libs/libbluray:= )
mtp? (
virtual/libusb:1
>=media-libs/libmtp-1.1.15
)
samba? ( >=net-fs/samba-4[client] )
archive? ( app-arch/libarchive:= )
cdda? (
dev-libs/libcdio:0=
>=dev-libs/libcdio-paranoia-0.78.2
)
google? ( >=dev-libs/libgdata-0.18.0:=[crypt,gnome-online-accounts] )
gphoto2? ( >=media-libs/libgphoto2-2.5.0:= )
nfs? ( >=net-fs/libnfs-1.9.8 )
net-misc/openssh
"
DEPEND="${RDEPEND}"
BDEPEND="
dev-util/glib-utils
app-text/docbook-xsl-stylesheets
app-text/docbook-xml-dtd:4.2
dev-libs/libxslt
>=sys-devel/gettext-0.19.8
virtual/pkgconfig
dev-util/gdbus-codegen
test? ( dev-libs/libgdata )
"

src_configure() {
local enable_logind="false"
if use systemd || use elogind; then
enable_logind="true"
fi

local enable_gcrypt="false"
if use afp; then # currently HAVE_GCRYPT and linkage only used with afp; check it on big bumps (grep for HAVE_GCRYPT and enable_gcrypt); adjust depends if changes
enable_gcrypt="true"
fi

local enable_libusb="false"
if use mtp; then # currently HAVE_LIBUSB and linkage only used with mtp; check it on big bumps (grep for HAVE_LIBUSB and enable_libusb); adjust depends if changes
enable_libusb="true"
fi

local emesonargs=(
-Dsystemduserunitdir="$(systemd_get_userunitdir)"
-Dtmpfilesdir="${EPREFIX}"/usr/lib/tmpfiles.d
$(meson_use policykit admin)
$(meson_use ios afc)
$(meson_use afp)
$(meson_use archive)
$(meson_use cdda)
$(meson_use zeroconf dnssd)
$(meson_use gnome-online-accounts goa)
$(meson_use google)
$(meson_use gphoto2)
$(meson_use http)
$(meson_use mtp)
$(meson_use nfs)
-Dsftp=true
$(meson_use samba smb)
$(meson_use udisks udisks2)
$(meson_use bluray)
$(meson_use fuse)
-Dgcr=true
-Dgcrypt=${enable_gcrypt}
$(meson_use udev gudev)
$(meson_use gnome-keyring keyring)
-Dlogind=${enable_logind}
-Dlibusb=${enable_libusb}
-Ddevel_utils=false # wouldn't install any of it as of 1.38.1; some tests need it, but they aren't automated tests in v1.38.1
-Dinstalled_tests=false
-Dman=true
)
meson_src_configure
}

pkg_postinst() {
xdg_pkg_postinst
gnome2_schemas_update
gnome2_giomodule_cache_update
}

pkg_postrm() {
xdg_pkg_postrm
gnome2_schemas_update
gnome2_giomodule_cache_update
}

0 comments on commit 7bbdcff

Please sign in to comment.