Skip to content

Commit

Permalink
dev-db/pgpool2: Bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
patricklauer committed Feb 22, 2017
1 parent 255dbcb commit 7e38ca2
Show file tree
Hide file tree
Showing 3 changed files with 204 additions and 0 deletions.
2 changes: 2 additions & 0 deletions dev-db/pgpool2/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,3 @@
DIST pgpool-II-3.5.2.tar.gz 2227075 SHA256 5d29fd9c30141bfdaf15b51c7878766178e5df42fa5e160d0f7df2824d26104f SHA512 dd7268bce0019de30dfad01a8600af798127a4c2cc818e6f85ba30289e97c253d6faa392734d85ccbc97be3f04458c12af1bba541e5b8f3d2ee8268432e01d1a WHIRLPOOL 22939c855919b8399c1129ff4622eae159141e9bf05cc36aca456bfd582c7ab0dc7ec87df5ea96d7101f438e89bf4e06f46a5f63cfde22e505d0a3965c0496fc
DIST pgpool-II-3.5.5.tar.gz 2243184 SHA256 8fa1ccf13ff4f7c1ab0f6d523090444f65d78923de11061b5027eb5d58318491 SHA512 f77888cbc5e2c15ae1035ee3a1965d4fd3d02cdfd5810c6c656456eaa0d73dae7471906bdf0848607723633da5b8d02145559b767735bcc9b7e4023b1d59efed WHIRLPOOL 5f4d4d9c3f6478b9b3ecda311c571e1f54805a07aa505acd32fbfb8fb2790183b732d6f86843a2b6614c74565efad7f9b3d962281cd2b1d23b54515448a1c84a
DIST pgpool-II-3.6.1.tar.gz 2539510 SHA256 244f99a70198b5861a63b2fe3e44ac39d2819f6aa6497f62958c6afa2750d94c SHA512 9d4f0ecec3cf7478c7c4cd5cb1aa75614edca204d11b145f145d752c24bed7f7f4ea2880f6a3f9833aee0b5f428e8cf36e2f91bdef2f6065fb98019df546469a WHIRLPOOL 9a307a63e9179ecfc7a52d1f056d47f09543bf4e378fa0090cdaf90d141c70e89323b4cfcbc9bbd9fa2422ff76bea592f189bea78915445fb1779ce9089ef6e1
102 changes: 102 additions & 0 deletions dev-db/pgpool2/pgpool2-3.5.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,102 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

MY_P="${PN/2/-II}-${PV}"

inherit eutils user

DESCRIPTION="Connection pool server for PostgreSQL"
HOMEPAGE="http://www.pgpool.net/"
SRC_URI="http://www.pgpool.net/download.php?f=${MY_P}.tar.gz -> ${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0"

KEYWORDS="~amd64 ~x86"

IUSE="doc memcached pam ssl static-libs"

RDEPEND="
dev-db/postgresql:=
memcached? ( dev-libs/libmemcached )
pam? ( sys-auth/pambase )
ssl? ( dev-libs/openssl:= )
"
DEPEND="${RDEPEND}
sys-devel/bison
!!dev-db/pgpool
"

S=${WORKDIR}/${MY_P}

pkg_setup() {
enewgroup postgres 70
enewuser pgpool -1 -1 -1 postgres

# We need the postgres user as well so we can set the proper
# permissions on the sockets without getting into fights with
# PostgreSQL's initialization scripts.
enewuser postgres 70 /bin/bash /var/lib/postgresql postgres
}

src_prepare() {
epatch "${FILESDIR}/pgpool2-3.5.0-path-fix.patch"

local pg_config_manual="$(pg_config --includedir)/pg_config_manual.h"
local pgsql_socket_dir=$(grep DEFAULT_PGSOCKET_DIR "${pg_config_manual}" | \
sed 's|.*\"\(.*\)\"|\1|g')
local pgpool_socket_dir="$(dirname $pgsql_socket_dir)/pgpool"

sed "s|@PGSQL_SOCKETDIR@|${pgsql_socket_dir}|g" \
-i src/sample/pgpool.conf.sample* src/include/pool.h || die

sed "s|@PGPOOL_SOCKETDIR@|${pgpool_socket_dir}|g" \
-i src/sample/pgpool.conf.sample* src/include/pool.h || die
}

src_configure() {
local myconf
use memcached && \
myconf="--with-memcached=\"${EROOT%/}/usr/include/libmemcached\""
use pam && myconf+=' --with-pam'

econf \
--disable-rpath \
--sysconfdir="${EROOT%/}/etc/${PN}" \
$(use_with ssl openssl) \
$(use_enable static-libs static) \
${myconf}
}

src_compile() {
emake

emake -C src/sql
}

src_install() {
emake DESTDIR="${D}" install

emake DESTDIR="${D}" -C src/sql install

newinitd "${FILESDIR}/${PN}.initd" ${PN}
newconfd "${FILESDIR}/${PN}.confd" ${PN}

# Documentation
dodoc NEWS TODO
use doc && dohtml -r doc/*

# Examples and extras
# mv some files that get installed to /usr/share/pgpool-II so that
# they all wind up in the same place
mv "${ED%/}/usr/share/${PN/2/-II}" "${ED%/}/usr/share/${PN}" || die
into "/usr/share/${PN}"
dobin doc/{pgpool_remote_start,basebackup.sh}
insinto "/usr/share/${PN}"
doins doc/recovery.conf.sample

# One more thing: Evil la files!
find "${ED}" -name '*.la' -exec rm -f {} +
}
100 changes: 100 additions & 0 deletions dev-db/pgpool2/pgpool2-3.6.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,100 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

MY_P="${PN/2/-II}-${PV}"

inherit eutils user

DESCRIPTION="Connection pool server for PostgreSQL"
HOMEPAGE="http://www.pgpool.net/"
SRC_URI="http://www.pgpool.net/download.php?f=${MY_P}.tar.gz -> ${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0"

KEYWORDS="~amd64 ~x86"

IUSE="doc memcached pam ssl static-libs"

RDEPEND="
dev-db/postgresql:=
memcached? ( dev-libs/libmemcached )
pam? ( sys-auth/pambase )
ssl? ( dev-libs/openssl:= )
"
DEPEND="${RDEPEND}
sys-devel/bison
!!dev-db/pgpool
"

S=${WORKDIR}/${MY_P}

pkg_setup() {
enewgroup postgres 70
enewuser pgpool -1 -1 -1 postgres

# We need the postgres user as well so we can set the proper
# permissions on the sockets without getting into fights with
# PostgreSQL's initialization scripts.
enewuser postgres 70 /bin/bash /var/lib/postgresql postgres
}

src_prepare() {
epatch "${FILESDIR}/pgpool2-3.5.0-path-fix.patch"

local pg_config_manual="$(pg_config --includedir)/pg_config_manual.h"
local pgsql_socket_dir=$(grep DEFAULT_PGSOCKET_DIR "${pg_config_manual}" | \
sed 's|.*\"\(.*\)\"|\1|g')
local pgpool_socket_dir="$(dirname $pgsql_socket_dir)/pgpool"

sed "s|@PGSQL_SOCKETDIR@|${pgsql_socket_dir}|g" \
-i src/sample/pgpool.conf.sample* src/include/pool.h || die

sed "s|@PGPOOL_SOCKETDIR@|${pgpool_socket_dir}|g" \
-i src/sample/pgpool.conf.sample* src/include/pool.h || die
}

src_configure() {
local myconf
use memcached && \
myconf="--with-memcached=\"${EROOT%/}/usr/include/libmemcached\""
use pam && myconf+=' --with-pam'

econf \
--disable-rpath \
--sysconfdir="${EROOT%/}/etc/${PN}" \
$(use_with ssl openssl) \
$(use_enable static-libs static) \
${myconf}
}

src_compile() {
emake

emake -C src/sql
}

src_install() {
emake DESTDIR="${D}" install

emake DESTDIR="${D}" -C src/sql install

newinitd "${FILESDIR}/${PN}.initd" ${PN}
newconfd "${FILESDIR}/${PN}.confd" ${PN}

# Documentation
dodoc NEWS TODO
use doc && dohtml -r doc/*

# Examples and extras
# mv some files that get installed to /usr/share/pgpool-II so that
# they all wind up in the same place
mv "${ED%/}/usr/share/${PN/2/-II}" "${ED%/}/usr/share/${PN}" || die
into "/usr/share/${PN}"
dobin src/sample/pgpool_remote_start

# One more thing: Evil la files!
find "${ED}" -name '*.la' -exec rm -f {} +
}

0 comments on commit 7e38ca2

Please sign in to comment.