Skip to content

Commit

Permalink
app-editors/okteta: 0.25.4 version bump
Browse files Browse the repository at this point in the history
Signed-off-by: Andreas Sturmlechner <[email protected]>
Package-Manager: Portage-2.3.51, Repoman-2.3.11
  • Loading branch information
a17r committed Oct 9, 2018
1 parent c0458e7 commit 7face3b
Show file tree
Hide file tree
Showing 2 changed files with 67 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-editors/okteta/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST okteta-0.25.3.tar.xz 950956 BLAKE2B d177db59b5327f4e75157c99fdac2191de9a7ef63433635ccf8f11ef4dc4ff201942c9f68383d720b18c26a9e7335bc1181ea4f0e36491b34b27e6c7dc469c9e SHA512 f27b0c2ca3c5f1ad838af847e08c53c8f8f3c386921bd2e0d5e833902659477196e6c6b72a428443e2be9013928c2151c1889ef33d59404815a34d81560ef2a7
DIST okteta-0.25.4.tar.xz 950344 BLAKE2B 3a3daf5cdb9e349e145a22afe836c78e18972e1f984472267cd182630b8f8132e10efb49cbc9fac40768aef4dadbb678afa26eb965642f07f407030f15b71dbd SHA512 d9887a90efbad3bb2caa0d3bb12af27708b77d54a90cd0da82eace7ea6dfc2efbcea3d7dc720bf4a088a823a8ed9edf75ab1c3680aa6d99c640d5c9e4c385e16
66 changes: 66 additions & 0 deletions app-editors/okteta/okteta-0.25.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,66 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

KDE_HANDBOOK="forceoptional"
KDE_TEST="true"
VIRTUALX_REQUIRED="test"
inherit kde5

if [[ ${KDE_BUILD_TYPE} = release ]]; then
SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
KEYWORDS="~amd64 ~x86"
fi

DESCRIPTION="Hex editor by KDE"
HOMEPAGE="https://www.kde.org/applications/utilities/okteta
https://utils.kde.org/projects/okteta"
IUSE="crypt designer"

DEPEND="
$(add_frameworks_dep kbookmarks)
$(add_frameworks_dep kcmutils)
$(add_frameworks_dep kcodecs)
$(add_frameworks_dep kcompletion)
$(add_frameworks_dep kconfig)
$(add_frameworks_dep kconfigwidgets)
$(add_frameworks_dep kcoreaddons)
$(add_frameworks_dep kcrash)
$(add_frameworks_dep kdbusaddons)
$(add_frameworks_dep ki18n)
$(add_frameworks_dep kiconthemes)
$(add_frameworks_dep kio)
$(add_frameworks_dep kjobwidgets)
$(add_frameworks_dep knewstuff)
$(add_frameworks_dep kparts)
$(add_frameworks_dep kservice)
$(add_frameworks_dep kwidgetsaddons)
$(add_frameworks_dep kxmlgui)
$(add_qt_dep qtdeclarative)
$(add_qt_dep qtgui)
$(add_qt_dep qtnetwork)
$(add_qt_dep qtprintsupport)
$(add_qt_dep qtscript 'scripttools')
$(add_qt_dep qtwidgets)
$(add_qt_dep qtxml)
crypt? ( app-crypt/qca:2[qt5(+)] )
designer? ( $(add_qt_dep designer) )
"
RDEPEND="${DEPEND}"

src_configure() {
local mycmakeargs=(
-DOMIT_EXAMPLES=ON
$(cmake-utils_use_find_package crypt Qca-qt5)
-DBUILD_DESIGNERPLUGIN=$(usex designer)
)

kde5_src_configure
}

src_test() {
local myctestargs=( -j1 )

kde5_src_test
}

0 comments on commit 7face3b

Please sign in to comment.